locked
Not able to log in to the SharePoint site RRS feed

  • Question

  • Hi All,

    I have SharePoint site (WSS 3.0) hosted in DMZ zone. I have created a site and extended it to Forms Authenticated site (Extranet) and hence I have two sites now in the IIS. One is windows authentication site and the other is Forms authenticated site (using asp.net membership provider tool).

    I am able to log in with the forms authentication site but when I log in to the Windows authenticated site using windows account, I am not able to log in even on using the correct user name and password. It is continuously prompting for password and when I give cancel, I am getting "you are not authorized to view the site"

    Any suggestions would be greatly appreciated.

     


    Cheers! Maruthu | http://sharepoint-works.blogspot.com

    Thursday, October 11, 2012 4:15 PM

Answers

  • Sounds like the loopback issue. See KB 896861 and follow method 1. You'll need to enter the hostname that the users are using when accessing with Windows authentication. For example: if the url is http://sharepoint.example.com, you need to enter: sharepoint.example.com as a value in the BackConnectionHostNames key.

    For reference, here are the steps:

    1. Set the
      <samp>DisableStrictNameChecking</samp>
      registry entry to 1. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
      281308 Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name
    2. Click Start, click Run, type regedit, and then click OK.
    3. In Registry Editor, locate and then click the following registry key:
      <samp>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0</samp>
    4. Right-click MSV1_0, point to New, and then click Multi-String Value.
    5. Type BackConnectionHostNames, and then press ENTER.
    6. Right-click BackConnectionHostNames, and then click Modify.
    7. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK.
    8. Quit Registry Editor, and then restart the IISAdmin service.

    Jason Warren
    Infrastructure Architect


    • Edited by Jason Warren Thursday, October 11, 2012 6:01 PM
    • Marked as answer by Maruthachalam Thursday, March 27, 2014 2:17 PM
    Thursday, October 11, 2012 5:59 PM

All replies

  • Sounds like the loopback issue. See KB 896861 and follow method 1. You'll need to enter the hostname that the users are using when accessing with Windows authentication. For example: if the url is http://sharepoint.example.com, you need to enter: sharepoint.example.com as a value in the BackConnectionHostNames key.

    For reference, here are the steps:

    1. Set the
      <samp>DisableStrictNameChecking</samp>
      registry entry to 1. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
      281308 Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name
    2. Click Start, click Run, type regedit, and then click OK.
    3. In Registry Editor, locate and then click the following registry key:
      <samp>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0</samp>
    4. Right-click MSV1_0, point to New, and then click Multi-String Value.
    5. Type BackConnectionHostNames, and then press ENTER.
    6. Right-click BackConnectionHostNames, and then click Modify.
    7. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK.
    8. Quit Registry Editor, and then restart the IISAdmin service.

    Jason Warren
    Infrastructure Architect


    • Edited by Jason Warren Thursday, October 11, 2012 6:01 PM
    • Marked as answer by Maruthachalam Thursday, March 27, 2014 2:17 PM
    Thursday, October 11, 2012 5:59 PM
  • Yes, I agree with Jason it might be a loop back issue.

    Add backconnectionhostnames

    Friday, October 12, 2012 6:07 AM