none
Why can't I see pictures on some websites - IE 11? RRS feed

  • Question

  • Why can't I see pictures on some websites - IE 11?

    For eg: msn 

    This use  to work but stopped last month, where as I did not made any change in GPO.

    I tried adding it to compatibility list but no help, Advanced - multimedia -show picture is enabled.

    Thanks in Advance

    Sunday, July 19, 2015 7:01 AM

Answers

  • Hi Beadmin,

    there was a similar question to yours here a few weeks back, for the MSN US site. (please include the full address of any websites you are having problems with your questions... MSN has different web sites for different countries... I tried msn.id but that was nadda.. silly me... I always get id and in mixed up.. http://in.msn.com/ redirects to http://www.msn.com/en-in)

    anyway I visited www.msn.com/en-in and did some tests... the same issue is present there also

    SEC7118: XMLHttpRequest for http://otf.msn.com/c.gif? required Cross Origin Resource Sharing (CORS).
    File: en-in

    this is being caused by the way the site has been programmed and the assumptions that the developers have made. Ultimately Changes have to be made by the MSN developers, who are outside the scope of these public forums (I do not work for nor represent MS). MSN is a separate identity to MSFT.

    Now, there is a short term fix that will get some of the images to display.....and it may not work at all on other msn sites in other countries... I would recommend that you wait until the programmers find a solution...(it should elevate in importance now that more ppl are reporting the issue).

    Tools>Internet Options>Security tab, Trusted Sites icon>'Sites' button.

    add

    *.msn.com to your trusted sites list. This will put all msn sub domains in the same security zone (trusted).

    BUT

    this fix will cause problems with other msn, bing and Microsoft sites as they all use a CSO (common sign on) with your live id...

    Rather than tweaking your IE security settings for a short term fix I recommend that you wait it out until the issue is fixed on the server side.

    Regards.


    Rob^_^

    • Marked as answer by Beadmin Monday, July 20, 2015 8:10 AM
    Monday, July 20, 2015 12:52 AM

All replies

  • Hi Beadmin,

    there was a similar question to yours here a few weeks back, for the MSN US site. (please include the full address of any websites you are having problems with your questions... MSN has different web sites for different countries... I tried msn.id but that was nadda.. silly me... I always get id and in mixed up.. http://in.msn.com/ redirects to http://www.msn.com/en-in)

    anyway I visited www.msn.com/en-in and did some tests... the same issue is present there also

    SEC7118: XMLHttpRequest for http://otf.msn.com/c.gif? required Cross Origin Resource Sharing (CORS).
    File: en-in

    this is being caused by the way the site has been programmed and the assumptions that the developers have made. Ultimately Changes have to be made by the MSN developers, who are outside the scope of these public forums (I do not work for nor represent MS). MSN is a separate identity to MSFT.

    Now, there is a short term fix that will get some of the images to display.....and it may not work at all on other msn sites in other countries... I would recommend that you wait until the programmers find a solution...(it should elevate in importance now that more ppl are reporting the issue).

    Tools>Internet Options>Security tab, Trusted Sites icon>'Sites' button.

    add

    *.msn.com to your trusted sites list. This will put all msn sub domains in the same security zone (trusted).

    BUT

    this fix will cause problems with other msn, bing and Microsoft sites as they all use a CSO (common sign on) with your live id...

    Rather than tweaking your IE security settings for a short term fix I recommend that you wait it out until the issue is fixed on the server side.

    Regards.


    Rob^_^

    • Marked as answer by Beadmin Monday, July 20, 2015 8:10 AM
    Monday, July 20, 2015 12:52 AM
  • Thanks for your reply... I would wait for MSN to fix this issue.

    today I have also face similar issue while making on-line payments, no graphics were displayed above VISA /MASTER  OR AMERICAN EX ..  Is that also related or should I try something else. 

    Monday, July 20, 2015 8:13 AM
  • Hi,

    If you can provide the website address we can have a look. ^_^

    Post addition: If the website page is using https eg. https://paypal.com and images aren't appearing then first check Internet Options>Advanced tab>check "Block unsecured images with other mixed content".... and disable any Toolbar addons you have running on your browser (some add content to the current web page).

    The most secure method for banking and online transactions is InPrivate browsing (Tools>In Private browsing).. which runs IE without addons and without cookies (so you have to re-enter your credentials each time your visit while in InPrivate)... Most banking sites require verification each time, so your Formfiller addons do not work anyway. I keep my financial site passwords in a small book locked away in a drawer.

    or

    First check that Tracking Protection or ActiveX filtering is not turned on for the current site. I can't post a screen shot here at the moment, but if any scripts or controls (content) is blocked by ActiveX Filtering or Tracking Protection (find them under the tools menu), a blue circle with a line through it will appear on the rhs of the browsers address bar... double click it to display the options to turn it on/off. You can find out more about ActiveX filtering and Tracking protection from the Help>Internet Explorer Help menu.... search for ActiveX filtering or Tracking protection.

    or

    If you have some web site programming skills

    first... set up the IE Dev tools to record error messages. Tools>Internet Options>Advanced tab>check "Always record developer console messages" (there is a slight overhead involved when switching this on)

    navigate to a web site, then press f12 to display the dev tool, select the console tab and any errors and warnings for blocked content will be listed in the console.... You can double click on an error or message item in the console to go to the MSDN documentation describing the error. Finding how to fix it is another exersize... web search on the error code and description.

    If you are on a company computer, your system administrators will manage what IE security zone settings and which websites are in each zone.

    If you are a home user on a non-domain network... I recommend that you don't place any websites in your Trusted zones list... It actually has lower integrity (allows unsigned ActiveX controls and applets for example). It is mainly used on enterprise networks where they know the website is using unsigned components, but they have commercial trust and the company that built the site is known to them...

    Sites requiring https (secure server connections) will work just as well in the Internet Zone(default zone)...Just so long as the lock icon is NOT red. (but green).

    The Restricted sites zone used to be where known 'bad' sites were placed. That method of blocking sites has been mostly superseded with the Smart Screen Filter (Tools>Smart Screen Filter)... make sure you have it turned on, and also that you have installed and activated an up-to-date anti-virus program...

    Generally, there is no need to tweak your IE security zone settings... commonly this is where users become bamboozled. Tools>Internet Options>Security tab, click "Reset all zones to default" to reset the zones to their factory defaults.

    You can determine which IE security zone a website maps to from the File>Properties menu in IE.

    Lastly we all know that we should do regular Windows Updates (Tools>Windows updates). These are issued the second Tuesday of each month... you can configure automatic updates from the WU control panel. You don't have to stop your work or play while they are being installed. (a reboot some time after they have completed may be required).


    Rob^_^


    Monday, July 20, 2015 9:08 AM
  • Thanks Rob for your time and explanation, This is awesome.
    Friday, July 24, 2015 6:30 AM