none
IE 11: Compatibility View settings keep getting resetted RRS feed

  • Question

  • Hello!

    I'm encountering a problem while using IE 11 via RDS (published desktop).

    I'm controling compatibility view settings in a GPO. There are listed some domains, but not "company.example.com"


    In "zone to site assignment" the domain "company.example.com" is listed with number 2, because trusted sites should not be listed in compatibility view.

    If i connect to my RDS desktop, IE displays "company.example.com" in compatibility view. A gpresult says, all GPOs are retrieved correctly.

    When i remove the entry, log off and log in again, it is displayed again.

    The registry in my RDS desktop displays the settings as they are set in GPO, so im very confused, where the compatibility view entry comes from and why it appears, after i deleted it.

    Tuesday, August 21, 2018 3:39 PM

Answers

  • Hi,

    type

    about:compat

    in the IE address bar to display the compatibility view lists.

    or

    Press f12>Emulation tab, it will tell your which Emulation mode is being used and how it was applied.

    eg. IE7 - User Compatibility View list, IE8 - Enterprise site mode lists.

    From your description, it sounds like you are Using the Machine key in GPO for your compatibility sites list, and have not deployed Enterprise Site Mode lists,

    OR

    You are using an iframe on an intranet website that links to a business partners website that you have mapped to your Trusted sites list.... ? IN this case, the embed iframe website INHERITS the Compatibility view of the top window (an intranet site that you are using GPO, IE settings or Enterprise Site Mode lists ).

    the about:compat and f12>Emulation tab should help you figure out why the outcome is not what you expected.

    Regards.


    Rob^_^

    • Marked as answer by Cpt.Captain Wednesday, August 22, 2018 10:00 AM
    Tuesday, August 21, 2018 9:47 PM
  • Hi Rob,

    thanks for your answer. It wasn't the direct solution for my problem, but it led me into the right direction.

    about:compat said the entry's origin is the local compatibility list (Compatibility List (local)).

    The local compatibility list isn't editet by the user himself, so i googled how you can manage it and found the registry key:

    HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation\ClearableListData\UserFilter

    which is managed in the GPO. So i edited the local compatibility list to the desired entries, extracted the hex value via registry and updated the value in the GPO.

    Now i'm getting the correct settings!


    • Marked as answer by Cpt.Captain Wednesday, August 22, 2018 10:00 AM
    • Edited by Cpt.Captain Wednesday, August 22, 2018 10:01 AM
    Wednesday, August 22, 2018 9:59 AM

All replies

  • Hi,

    type

    about:compat

    in the IE address bar to display the compatibility view lists.

    or

    Press f12>Emulation tab, it will tell your which Emulation mode is being used and how it was applied.

    eg. IE7 - User Compatibility View list, IE8 - Enterprise site mode lists.

    From your description, it sounds like you are Using the Machine key in GPO for your compatibility sites list, and have not deployed Enterprise Site Mode lists,

    OR

    You are using an iframe on an intranet website that links to a business partners website that you have mapped to your Trusted sites list.... ? IN this case, the embed iframe website INHERITS the Compatibility view of the top window (an intranet site that you are using GPO, IE settings or Enterprise Site Mode lists ).

    the about:compat and f12>Emulation tab should help you figure out why the outcome is not what you expected.

    Regards.


    Rob^_^

    • Marked as answer by Cpt.Captain Wednesday, August 22, 2018 10:00 AM
    Tuesday, August 21, 2018 9:47 PM
  • Hi Rob,

    thanks for your answer. It wasn't the direct solution for my problem, but it led me into the right direction.

    about:compat said the entry's origin is the local compatibility list (Compatibility List (local)).

    The local compatibility list isn't editet by the user himself, so i googled how you can manage it and found the registry key:

    HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation\ClearableListData\UserFilter

    which is managed in the GPO. So i edited the local compatibility list to the desired entries, extracted the hex value via registry and updated the value in the GPO.

    Now i'm getting the correct settings!


    • Marked as answer by Cpt.Captain Wednesday, August 22, 2018 10:00 AM
    • Edited by Cpt.Captain Wednesday, August 22, 2018 10:01 AM
    Wednesday, August 22, 2018 9:59 AM