locked
TOC Related questions RRS feed

  • Question

  • Hello Everyone,

    I have recently tried to generate a TOC in word 2010. Only problem is that I want to use my own custom styles instead of those 

    TOC1, TOC2, ....... etc.

    I noticed that if I go to:

    reference Tab >> Table Of Contents >> Insert Table of Contents >> modify button

    a new dialog with a title of: Style opens up, in it there are two disabled buttons: New and Delete, I am guessing that these are the buttons that will allow me to do exactly what I want, except that the two buttons are Disabled .

    Does anyone know why these buttons are disabled and better yet, what do I need to do in order to enable them?

    Any help would be very much appreciated

    Best Regards,

    Sunday, March 4, 2012 8:59 PM

Answers

  • Word always uses the styles TOC1, TOC2, etc. for a table of contents. You can modify these styles to suit your purpose (that's what the Modify... button is for), but you can't use other styles than TOC1, TOC2, ... in a table of contents.

    Regards, Hans Vogelaar

    • Marked as answer by Danielg271 Friday, March 9, 2012 1:25 PM
    Sunday, March 4, 2012 9:58 PM
  • "Danielg271" wrote in message news:cbc767cd-cada-4726-9432-97dc3eec79f5@communitybridge.codeplex.com...
    Hans,
     
    Thank you for your response. If that is the case, any idea what these buttons are there for? and how to enable them?
     
     
    The buttons you mention will be available if you access the Style dialog box by other means. For example, you can assign a keyboard shortcut to the FormatStyle command and run it. But note that you don’t really need to in recent versions of Word, because there are other ways to manage styles.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Danielg271 Friday, March 9, 2012 1:25 PM
    Tuesday, March 6, 2012 1:21 PM

All replies

  • Word always uses the styles TOC1, TOC2, etc. for a table of contents. You can modify these styles to suit your purpose (that's what the Modify... button is for), but you can't use other styles than TOC1, TOC2, ... in a table of contents.

    Regards, Hans Vogelaar

    • Marked as answer by Danielg271 Friday, March 9, 2012 1:25 PM
    Sunday, March 4, 2012 9:58 PM
  • Hans,

    Thank you for your response. If that is the case, any idea what these buttons are there for? and how to enable them?

    Tuesday, March 6, 2012 9:04 AM
  • "Danielg271" wrote in message news:cbc767cd-cada-4726-9432-97dc3eec79f5@communitybridge.codeplex.com...
    Hans,
     
    Thank you for your response. If that is the case, any idea what these buttons are there for? and how to enable them?
     
     
    The buttons you mention will be available if you access the Style dialog box by other means. For example, you can assign a keyboard shortcut to the FormatStyle command and run it. But note that you don’t really need to in recent versions of Word, because there are other ways to manage styles.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Danielg271 Friday, March 9, 2012 1:25 PM
    Tuesday, March 6, 2012 1:21 PM
  • Stefan,

    Thank you for your response.

    Forgive the question but, I don't think I quite understand how assigning a keyboard shortcut has the do with the availability of the mentioned buttons.

    Did you mean that if I were to assign a shortcut to FormatStyle command and hit it, it will pop up the style dialog with the buttons enabled?

    Thursday, March 8, 2012 9:16 PM
  • "Danielg271" wrote in message news:6ed2b90e-757c-47d8-b993-f4f687cd3443@communitybridge.codeplex.com...
    Stefan,
     
    Thank you for your response.
     
    Forgive the question but, I don't think I quite understand how assigning a keyboard shortcut has the do with the availability of the mentioned buttons.
     
    Did you mean that if I were to assign a shortcut to FormatStyle command and hit it, it will pop up the style dialog with the buttons enabled?
     
     
    Yes. Using a keyboard shortcut, or a macro, is the only way to access the old Style dialog box in Word 2007/2010, because it is not offered as a command that you can add to the Quick Access Toolbar.

    Stefan Blom, Microsoft Word MVP
    • Marked as answer by Danielg271 Friday, March 9, 2012 1:24 PM
    • Unmarked as answer by Danielg271 Friday, March 9, 2012 1:25 PM
    Thursday, March 8, 2012 10:56 PM
  • I see. Did it and worked.

    Thanks

    Friday, March 9, 2012 1:24 PM
  • On 2012-03-09 14:24, Danielg271 wrote:

    I see. Did it and worked.

    Thanks


     

    I'm glad I could help!

    Stefan Blom, Microsoft Word MVP
    Thursday, March 15, 2012 6:39 PM