none
filter-based outbound rule not applied RRS feed

  • Question

  • I've created an outbound filter-based rule in FIM 2010 R2 SP1 that doesn't seem to want to apply.  I set the outbound scoping filter to match on a single username (and will adjust it to match a broader set if I can get this to work).  If I preview a full sync on the FIM user object in the Sync Manager, the rule shows up as "Not Applied" under a provisioning summary (and correctly doesn't show up at all for other users).  I don't have any objects in the target MA (it's an empty SQL table).  I've got sync rule provisioning enabled and other rules that i have implemented with MPRs and workflows work fine, but I wanted to try a filter-based rule for simplicity in this situation.  It's currently set up to flow two simple string attributes.  Can anybody provide pointers as to how to troubleshoot why it's not applying?

    -Robert

    Thursday, December 12, 2013 5:18 PM

Answers

  • Robert, 

    You need to make sure the 'create resource in external system' checkbox is checked, and furthermore that there is an 'initial flow' attribute for your anchor.  This thread has a lot of good information (although they are using classic sync rules).

    http://social.technet.microsoft.com/Forums/en-US/1aa13147-e16c-4e99-a7da-76e3c9e8c10d/how-do-we-sync-fim-to-an-external-sql-?forum=ilm2

    David Wind's post about 3/5 of the way down explains the sync rule configuration that should work:

    Sync Rules called 'SQL user outbound'

    • data flow direction: outbound
    • scope: person - SQL MA - person
    • relationship: displayname - displayname
    • Outbound Sync:
    • displayname -> displayname
    • employeeID -> employeeID
    • sn -> surname
    • csObjectID -> dn (initial flow only)

    • Proposed as answer by Peter_Stapf Tuesday, December 17, 2013 8:53 AM
    • Marked as answer by Robert Rust Tuesday, December 17, 2013 4:31 PM
    Monday, December 16, 2013 9:53 PM

All replies

  • Hello,

    little late but maybe you still need help.

    Export Flows checks for the RelationShip Criteria, if that is not valid for the current object flow is not applied (got that many times in my environment in the early days).

    As you dont have Objects in the Target MA it seems to me that you want to have provisioning working, so you need at least one initial flow, otherwise provisioning wont work.

    Regards
    Peter


    Peter Stapf - Doeres AG - My blog: JustIDM.wordpress.com

    Monday, December 16, 2013 1:52 PM
  • Robert, 

    You need to make sure the 'create resource in external system' checkbox is checked, and furthermore that there is an 'initial flow' attribute for your anchor.  This thread has a lot of good information (although they are using classic sync rules).

    http://social.technet.microsoft.com/Forums/en-US/1aa13147-e16c-4e99-a7da-76e3c9e8c10d/how-do-we-sync-fim-to-an-external-sql-?forum=ilm2

    David Wind's post about 3/5 of the way down explains the sync rule configuration that should work:

    Sync Rules called 'SQL user outbound'

    • data flow direction: outbound
    • scope: person - SQL MA - person
    • relationship: displayname - displayname
    • Outbound Sync:
    • displayname -> displayname
    • employeeID -> employeeID
    • sn -> surname
    • csObjectID -> dn (initial flow only)

    • Proposed as answer by Peter_Stapf Tuesday, December 17, 2013 8:53 AM
    • Marked as answer by Robert Rust Tuesday, December 17, 2013 4:31 PM
    Monday, December 16, 2013 9:53 PM
  • The part I was missing was an "initial flow" attribute.  Silly error on my part.  Thanks!
    Tuesday, December 17, 2013 4:32 PM