none
No bootable devices found after apply image RRS feed

  • Question

  • Hello all,

    I am trying to deploy Windows 10 1903 using MDT 8456 and am running into a problem. I am testing this out on a Dell Latitude E5530 that had Windows 7 installed and secure boot off in legacy BIOS mode.

    I changed the BIOS to UEFI, secure boot on and managed to deploy Windows 10 successfully through MDT. I have now made some changes to my task sequence and am attempting to deploy to this same machine again, however, now after MDT applies the image and the computer reboots, I get an error that there are no bootable devices.

    If I use the boot menu, I see under the UEFI entries that there is an entry for Windows Boot Manager. If I select that, the computer boots normally into Windows and the task sequence resumes and completes normally.

    Does anyone know what is going on here and how can I fix it so that I don't have to manually choose Windows from the boot menu to start the computer? Thanks!

    Monday, October 21, 2019 5:51 PM

All replies

  • I am having the same thing on HP machines. I went from 1809 in MDT to 1903. When I image a machine, the final restart at the end goes to BootDevice not found.  If I go back into the BIOS and Enable Legacy and Disable SecureBoot, it boots back and finishes the TS. If this could be resolved, that would be great! :)
    Monday, October 21, 2019 7:00 PM
  • I did find this:

    community.spiceworks.com/topic/2155692-mdt-2013-uefi-win10-deployment-fails-boot-drive-not-found-dell-latitude-7290?page=2

    However, I'm not sure it will work for me since my TS steps were copied from a previous one already.

    Monday, October 21, 2019 7:03 PM
  • I guess the obvious question is..... if your TS worked the first time, then you made changes to your TS and now it's failing, what changes did you do to your TS, specifically?
    Friday, October 25, 2019 5:12 PM
  • The only this that has changed is the OS from 1809 to 1903. The Task Sequence, other than pointing to the new custom WIM, is unchanged.
    Tuesday, October 29, 2019 3:15 PM
  • And you did add the Full OS files for 1809 in your Build TS? And after that, regenerated the boot file and replaced it in WDS? Also, is this failure just on one pc or multiple ones?
    Tuesday, October 29, 2019 3:29 PM
  • Yes, added the FUll OS files for 1903 in the Build TS. Regenerated and replaced in WDS. The failure happens 100% of the time.
    Tuesday, October 29, 2019 7:05 PM
  • Hmm, is this on all the models you have, or just one specific pc?
    Tuesday, October 29, 2019 7:10 PM
  • This happens on every model we have.
    Monday, November 4, 2019 3:29 PM
  • Just as a last resort.....when you get to the initial Wizard screen, press F8.

    That brings up a DOS box. Within the DOS box, type:

    diskpart (enter)
    list disk (enter)
    select disk 0 (enter)
    clean (enter)
    exit(enter)
    exit(enter)

    Shut down the pc and try again. This may help clean out the boot sector.. However in your TS, in PreInstall, under New Computer, you should see Format Partition for bot BIOS and UEFI.

    When the cloning process begins, do you see MDT format the drive as UEFI?

    Monday, November 4, 2019 4:24 PM
  • Check this, It might be helpful

    https://docs.microsoft.com/en-us/windows/client-management/advanced-troubleshooting-boot-problems

    Monday, November 4, 2019 5:10 PM
  • I have a similar issue.   We've been making MDT images and deploying with SCCM since Win8.  We've done 10 1511, 1709 an 1809.  Changes we've done for 1903 include the OS, MDT and ADK version.  Every PC i build with the 1903 image boots once, does some setup work, then reboots to the boot selection menu.  At that point it also will not boot WinPE based on 1903 altough WinPE based on earlier windows releases, 1809, 1709, 1511 boot fine.  UNLESS I turn off secure boot.  

    if there is a question this is UEFI, nobody uses legacy BIOS outside of VM these days.  Which explains why i don't get the issue on type 1 HyperV.  Not sure why it doesn't fail on type 2 HyperV withe secure boot enabled. i'm ignoring that fact.

    This happens on multiple Thinkpad models; current, last year, 2015, etc.. Also happens on a Dell and a Toughbook.  All the same...  Every time

    We also give our image to Lenovo and they apply it to our PCs at the factory.  They apply the image using .. whatever they use.. Same thing....  

    Also tried generating one of those Windows 1903 boot keys you make online.  That worked,  but if i replace install.wim with an MDT image (slimmed down from normal).  Same thing..

    At this point i'm saying.  WTF.

    We regenerated the SCCM Deployment task sequence FRESH  from the default (SCCM 1902) and noticed the Apply Image step was creating partitions in a different order than the one we'd been carrying over since Win 8.0.   

    this is the new one.

    EFI FAT32 500MB
    MSR 128 MB
    Windows Primary (C:) NTFS 99% of remaining
    Recovery NTFS the rest (1 gig plus)

    I told Lenovo and their stuff is good to go now.  But my SCCM Task sequence still produces a PC that boots once then goes to boot menu.

    Wednesday, November 20, 2019 2:45 AM
  • We run into this exact issue with the Dell E5530. As of now, we haven't found a fix. We just documented the fact that we have to launch it from the boot menu, and that's part of our process for deploying those systems now. Honestly, half of my job at this point is finding workarounds for broken Microsoft crap.

    I can tell you for certain that updating the BIOS doesn't do it.


    Thursday, November 21, 2019 5:05 PM
  • I had this issue once in the past. Back up your LTIApply.wsf file.

    Modify LTIApply as follows:


      • If
      • oEnvironment.Item("OSCurrentVersion")<>""then


      •                                                                

      •                 oUtility
      • .GetMajorMinorVersion(oEnvironment.Item("OSCurrentVersion"))


      •                
      • If((oUtility.VersionMajor=6andoUtility.VersionMinor>=2)oroUtility.VersionMajor>=10)then


      •                              
      • TestAndFailRunBCDBootEx(sDestinationDrive &"\windows"," /s "&left(oBootDrive.Drive,2)&" /f UEFI"),5616,"Verify BCDBootEx"


      •                
      • Else


      •                              
      • TestAndFailRunBCDBootEx(sDestinationDrive &"\windows"," "),5616,"Verify BCDBootEx"


    and the modified version should be:

    <dir>
    <dir>

    If

    oEnvironment.Item("OSCurrentVersion")<>""then


                                                                   

                    oUtility

    .GetMajorMinorVersion(oEnvironment.Item("OSCurrentVersion"))


                   

    If((oUtility.VersionMajor=6andoUtility.VersionMinor>=2)oroUtility.VersionMajor>=10)then


                                 

    TestAndFailRunBCDBootEx(sDestinationDrive &"\windows"," "),5616,"Verify BCDBootEx"


                   

    Else


                                 

    TestAndFailRunBCDBootEx(sDestinationDrive &"\windows"," "),5616,"Verify BCDBootEx"

    </dir>
    </dir>

    This prevented my pc's from an endless loop back to PXE and also saying no device found. If it doesn't work for you, replace your existing wsf back.

    Thursday, November 21, 2019 6:13 PM
  • I'm having some trouble reading what I should change in the LTIApply.wsf. Could you write that out a little clearer? Possibly putting it into Visual Studio Code and giving the line numbers.
    Wednesday, November 27, 2019 2:55 PM
  • The spacing won't paste correctly so I will type it out.

    The current section is:

    TestAndFail RunBCDBootEx(sDestinationDrive &"\windows"," /s "&left(oBootDrive.Drive,2)&" /f UEFI"),5616,"Verify BCDBootEx"

    What you need to paste over the above is right here:

    TestAndFail RunBCDBootEx( sDestinationDrive & "\windows", " "), 5616, "Verify BCDBootEx"

    Wednesday, November 27, 2019 7:31 PM