none
RDP into Windows 10 Pro setup with MSA on 2FA (Workgroup, not on domain) RRS feed

  • Question

  • So I setup a fresh Windows 10 Pro (1903) on a laptop. During the OOBE, I set it up on the default Workgroup (no local nor AAD domain). When logging in, I specified an MSA using 2FA for my account. In that setup process, I never logged in with a password, just with my Microsoft Authenticator app, and it then prompted me to enter a local PIN. I have since made sure that my MSA password allows me to locally login as well (not just a PIN - both work).

    Next, I enabled Remote Desktop via the old System -> Remote Settings window. Given that this is the only account on the system so far, it's in the local Admin group so it has RDP permissions.

    Lastly, I verified RDP was allowed by the firewall. All looks good there.

    However, whenever I try to login, I keep getting bad credential errors. It's an immediate error, so that tells me the firewall is good. I think I'm not logging in with the correct username. I'm honestly not sure what that should be. My email address? Or just my "Name" (`.\Shane`) that shows up under `C:\Users\`? I suspect the issue is there.

    So, what am I missing to make this work?

    Monday, July 1, 2019 6:24 PM

All replies