locked
Exchange 2007 (SP3) roles on Windows 2008 R2 servers not discovered in SCOM 2007 R2 RRS feed

  • Question

  • Hi All, 

    We have several Exchange 2007 SP3 servers, some on Windows 2008 and some on Windows 2008 R2. The Exchange roles on the Windows 2008 R2 servers are not discovered. Only the Exchange roles on the 'old' Windows 2008 are discoverd. 

    I have enabled proxying on all servers within SCOM2007R2. I have enabled discovery on all Exchange objects in SCOM. The SystemCenterServer agent service is running on Local Service credentials, No RunAs configured for Exchange Profiles.

    The servers are monitored by the 'normal' MP's for Windows but not for Exchange.

    Anyone a solution for this? Maybe the Exchange MPs are not updated for the recently supported installation on W2k8R2?

    regards

    Thursday, March 24, 2011 8:24 AM

Answers

  • In reply to my own question. 

    If I create the String Value registry key "ConfiguredVersion" with Data 8.3.83.6 in path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\MailboxRole\" and restart the SCOM agent (service) the mailbox role on Windows 2008 R2 is discovered. 

    If you have other roles you have to put it in another path in your registry. 

    Regards,

    • Proposed as answer by Terence Yu Friday, March 25, 2011 6:52 AM
    • Marked as answer by Arjen Furster Friday, March 25, 2011 7:19 AM
    Thursday, March 24, 2011 8:52 AM

All replies

  • In reply to my own question. 

    If I create the String Value registry key "ConfiguredVersion" with Data 8.3.83.6 in path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\MailboxRole\" and restart the SCOM agent (service) the mailbox role on Windows 2008 R2 is discovered. 

    If you have other roles you have to put it in another path in your registry. 

    Regards,

    • Proposed as answer by Terence Yu Friday, March 25, 2011 6:52 AM
    • Marked as answer by Arjen Furster Friday, March 25, 2011 7:19 AM
    Thursday, March 24, 2011 8:52 AM
  • Thanks to post your answer. It is of great value of us.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, March 25, 2011 6:54 AM