none
How to recreate the C:\Users\Public\Public\Downloads folder RRS feed

  • Question

  • I've corrupted the permissions on my C:\Users\Public\Public\Downloads folder. How can I recreate this folder? I've tried deleting the folder and then recreating it in the registry under HKEY_LOCAL_MACHINE\..\Shell Folders & User Shell Folders, but to no avail.

    This is on a Windows 8.1 Pro x64, non-domain, desktop installation.



    Friday, October 16, 2015 6:00 PM

Answers

  • Hi,

    The safest way to do this is to create a new download folder under c:\user\Public\, it should inherit the all default security settings under Public folder. And don’t forget to compare with default settings on a clean Windows 8.1 machine to make sure they are same.

    If this doesn’t work, you need to follow the instruction as mentioned below which is including system restore.

    How do I restore security settings to a known working state?

    https://support.microsoft.com/en-us/kb/313222

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, October 21, 2015 1:20 AM
    Moderator

All replies

  • Have you tried using Takeown command in CMD or Powershell?

    Examples:
        TAKEOWN /?
        TAKEOWN /F lostfile
        TAKEOWN /F \\system\share\lostfile /A
        TAKEOWN /F directory /R /D N
        TAKEOWN /F directory /R /A
        TAKEOWN /F *
        TAKEOWN /F C:\Windows\System32\acme.exe
        TAKEOWN /F %windir%\*.txt
        TAKEOWN /S system /F MyShare\Acme*.doc
        TAKEOWN /S system /U user /F MyShare\MyBinary.dll
        TAKEOWN /S system /U domain\user /P password /F share\filename
        TAKEOWN /S system /U user /P password /F Doc\Report.doc /A
        TAKEOWN /S system /U user /P password /F Myshare\*
        TAKEOWN /S system /U user /P password /F Home\Logon /R

    hope this helps

    type Takeown /? in cmd for more help on the command


    Friday, October 16, 2015 8:16 PM
  • Chris, I appreciate your reply. Perhaps I can better explain my need at this point.  I haven't lost any data.  I had been using the Public Documents folder to sync with Google Drive so I could have shared access across multiple workstations without implementing Homegroups or configuring shares.  The reason being is that I typically have a WSE2012 server running, but I've had it offline for reconfiguration and I'm truly not all that savvy with networking, to begin with.

    Anyway, I changed to syncing Google Drive on the Public Downloads folder but apparently it has some different permissions characteristics from that of the Public Documents folder, and the outcome was that Google Drive refused to load on startup, except for on the Windows account that it was initially configured from. I have moved back to using the Public Documents folder on the workstations that I didn't mess with any permissions, but I've deleted the Public Downloads folder on the workstation that I made changes to the permissions settings. All I want to do at this point is recreate an empty Public Documents folder on this single workstation, using the default permissions.

    I'm guessing the difference between the Public Dowloads vs. Documents folders is some sort of online, file downloading scrutiny, which would be why Hyper-V doesn't utilize Public Downloads for anything... My assumption is that it also would not work to just copy the Downloads folder from the Default user profile, because that would have different permissions, as well.

    All that said, is TAKEDOWN still the method you recommend?  My initial look at TAKEDOWN's functionality didn't give me the impression that it was what I needed for my particular goal, and I've already burned considerable time on this. I would use system restore, except I would loose a lot of other system configurations I recently made.



    Monday, October 19, 2015 3:50 PM
  • Hi,

    The safest way to do this is to create a new download folder under c:\user\Public\, it should inherit the all default security settings under Public folder. And don’t forget to compare with default settings on a clean Windows 8.1 machine to make sure they are same.

    If this doesn’t work, you need to follow the instruction as mentioned below which is including system restore.

    How do I restore security settings to a known working state?

    https://support.microsoft.com/en-us/kb/313222

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, October 21, 2015 1:20 AM
    Moderator