none
Why Project Details views getting waired ?? RRS feed

  • Question

  • Hi,

    WE have faced below error in on project details page for perticular views intermitantly -

    The user who observed is administrator and checked that there is no filter for this views so wondering what else can be the cause for his issue.

    Pls suggest !!

    Regards, Parag

    "Nothing is true in error message"

    Tuesday, April 17, 2012 10:50 AM

All replies

  • Hi,

    By displaying the message seems to be lack of permission to view Enterprise Gantt. Try to access server settings - manage views and view project click the Enterprise Gantt view and make sure all permission groups are embedded within this Enterprise Gantt view.

    Another point that you can check is to edit all permission groups and making sure everyone has access permission.

    I hope this helps.


    Hezequias Vasconcelos

    Tuesday, April 17, 2012 11:36 AM
  • Hi Parag,

    from what I understand you dont have any filters on your view. If this is the case I would check if the user has access through the Category permission. The error message indicates that it is a user permission issue.

    The best idea to check is to give the user Admin permission to see if they can see the inforamtion then. If so you know that there is somthing wrong with the permission ( group or category)

    Hope this helps


    Marc Soester [MVP] http://marcsoester.blogspot.com

    Wednesday, April 18, 2012 6:53 AM
    Moderator
  • Hi Marc,

    The user is administrator on the PWA instance. Here are few tests the user has tried -

    • Remove Resource Names field from *** Enterprise Gantt view – view worked for a minute, then stopped again
    • Check and uncheck the Show Project Summary Task checkbox under View Options – this worked and then stopped working
    • Apply standard views (i.e., Tasks Detail, Resource Costs, etc…) and other Custom views (i.e., *** Critical Path) – these all work fine

    Regards,

    Parag

    Thursday, April 19, 2012 9:33 AM
  • As Mark said, I would ensure that the category permissions for the Enterprise Gantt view are the same as for the other views. If this doesn't work then it would appear to be a corrupt view and I would recreate it.

    Ben Howard [MVP] blog | web


    Thursday, April 19, 2012 9:59 AM
    Moderator
  • Hi Parag,

    From what I understand you say that the view works and suddelnly it stops? I personally have not had this issue, but Ben's suggestion is certainly the next part I would try. Just create a new brand new view and see if you still have this issue with this new view. if the answer is no, you may need to recreate the views. Let us know how you go.

    Thanks


    Marc Soester [MVP] http://marcsoester.blogspot.com

    Thursday, April 19, 2012 11:17 PM
    Moderator
  • Parag,

    The fact that it works for a while and then stops makes me wonder if there's and Active Directory sync job running that's changing some user permissions.

    How much of your Project Server security is being handled using Active Directory?

    Friday, April 20, 2012 9:45 PM
  • Hi,

    Now created new view with the same fields as in previous view in my first comment. Same error still persists :(

    Any suggestions !!

    Regards,

    Parag

    Friday, May 4, 2012 10:38 AM
  • Hi Parag,

    Can you please check ULS logs where you can see exactly what problem it had. Try opening the project view and note the time, then review the ULS logs and verify what was logged?


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Friday, May 4, 2012 11:16 AM