locked
PXE service point is not responding to PXE requests- 16389 RRS feed

  • Question

  • PXE service point is not responding to PXE requests

     

    Status Message in SMS_PXE_SERVICE_POINT component log: PXE Control Manager detected PXE service point is not responding to PXE requests.  The error is 16389.

     

     

    I have SCCM 2007 running on Windows 2008.  I am trying to get PXE boot working... 

     

    I have gone through these basic steps:

     

    1. Uninstalled PXE Service Point Role
    2. Uninstalled WDS
    3. Deleted 'e:\RemoteInstall' folder
    4. Rebooted then reinstalled WDS, rebooted
    5. Reinstalled PXE Service Point Role
    6. DHCP is not installed on this server and on the same subnet as my DHCP server

    The only real error I can find if this:

     

    pxecontrol.log

    Sent 274 bytes to 127.000.000.001:4011

    Error receiving replies

    Pxe test request failed, error code is 16389

    PXE test request failed, status code is -2147467259, 'Error receiving replies from PXE server'
    Successfully performed availability check against local computer

    Initialization still in progress. 

     

    Any ideas?

     

     

    Tuesday, July 1, 2008 7:38 PM

Answers

  •  

    Hi.... 

     

    Thanks for everyones help.  I eventually found out what the problem was...  My SCCM 2007 was running on Windows 2008 server.  I discovered that you need to install SCCM 2007 SP1 if you want to run on windows 2008.  (had to burn an MS support call on this...thaaaaaaa)

     

    Anyway, thanks for your help!

     

    Now my PXE boot service is working just fine...

     

     

    Thursday, July 10, 2008 4:44 PM

All replies

  • Check the PXESetup.log file on the PXE server.

    It is created when you add the PXE Service Point role to the server and should have details about what is happening during the PXE SP setup.

     

    If this installed correctly then there are other ways to get Verbose logs out of PXE SP.

     

    Wednesday, July 2, 2008 12:47 AM
  •  

    Thank you for the suggestion. 

     

    The PXESetup.log says installation successful ..exit code = 0.  All looks good in this log file.

     

     

    Wednesday, July 2, 2008 12:04 PM
  • How do you enable enhanced/verbose logging for a PXE Service Point?

     

    Wednesday, July 2, 2008 2:28 PM
  • "How to enable logging in Windows Deployment Services (WDS) in Windows Server 2003": http://support.microsoft.com/kb/936625/en-us

     

    Wednesday, July 2, 2008 2:56 PM
  • Thanks... but I was actually trying to get more details regarding the PxE service point in SCCM 2007:

     

    pxecontrol.log

    Sent 274 bytes to 127.000.000.001:4011

    Error receiving replies

    Pxe test request failed, error code is 16389

    PXE test request failed, status code is -2147467259, 'Error receiving replies from PXE server'
    Successfully performed availability check against local computer

    Initialization still in progress. 

     

     

    So that I could check out this error..

    Wednesday, July 2, 2008 3:02 PM
  • To enable WDS Logging set the following registry key:

    HKLM\Software\Microsoft\Tracing\WDSServer\EnableFileTracing = 1

     

    The log file generated from this setting will appear in %Windir%\Tracing\WDSServer.log

     

    To add additional logging features to the PXE Filter Script add the following style of code to the script: PXE.LogTrace "My log file comment"

     

    Thursday, July 3, 2008 1:43 AM
  •  

    Thanks...  I, was able to enable logging... and can see lots of stuff happening when I boot the PXE client.

     

    However, I get this error in the wdsserver.log (like a hundred times)

     

    [2608] 11:21:18: [d:\rtm\base\ntsetup\opktools\wds\wdssrv\server\src\udpendpoint.cpp:811] Expression: , Win32 Error=5023

     

    I see these errors on the PXE client:

     

    PXE-T04: Access Violation

    PXE-E36: Error received from TFTP server

    PXE-M0F: Exiting Intrl PXE ROM

     

    I still see this error in the PXEControl.log

     

    Pxe test request failed, error code is 16389

    PXE test request failed, status code is -2147467259, 'Error receiving replies from PXE server'

    Thursday, July 3, 2008 3:29 PM
  • Access violation looks like a rights issue.

    Check that all the accounts that you are using are set up correctly and the WDS\PXE server has the correct rights over your ConfigMgr server.

     

    Failing this, Remove the PXE Service Point role from ConfigMgr and re-add it.

    I have seen some instances of the WDS server needing to have WDS re-installed and even the whole box be flattened and started again.

     

    Tuesday, July 8, 2008 12:28 AM
  •  

    The WDS server PXE role and ConfigMgr are all installed on the same server.  I can't find an account issue...and I have been looking through the local Security logs (for access problems) ..but can't find any.

     

    I will try to re-install.

     

    tx.

    Tuesday, July 8, 2008 11:36 AM
  •  

    Hi.... 

     

    Thanks for everyones help.  I eventually found out what the problem was...  My SCCM 2007 was running on Windows 2008 server.  I discovered that you need to install SCCM 2007 SP1 if you want to run on windows 2008.  (had to burn an MS support call on this...thaaaaaaa)

     

    Anyway, thanks for your help!

     

    Now my PXE boot service is working just fine...

     

     

    Thursday, July 10, 2008 4:44 PM
  • I had this same error code and got it resolved thanks to Anandkumar Nair at MS Support.

    Cause:

    Running SQL server under a service account with missing SPN entries. When running SQL in SCCM 2007 in a cluster or under a service account you must register SPN records for the name and fqdn of the server.

    Check Symptoms:

    CCM\Logs\SMSPXE.Log shows the PSP can not log into SQL server.

    MPDB ERROR - CONNECTION PARAMETERS - Error Description   : The EXECUTE permission was denied on the object 'PXE_GetPXECert', database '<SMS DB NAME>', schema 'dbo'.

    When you execute: SetSPN -L <Domain\Account> you do not see the SQL server SPNs listed:

    • MSSQLSvc/<SQL Server computer name>:1433
    • MSSQLSvc/<SQL Server computer name>.<dns suffix>:1433

    Solution:

    ** Don't forget to ammend the port if you are running a custom SQL network config.

    1. setspn –A MSSQLSvc/<SQL Server computer name>:1433 <Domain\Account>.
    2. setspn –A MSSQLSvc/<SQL Server computer name>.<dns suffix>:1433 <Domain\Account>.
    3. Manually start WDS on the PSP

    Reference:

    The complete procedure is here: http://technet.microsoft.com/en-us/library/bb735885.aspx


    Victor Meyer
    • Proposed as answer by Victor Meyer Monday, November 29, 2010 4:43 PM
    Monday, November 29, 2010 4:39 PM