locked
Connecting a Vista PC and a Windows 7 PC RRS feed

  • Question

  • I have a direct connection (no switch, router or hub). On the Vista machine I can change my network type to "Private" (Network discovery ON, File sharing ON, Public folder sharing ON), no problem here. However on the Windows 7 machine (a fresh installation of Windows 7 x64 Ultimate), the network type goes to "Public" and cannot be changed (the link to change it is gone, however, when the Windows 7 machine is connected to my router, I can change the network type between "Public", "Work" and "Home").

    - How can I change the network type to "Home" on Windows 7 for this configuration (I would like to share files etc.)?

    By configuring most of the setting to ON for the "Public" network type on the Windows 7 machine (Network discovery ON, File sharing ON, Public folder sharing ON, Password protected sharing OFF), I am able to see the Windows 7 machine from the Vista machine. I can see a numer of folders, "Music", "Pictures", "Videos" etc. However, when trying to access these folders from the Vista machine, I get this error: 0x80070005 (I am not allowed to see the contencts of these folders). Everything works OK the other way around (I can access folders shared by the Vista machine).

    - How can I get access to the folders shared by the Windows 7 machine?

    Thursday, February 18, 2010 7:29 PM

Answers


  • follow these steps:

    1. Start --> run --> MMC --> press enter

    2. In MMC console , from menu file select Add/Remove Snap-in

    3. Select Group Policy Object editor --> Press Add --> select Local computer --> press finish -->press OK

    4. Now under the "console Root" you have 'local computer Policy", expand it and Open the "Computer configration" -->Windows Settings -->Security Settings -->select Network list manger policies
    on the right Side you will see options for :

    double click -->Unidentified networks

      Then you can select the option to consider the Unidentified networks as private and if user can change the
    location.

    • Proposed as answer by Bubbapcguy Friday, February 19, 2010 5:16 PM
    • Marked as answer by Nicholas Li Thursday, February 25, 2010 1:51 AM
    Friday, February 19, 2010 10:27 AM
  • Hi,

     

    Regarding the issue that you failed to access the share folder from Windows Vista, please try the following:

     

    1.     Boot the two computers to Safe Mode with networking and see if it works.

     

    2.     Check both Sharing and Security settings on all of the computers’ shares properties, and make sure that you have assigned the “Full-Control” permissions to “Everyone”.

     

    3.     Disable “Password Protected sharing” on Windows 7 computer:

     

    1)    Open Network and Sharing Center.

    2)    Click “Change Advanced sharing settings”.

    3)    Select “Turn off password protected sharing” under “Turn off password protected sharing”.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    • Marked as answer by Nicholas Li Thursday, February 25, 2010 1:51 AM
    Monday, February 22, 2010 10:24 AM

All replies


  • follow these steps:

    1. Start --> run --> MMC --> press enter

    2. In MMC console , from menu file select Add/Remove Snap-in

    3. Select Group Policy Object editor --> Press Add --> select Local computer --> press finish -->press OK

    4. Now under the "console Root" you have 'local computer Policy", expand it and Open the "Computer configration" -->Windows Settings -->Security Settings -->select Network list manger policies
    on the right Side you will see options for :

    double click -->Unidentified networks

      Then you can select the option to consider the Unidentified networks as private and if user can change the
    location.

    • Proposed as answer by Bubbapcguy Friday, February 19, 2010 5:16 PM
    • Marked as answer by Nicholas Li Thursday, February 25, 2010 1:51 AM
    Friday, February 19, 2010 10:27 AM
  • Excellent! Thanks for the info (strange that this setting has been changed from Vista to Win7, the default behavior in Vista seems more user friendly I think)!

    Friday, February 19, 2010 12:42 PM
  • Hi,

     

    Regarding the issue that you failed to access the share folder from Windows Vista, please try the following:

     

    1.     Boot the two computers to Safe Mode with networking and see if it works.

     

    2.     Check both Sharing and Security settings on all of the computers’ shares properties, and make sure that you have assigned the “Full-Control” permissions to “Everyone”.

     

    3.     Disable “Password Protected sharing” on Windows 7 computer:

     

    1)    Open Network and Sharing Center.

    2)    Click “Change Advanced sharing settings”.

    3)    Select “Turn off password protected sharing” under “Turn off password protected sharing”.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    • Marked as answer by Nicholas Li Thursday, February 25, 2010 1:51 AM
    Monday, February 22, 2010 10:24 AM