none
Project Pro 2013: Not able to create a budget resource of type work RRS feed

  • Question

  • I have created one resource called Budget Cost and one called Internal resource. I was successful in assigning the budget cost to the project summary task. When I however try to assign the Internal resource , the "Assign" button is greyed out. I assume this is due to the fact that Project doesn't recognize it as a budget resource. When I look at resource information the "Budget" choice is unchecked. I have tried to check the box and assign again, but without result. When I reopen the resource it is unchecked again.I followed this video when trying to do this: https://www.youtube.com/watch?v=KzQMnDollzM

    Any good tips on how to solve this?

    Thursday, July 2, 2015 9:11 AM

All replies

  • Hi,

    Indeed cost resources which are not "budget" flaged cannot be assigned to the project summary task. This explains why the "assign" button in the "assign resources" dialog box is greyed out.

    However if you select for your internal resource the budget checkbox, then it should work. Can you check that the resource is budget? I just tested with Project 2010 and 2016 and it worked properly. Can you test on a brand new project?


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, July 2, 2015 10:02 AM
    Moderator
  • Ketil --

    Budget resources essentially come in two flavors: Cost and Work.  Those who use Budget resources mostly use Budget Cost resources to specify the overall monetary budget for the project.  For example, our Leadership Team has given us a $750,000 budget for our project.  In this case, we would assign a Budget Cost resource named something like Project Budget, assign it to the Project Summary Task (Row 0), and then enter $750,000 in the Budget Cost column.

    Those who use Budget Work resources do so to specify an overall work budget (measured in hours) for the project.  For example, we estimate 5,200 man hours of work for the project.  In this case, we would assign a Budget Work resource named something like Project Work, assign it to the Project Summary Task (Row 0), and then enter 5,200 hours in the Budget Work column.

    In no case should you ever convert a human Work resource (as you call an internal resource) to a Budget resource, as this makes no sense at all.  This is because you should never assign humans to the Project Summary Task.  If you need to track your overall budget of work for the project, I would recommend you create a new Work resource named something like Project Work, make it a Budget resource, and then assign it to the Project Summary task as needed.

    By the way, you could actually create multiple Budget Cost resources to track your budget for different types of expenditures in the project.  For example, you could have Budget Cost resources called something like Equipment Budget or Supplies Budget, for example.

    Hope this helps.


    Dale A. Howard [MVP]

    Thursday, July 2, 2015 10:11 AM
    Moderator
  • Guillaume: Thanks. I maybe should have added that the project I tried to edit is checked out from  Project Server 2013. The plan is based on a template which is given to all new projects within that particular EPT. I am able to assign the Cost resource as Budget, but not the Work one. In this video (http://youtu.be/GmGhIS7nuAE) you can see me trying to check the budget box without any luck.

    As you said I tried to create a new project file on my computer and did the same there. For some reason it worked right away: http://youtu.be/AF_a-m_9YAw I cannot understand why it works there and not on the other PWA connected plan?

    Dale: I am indeed trying to do exactly what you recommend. My working of the resource was probably a bit off and created some misunderstanding J

    Thanks for your help.

    Thursday, July 2, 2015 12:30 PM
  • Indeed it looks like a bug.

    Just one comment: based on your first video, I see that you are dealing with local resource for your budget, which shouldn't be the case in an enterprise context. That being said, if it would have been enterprise resources, it would explain your issue since you cannot update enterprise resources attributes from your project plan. Is there a particular reason why you're using local resources?

    I would suggest to use the save for sharing method to see if it helps repairing your project which might be corrupted. Or try also to delete the resource and create it again. Finally try to save, publish, close the project and open it again.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, July 2, 2015 1:28 PM
    Moderator
  • I should definitely use a enterprise resource as you say. I have also created a new project template and associated it with the EPT. The same bug remains, but I was able to work around it by adding the column "Budget" and when choosing "Yes" using the dropdown it worked. Strange stuff :-)

    Thanks for the tip regarding "Save for sharing method".

    Friday, July 3, 2015 10:59 AM
  • You're welcome!

    If any of Dale's replies or mine were useful or answered your question, please mark them accordingly.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Friday, July 3, 2015 11:26 AM
    Moderator