none
Smartcard RPC error Anniversary update RRS feed

  • Question

  • I'm not sure to ask the question here or in the networking forum.

    I've got some computers with windows 10 installed. The computers logon to a domain with a smartcard (yubikey). No problem until the Anniversary update is installed.

    The computers with the Anniversary update show the smartcard logon option and display the correct user in the smartcard. After entering the PIN the computer tries to logon to the domain and then crashes with a RCP error (Kan RPC niet uitvoeren) (sorry, i don't have the exact error in English because it's a dutch windows install) 

    After the RPC error you can press ok and the logon prompt is displayed again for a LOCAL (not domain) user. Then the computer restarts.

    Anyone having the same problems (and maybe a solution?)

    Wednesday, September 21, 2016 5:45 PM

All replies

  • Hi,

    Did the issue occur with all the Windows 10 Anniversary update machines or the specific one?

    It will be better for us to troubleshoot this issue if there is exact error message. Considering this forum is for English only, if it is possible, try test it on a English Windows machine, or post this Dutch error message in a Dutch forum, they may understand it better.

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 22, 2016 7:20 AM
    Moderator
  • Rick,

    This issue occured on all three computers that were updated with the anniversary update, in a total of six windows 10 computers.

    I'll try to get a english windows install on one of the machines.

    Thursday, September 22, 2016 8:10 AM
  • Hi,

    we have the same error, I tried a German Windows 10 (1607) and a English Windows (1607), both show the same error.

    The interesting part is, if you use the yubikey to authenticate via RDP it works. "Only" the local login doesn't work.

    Best regards,

    Sebastian


    Monday, November 7, 2016 9:26 AM
  • Hi,

    the problem seems to be a bug within the Smard Card services provided by Windows 10.

    I had a long conversation with the YubiCo support and they were able to trace the problem. It appears that login process doesn't always end the applet select command. The YubiCo support got in touch with Microsoft and provided full details, the issue is currently under investigation. Unfortunately there is no timeframe for a solution.

    Best regards,

    Sebastian

    Wednesday, November 23, 2016 8:26 AM
  • Funny thing, i disabled the anniversary update and everything kept working. So for so good.

    Last week we received two upates from microsoft on one of the machines (i'm afraid it will be installed on the others to) and..... same problem.

    So Microsoft did nog fix the problem and now the problem is also in windows 10 before the anniversary update.

    Monday, January 23, 2017 3:34 PM
  • Here is an article about the new hotfix!

    http://www.theregister.co.uk/2017/02/16/win10_anniversary_borks_smartcards/

    Thursday, February 16, 2017 9:20 AM
  • I've tried this new hotfix! on a freshly installed windows 10 system. No success, still nog working.
    Friday, March 10, 2017 1:55 PM