locked
Excel 2013 crashes when editing columns RRS feed

  • Question

  • We have someone who is trying to edit the columns in a spreadsheet using Excel 2013 (the .xlsx is an export from SAP, fwiw), but each time he tries to edit by column, either one or multiple columns at a time, the program crashes immediately. I tried it on my machine as well and saw the same behavior, so it's not his instance of Excel that is failing. I tried saving the data as different file types, eg .xls, and the same thing happens. I disabled all add-ins, and the only way to get it working in Excel 2013 is running in safe mode. 

    It's only been the one file so far, and it works on Office 2010 and 2011. I'm hoping it's just some fluke that a future patch will fix? I just need a different workaround, since he's missing some functionality in safe mode. Anyone else seen something like this?

    Wednesday, March 6, 2013 11:31 PM

Answers

  • I found the fix for this, in case anyone sees a similar problem. I tried to open the file in Sharepoint and discovered that it wasn't compatible due to its XML maps. So I deleted the file's XML maps (put in there by SAP), and there were no more problems. To delete the XML maps, I went into the Customize ribbon option, selected the Developer tab and saved, went to the Develop tab and clicked Source, then clicked on the XML Maps button. I selected both, deleted, and problem solved.
    • Marked as answer by Rex Zhang Friday, March 8, 2013 3:02 AM
    Thursday, March 7, 2013 9:46 PM

All replies

  • I found the fix for this, in case anyone sees a similar problem. I tried to open the file in Sharepoint and discovered that it wasn't compatible due to its XML maps. So I deleted the file's XML maps (put in there by SAP), and there were no more problems. To delete the XML maps, I went into the Customize ribbon option, selected the Developer tab and saved, went to the Develop tab and clicked Source, then clicked on the XML Maps button. I selected both, deleted, and problem solved.
    • Marked as answer by Rex Zhang Friday, March 8, 2013 3:02 AM
    Thursday, March 7, 2013 9:46 PM
  • Hi,

    I’m glad to hear that you got it working. Thanks for your contribution.

    Best regards,


    Rex Zhang
    TechNet Community Support

    Friday, March 8, 2013 3:02 AM