locked
BDD 2007 and KMS activation still prompts for product key RRS feed

  • Question

  • I am testing the deployment of Vista Business VLK with BDD and I have everything working except 1 issue.
    If I select "No product key is required" during the client install wizard or use SkipProductKey=YES in the customsettings.ini I still get prompted for a product key during the image deployment. I have Volume License Media.

    My Bootstrap.ini is:

    [Settings]
    Priority=Default

    [Default]
    DeployRoot=\\XXXXX\Distribution$
    userDomain=xxxxxxxxx
    UserID=xxxxxxxxx
    SkipBDDWelcome=YES

    and my CustomSettings.ini is

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Y
    SkipBDDWelcome=YES
    SkipUserData=Yes
    UserDataLocation=NONE
    SkipCompterBackup=YES
    SkipApplications=YES
    SkipAppsOnUpgrade=YES
    Applications1={f5229186-4b94-4896-a9c2-c9544fcfe8c5}
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipDomainMembership=Yes
    JoinWorkgroup=WORKGROUP
    ComputerName=%SerialNumber%
    SkipTimeZone=Yes
    TimeZone=290
    TimeZoneName=New Zealand Standard Time
    SkipLocaleSelection=YES
    UILanguage=en-NZ
    InputLocale=en-NZ
    SystemLocale=en-NZ
    UserLocale=en-NZ
    KeyboardLocale=en-NZ
    SkipBuild=Yes
    BuildID=BUILD01


    After continuing without entering a product key I can verify that I have a VLK install by running slmgr -dlv
    and checking that the description has VOLUME_KMSCLIENT and that the KMS client information is populated.

    I am not running a KMS server on site as yet as this is just a test environment

    Any help would be appreciated

    Thanks
    Andrew
    Sunday, October 7, 2007 7:52 PM