none
Reporting (Tape Management/Utilization) not working - timeout?! RRS feed

  • Question

  • Hi,

    We have the following Configuration running:

    Server #1:
    Windows 2008 R2, all Patches
    DPM 2010 3.0.7696.0 (Upgraded from DPM 2007 SP1 all Rollups)
    Local SQL Instance (installed with DPM Setup)

    DPM Configured in Tape Library Sharing-Mode as "Library Server"
    Connected to a HP MSL 8096 via FC SAN


    Server #2:
    Windows 2008 R2, all Patches
    DPM 2010 3.0.7696.0 (Upgraded from DPM 2007 SP1 all Rollups)
    Local SQL Instance (installed with DPM Setup)

    DPM Configured in Tape Library Sharing-Mode as "Library Client"
    Connected to a HP MSL 8096 via FC SAN
    Media Changer Device in Device Manager is disabled


    On both Servers de SQLServer Services are running under the same DomainUser Account.
    Setup of Tape Library Share-Mode worked without any problems.


    Our problem:
    Everything works just fine except the reporting on Server #2 (Library Client).
    These reports are not working:

    - Tape Management
    - Tape Utilization

    All the other reports are just working fine.
    When i run a Tape Management Report on Server #2 it just says "generating report" but nothing really happens. After a while (~15min) i get a timeout and this error message:

    ---
    Fehler beim Clientrendering.
     Fehler bei der Berichtsverarbeitung. (rsProcessingAborted)
      Query execution failed for dataset 'OnlineTapes'. (rsErrorExecutingCommand)
       Named Pipes Provider: Could not open a connection to SQL Server [1326].
    ---

    At this time I get a Message in the Event-Log on Server #1 (Library Server):

    ---
    Account For Which Logon Failed:
     Security ID:  NULL SID
     Account Name:  DPMR$SERVER1
     Account Domain:  SERVER1
    ---

    (have to add here: it also didn't worked back when we were running DPM 2007 - just didn't care and thought DPM 2010 will fix it)


    What i checked so far:
    - Compared local User Accounts and SQL Permissions on Server #1 with #2.
     -> no differences

    Right now we're using a SQL-Query to get the list of expired tapes on Server #2. There's no other way at the moment.

    To me it looks like a permuission problem but can't figure out where to add/change permissions?!
    Any help is appreciated!

    • Edited by prolet Thursday, June 24, 2010 7:33 AM typo
    Thursday, June 24, 2010 7:33 AM

Answers