locked
Vista Unattended: Running "winsat.exe formal" after setup silently without user login? RRS feed

  • Question

  •  

    Hi

     

    I'm trying to start winsat with the parameter formal in order to activate aero on my clients.

     

    Unfortunatly that won't work (I don't get a "index rate" in Control Panel --> System) when "winsat.exe formal" runs in background (in a service for example).

     

    I need to start it from cmd.

     

    Does anybody know another solution?

    PC Type: HP 7800, Q35 on board graphics.

     

    Thanks

    Thursday, October 30, 2008 9:30 AM

All replies

  • Hi,

     

    Thank you for your inquiry.

     

    Please understand that some Windows Vista versions cannot use Aero. If you are using Windows Vista starter, Windows Vista Home Basic, we cannot activate Aero on it.

     

    For more information, you can refer to the following link:

     

    The System Assessment Tool

    http://www.microsoft.com/technet/scriptcenter/topics/vista/winsat.mspx

     

    In addition, if you not using Windows Vista starter or Windows Vista Home Basic, the Aero cannot be enable could be caused by following factors:

     

    1. The hardware, such as a video card or its driver, does not meet the requirements.

    2. The color settings are set below 32 bit.

    3. The monitor refresh frequency is set too low.

    4. The Desktop Windows Manager Session Manager service (UxSms) is not running.

     

    Hope it helps.

     

     

    Monday, November 3, 2008 6:54 AM
    Moderator
  •  

    Good morning

     

    The hardware is supporting Aero. When I run the command winsat formal, then aero is activated and works.

     

    The problem is, that the process is not automated. when I deploy a client unattended, I need to activate areo with that command manualy.

     

    my question: how do I run this command silently, for example in the unattended process without user interaction?

    Thx

    Monday, November 3, 2008 9:25 AM
  •  

    Hi,

     

    Thank you for your update.

     

    Before moving on, could you please let me know if the computer is in a domain? If so, could you please contact network administrator to check if there is a group policy block Aero?

     

    If not, please refer to the following suggestions:

     

    Verify the status of the UxSms service.

    =================================

    1.      Open the Services console (services.msc).

    2.      Double click on Desktop Windows Manager Session Manager.

    3.      The service status should display Started and the Startup type should be set to Automatic.

     

    Manually Override WinSAT Configuration

    =================================

    In the event that you need to override the automatic configuration set by WinSAT, use the following steps:

     

    1.      Ensure that two registry values are set:

    a.      HKCU\Software\Microsoft\Windows\DWM\Composition set to 1 (32-bit DWORD)

    b.      HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy set to 2 (32-bit DWORD)

     

    Note: You may need to create the DWM key and the two values if they do not exist.

     

    2.      Restart the Desktop Windows Manager Session Manager service:

    a.      Open a command prompt with administrative privileges.

    b.      Type the following lines, pressing ENTER after you type each line:

     

    net stop uxsms

    net start uxsms

     

    Then, restart the computer to test the issue again.

     

    If the issue still persists, please collect WinSAT Results and post it on the forum.

     

    WinSAT Results

    =====================

    The WinSAT performance diagnostic results in XML format can be located in the following location:

     

    %windir%\performance\WinSAT\

     

    To output the details of your video hardware assessed by WinSAT to a text file, type the following command line in a Command Prompt with administrative privileges:

     

    winsat  features  v >myVide_WinSAT.txt

     

    Then, please find the myVide_WinSAT.txt in %windir%\system32 and post it on the forum.

     

    Thank you for your cooperation.

    Wednesday, November 5, 2008 2:39 AM
    Moderator
  • hi

     

    thx for your answers.

     

    there are no GPOs blocking aero.

     

    Service was startet. The keys were present. I had to change the HKCU\Software\Microsoft\Windows\DWM\CompositionPolicy to 2

     

    Here the result of the myVide_Winsat.txt:

     

     

     

    Windows System Assessment Tool
    > DWM running... leaving it on
    > System processor power policy saved and set to 'max performance'
    > Running: Feature Enumeration v1.0.0.0 ''
    > Gathering System Information
    > Run Time 00:00:15.48
    > Operating System                        : 6.0 Build-6001
    > Processor                               : Intel(R) Core(TM)2 Duo CPU     E6750  @ 2.66GHz
    > TSC Frequency                           : 2660400000
    > Number of Processors                    : 1
    > Number of Cores                         : 2
    > Number of CPUs                          : 2
    > Number of Cores per Processor           : 2
    > Number of CPUs Per Core                 : 1
    > Cores have logical CPUs                 : NO
    > L1 Cache and line Size                  : 32768  64
    > L2 Cache and line Size                  : 4194304  64
    > Total physical mem available to the OS  : 2.96 GB (3'189'297'152 bytes)
    > Adapter Description                     : Intel(R) Q35 Express Chipset Family
    > Adapter Manufacturer                    : Intel Corporation
    > Adapter Driver Version                  : 7.14.10.1461
    > Adapter Driver Date (yy/mm/dd)          : 2008\3\25
    > Has DX9 or better                       : Yes
    > Has Pixel shader 2.0 or better          : Yes
    > Has LDDM Driver                         : Yes
    > Dedicated (local) video memory          : 0.00MB
    > System memory dedicated as video memory : 128.00MB
    > System memory shared as video memory    : 158.98MB
    > Primary Monitor Size                    : 1280 X 1024  (1310720 total pixels)
    > WinSAT is Official                       : Yes
    > Total Run Time 00:00:18.52
    > The System processor power policy was restored

     

    Thx for your help

    Monday, November 10, 2008 9:35 AM