locked
Process stays running after closing the application RRS feed

  • Question

  • We have a strange problem with 1 application.
    Within the Sequencer everything works fine.
    Within the Client (Citrix / TS Server) the application itself also works fine.
    But when I close the application, the process keeps running (also see in the Task Manager / Process) till closing the User Session.
    User get's the End Task Error.... :-(

    Within the Sequence session, the application close normally....

    I allready tried different versions of AppV (4.2 / 4.5)
    Also tried the the Child Process option and Local Interaction Allowed but this also doesn't change the problem.

    The Application name: Avaya Desktop Wallboard Marquee 4.


    I hope someone can help me :-)

    Thursday, October 15, 2009 12:00 PM

All replies

  • Assuming you mean that you've tried setting TERMINATECHILDREN to TRUE then I'd look at what process is actually running - is the exe that you call from the OSD actually spawning the main app as a child?  (in other words, do you run something which in turn runs something else, but doesn't terminate itself) It may be that closing the "application" is actually a child process and the parent is still active.. 
    Thursday, October 15, 2009 2:20 PM
  • Hello,

    Would be interesting to what kind of process is left behind...

    I have seen java in some instances not stopping eventhough the main internet explorer process is killed due to some changes the xenapp installation imposes.

    /Znack
    Thursday, October 15, 2009 5:32 PM
  • You might want to try Tim's LaunchIt (from http://www.tmurgent.com/Tools.aspx) to launch your process in the OSD file. As I understand it, it should close [grand]child-processes more thoroughly than TERMINATECHILDREN=TRUE.

    /Kalle
    Thursday, October 15, 2009 6:49 PM
    Moderator
  • I have solved issues with hanging processes (at shutdown but also startup) with changing SUBSYSTEM VALUE from windows --> console (especially with Java applications).
    One issue was when the app launched but App-V client didn't catch the launch. So after the "timeout" the application was killed by the App-V client thinking it didn't launch at all.


    Ment van der Plas
    Sunday, October 18, 2009 10:04 AM
    Answerer
  • Thank you all for the answers.

    I tried a couple of thinks.

    - TerminateChildren = True
    - Launch It
    - Subsystem Value from windows to console

    But nothing seems to work.

    This are not Java application and it doesn't start any child process.

    1. I start the application (extra process is coming within the Task Manager -> Process)
    2. I close the application. It looks normal for the user but I don't see the shutdown message from Softgrid / The application process is still running within the Task Manager -> Process (no child process). When I kill the process manually, it works fine and I see the shutdown message from Softgrid.....

    Any ideas?

    Wednesday, October 21, 2009 9:56 AM
  • Hello,

    Well do a procmon and see what happens - perhaps its still doing stuff?

    /Znack
    Wednesday, October 21, 2009 10:06 AM
  • Hi mderoos

     

    Have you got the answer for the process issue you are facing.

    Thursday, January 19, 2012 12:56 PM
  • Im also facing the same problem. Does any body got solution ?

    Please help me.....

    Tuesday, January 24, 2012 7:41 AM
  • Did you do a ProcMon like Znack suggested to see if the process was still actively making calls?

    It looks like you've exhausted your options otherwise in my opinion. You could have a post script to kill the process if it's for a process which is only required by that application otherwise I wouldn't go near that because you could break another application that relies on the process.


    Blog: rorymon.com Twitter: @Rorymon
    Tuesday, January 24, 2012 6:55 PM