locked
Can't restore anything RRS feed

  • Question

  • I just installed Windows Server 2012 essentials and have two days of backups under my belt.  Oddly I needed to restore a single file that was corrupt.  Logged into my computer with my "domain" account, opened the dashboard with an admin account, selected devices, right clicked on the computer in question and selected to restore files or folders.  Pulled up the two days of backups.  Selected the latest, gets to 4% opening volume and says:

    The restore process did not succeed because your computer cannot connect to the server.  make sure the computer is connected to the network, and then try again.

    Which obviously isn't the case as it shows "online" and I was able to conenct and get the list backups.  On Windows 7 64-bit for reference.  Any help?

    Thanks.

    Wednesday, December 26, 2012 5:12 PM

Answers

  • Found my own problem.  Kind of a problem.  Had VMWare Player on the computer and it creates two additional network IP's of a different one than the subnet you are on, so like my network is on:

    192.168.0.x

    VMWare creates like

    192.168.51.1 and 192.168.221.1

    There were some DNS warning about not knowing what they were and when I disabled those two virtual network cards since I'm using bridged mode, it started restoring.  I had done a reboot for good measure.

    Hopefully problem is solved.


    • Marked as answer by syarbrou1 Thursday, January 3, 2013 12:02 AM
    • Edited by syarbrou1 Thursday, January 3, 2013 12:06 AM
    Thursday, January 3, 2013 12:02 AM

All replies

  • Open up the dashboard with your user account.
    Wednesday, December 26, 2012 11:33 PM
  • I'll try when I'm back to my PC, however if memory serves it forces you to use an admin account when logging into the dashboard.
    Thursday, December 27, 2012 3:40 AM
  • As I expected message came up "You must be a network administrator to run Windows Server 2012 Essentials Dashboard.  Sign in as a network administrator, and then try again.".  What I find interesting.  Other thoughts?

    Thanks.


    • Edited by syarbrou1 Saturday, December 29, 2012 3:00 PM
    Saturday, December 29, 2012 3:00 PM
  • Use the credentials for the administrator account you were required to set up during your installation.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Saturday, December 29, 2012 4:07 PM
  • I did.  I was responding to the previous person who said to use my user account and that it wouldn't work and I verified of course that it required the admin account.  Admin account setup at the beginning, using it to login to the dashboard, starting the restore after selecting the day to restore fails per my original thread submission.


    • Edited by syarbrou1 Sunday, December 30, 2012 4:07 AM
    Sunday, December 30, 2012 4:06 AM
  • This is what shows for reference in the SharedServiceHost-BackupServerConfig log file which I know isn't necessary the place where restore elements reside but showed an update to the file when it failed.  Also note this has now failed on two computers.  Lots of good backups, no way to restore them.  Note I have all internal firewalls turned off completely to test things so isn't firewall related:

    [10464] 130101.160347.1242: ProviderFramework: Information: [0] : PfErrorHandler: IGNORING WCF internal exception: (CommunicationException) The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '10675199.02:48:05.4775807'. ==> (IOException) The read operation failed, see inner exception. ==> (CommunicationException) The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '10675199.02:48:05.4775807'. ==> (SocketException) An existing connection was forcibly closed by the remote host

    I also get stuff like the below in the SharedServiceHost-AlertServiceConfig.2 log:

    [9800] 121229.211504.4951: Notifications: Information: [0] : LNx01: Source SNx03 fired a one-shot:
    Notification Category: NetworkHealthAlerts
                       Id: Raise
                   Source: notifier:SharedServiceHost.exe:p3952:mt4:1
    [12068] 121229.211504.5575: ProviderFramework: Information: [0] : PfErrorHandler: IGNORING WCF internal exception: (CommunicationException) The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '10675199.02:48:05.4775807'. ==> (IOException) The read operation failed, see inner exception. ==> (CommunicationException) The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '10675199.02:48:05.4775807'. ==> (SocketException) An existing connection was forcibly closed by the remote host

    Same basic detail just some additional stuff before the long error.

    Thoughts?

    Tuesday, January 1, 2013 10:08 PM
  • Found my own problem.  Kind of a problem.  Had VMWare Player on the computer and it creates two additional network IP's of a different one than the subnet you are on, so like my network is on:

    192.168.0.x

    VMWare creates like

    192.168.51.1 and 192.168.221.1

    There were some DNS warning about not knowing what they were and when I disabled those two virtual network cards since I'm using bridged mode, it started restoring.  I had done a reboot for good measure.

    Hopefully problem is solved.


    • Marked as answer by syarbrou1 Thursday, January 3, 2013 12:02 AM
    • Edited by syarbrou1 Thursday, January 3, 2013 12:06 AM
    Thursday, January 3, 2013 12:02 AM
  • This lead me down the right path.  I switched from Bridge to NAT and this worked for me.

    Thanks.

    Tuesday, October 21, 2014 2:24 PM