locked
Strange behaviour at branch office RRS feed

  • Question

  • Hi,

    I have deployed W7 to two laptops for about 3 hours ago, both of them failed doing the refresh. So I have done much research on one of the laptops but haven't found anything wrong with the settings or nothing. But it still wont get icons at the desktop. I tried the other laptop just for fun. I logged on and of course there the icons popped up on the desktop...

    I really doesn't understand what's going on now. Both of the laptop have the exact same configuration.
    Friday, March 5, 2010 2:07 PM

Answers

  • I have fixed this problem now. I reconfigured the AppV Management Server to use RTSPS not RTSP. Now the communication only uses one port. I think it's odd that there aren’t more articles online about configuring AppV with a certificate since using certificate makes the network configuration a lot easier. So my conclusion is if you have a branch office you should use a certificate, make all a lot easier 

    But I'm just glad this issued is solved now.

     

     

    • Marked as answer by Tor-André Thursday, March 25, 2010 7:18 AM
    Thursday, March 25, 2010 7:18 AM

All replies

  • Hello,

    Well, key to understand what happens here is perhaps not to verify the configuration but determine what comes into play.

    What does the log-files say?
    If you perform a manual refresh, what does the error message say?

    /Znack
    Friday, March 5, 2010 2:18 PM
  • I have done many manual refreshes. As you can see from the log, it fails at the two first refreshes and on the third it works.


    [03/04/2010 11:09:07:086 SRVC INF] {tid=6F8}
    ---- The Application Virtualization Client Service version 4.6.0.1523 has started ----


    [03/04/2010 11:11:19:773 MIME ERR] {tid=6F4:usr=xxxxxxxxxxxx}
    Failure on Desktop Configuration Server request to URL {rtsp://xxxxxxxxxxxx:554/} with header {Host: xxxxxxxxxxxx
    Content-Type: text/xml
    AppV-Op: Refresh
    } (rc 19D0810A-10000005).


    [03/04/2010 11:11:35:054 MIME ERR] {tid=A04:usr=xxxxxxxxxxxx}
    Failure on Desktop Configuration Server request to URL {rtsp://xxxxxxxxxxxx:554/} with header {Host: xxxxxxxxxxxx
    Content-Type: text/xml
    AppV-Op: Refresh
    } (rc 19D0810A-10000005).


    [03/04/2010 11:16:06:141 MIME INF] {tid=C0C:usr=xxxxxxxxxxxx}
    Updated MIME information from xxxxxxxxxxxx:554/
    Monday, March 8, 2010 2:22 PM
  • Hello,

    I would say that during this four minute gap something with the network connectivity changes - is there anything started on the client that could effect this?

    http://support.microsoft.com/kb/930697

    /Znack
    Monday, March 8, 2010 2:27 PM
  • Thanks for the link znack, I have tried some of the suggestions there, but I will take a closer look at it.

    But I have had one breakthrough now. I have got one IP client address that have no network rules applied between the client and the management server. I deployed a new client and of course the package download failed. I then changed the IP address and did a new refresh then the icon come popping up on the desktop. I did this 3 times just to be sure that it just wasn't a coincident. So there seems to be a network issue here.

    What ports do AppV over rtsp need? As I can see using netstat -an (on a working client) it communicates on port 554 and 445, and these are open. Are there any other ports that should be opened? What about high ports?
    Monday, March 8, 2010 4:29 PM
  • Hello,

    See this slightly older article;
    http://support.microsoft.com/kb/932017

    Ports should still be valid...

    /Znack
    Monday, March 8, 2010 6:46 PM
  • A little update. We have made a new rule in the firewall that applies to the article you posted znack. But it didn't solve anything. The strange thing it seemed like when a entered a static IP and did a refresh the icons appeared. The static IP address is inside the scoop of the DHCP server. I then went back to a DHCP address and the icons didn't appear. So I tried switching between DHCP address and static address a couple of times, and the outcome was the same every time. But suddenly the icons appeared with a DHCP address..... I really doesn't understand anything now. So I have opened a support ticket with Microsoft today, they will contact me within 24 hours.
    Tuesday, March 9, 2010 3:08 PM
  • A new update: If the IP is leased I don't get the icons. If I set a fixed IP that haven't been leased but are within the scope I get the icons and the packages are loaded.

    So does anybody have some tip about what could be wrong?
    Thursday, March 11, 2010 11:17 AM
  • Hello,

    Any difference in settings compared between what you set manually and what they get via DHCP?

    /Znack
    Thursday, March 11, 2010 9:15 PM
  • No, I'll set the same as I get from the DHCP server. The only difference is that I choose an IP that isn't leased.
    Friday, March 12, 2010 12:44 PM
  • Hello,

    Perhaps its a difference in the IP and what traffic that is allowed to flow.

    /Znack
    Friday, March 12, 2010 12:48 PM
  • When the computer get a new lease (not the same that it got when it were deployed through WDS) downloading icons and loading packages works fine.
    Monday, March 15, 2010 7:30 AM
  • I have fixed this problem now. I reconfigured the AppV Management Server to use RTSPS not RTSP. Now the communication only uses one port. I think it's odd that there aren’t more articles online about configuring AppV with a certificate since using certificate makes the network configuration a lot easier. So my conclusion is if you have a branch office you should use a certificate, make all a lot easier 

    But I'm just glad this issued is solved now.

     

     

    • Marked as answer by Tor-André Thursday, March 25, 2010 7:18 AM
    Thursday, March 25, 2010 7:18 AM
  • Thursday, March 25, 2010 7:43 AM
  • MS posted a blog article that is related to that issue

    http://blogs.technet.com/appv/archive/2010/03/24/network-devices-that-use-rtsp-inspection-may-cause-problems-in-specific-app-v-scenarios.aspx

     

     


    Falko
    Monday, March 29, 2010 3:01 PM
    Moderator