none
MsDb2Client doesn’t support batch operations RRS feed

  • Question

  • We are getting this error when attempting to do a single insert into DB2/AS400 using HIS from bizTalk 2010. To the best of our knowledge we are not attampting any batch operations. Searches haven't been productive.

    Tuesday, January 8, 2013 10:07 PM

Answers

  • It turns out that the root issue for this was in the configuration of the DB2 Transport Properties for the send port. We had been advised to set the UseFastLoad property =True. Changing this to = False resolved this issue. it may be something unique to this clients DB2 installation.
    • Marked as answer by DeemsDavis Thursday, January 10, 2013 8:39 AM
    • Edited by DeemsDavis Saturday, January 12, 2013 8:07 PM
    Thursday, January 10, 2013 8:39 AM

All replies

  • Hi,

    Could you please post your connectionstring (without any credentials) and your code how you are executing the nonquery ?

    Best Regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com

    Wednesday, January 9, 2013 12:50 PM
  • As Steve mentioned, it may be a setting in your connection string. If you happen to have "FastLoad Optimize=True" in the connection string, try setting it to "FastLoad Optimize=False" (without quotes) to see if that resolves the problem.

    You may need to restart the BizTalk host instance after making the change to make sure that the new connection string setting is used.

    Thanks...


    Stephen Jackson - MSFT

    Wednesday, January 9, 2013 10:58 PM
  • It turns out that the root issue for this was in the configuration of the DB2 Transport Properties for the send port. We had been advised to set the UseFastLoad property =True. Changing this to = False resolved this issue. it may be something unique to this clients DB2 installation.
    • Marked as answer by DeemsDavis Thursday, January 10, 2013 8:39 AM
    • Edited by DeemsDavis Saturday, January 12, 2013 8:07 PM
    Thursday, January 10, 2013 8:39 AM