locked
Server 2012 R2 - Change network location from public to private RRS feed

  • Question

  • I am having an issue with changing Network location to private from Public on Server 2012 R2 X64 .

    Please note all the reference for previous servers for fixing this issue  does not work on 2012 R2.

    I am using Static-IP and "Workgroup" as domain setting.

    In 2012 server by Right  clicking on Network and Turn sharing on or OFF worked but in 2012- R2 Right click is not working not providing turn sharing ON or OFF option.


    • Edited by Naveedm1 Friday, January 10, 2014 5:58 PM
    Friday, January 10, 2014 5:28 PM

All replies

  • Check if you can change from here :

    Run -- Gpedit.msc-- Open Computer configration -->Windows Settings -->Security Settings -->select Network list manager policies


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by TomazicM Monday, June 23, 2014 7:05 PM
    Friday, January 10, 2014 6:08 PM
  • Check if you can change from here :

    Run -- Gpedit.msc-- Open Computer configration -->Windows Settings -->Security Settings -->select Network list manager policies


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    NO it did not work I had already tired and rebooted it does not work. Just for other having the same issue please note my Build is 9600 so this may not apply to you,if you have a different Build you might not have this problem.

    I am going back to server2012 rather using R2.

    Friday, January 10, 2014 11:52 PM
  • Exactly the same problem.
    Exactly the same OS version, 2012 R2 x64.

    I've read a guide that says to right click the network icon etc etc.

    The menu that pops up from the right hand side of the screen does absolutely nothing, and this is on the released/official build of 2012 R2.

    I can left click "View Connection Settings" or the actual "Network | Connected" icon as much as I want and nothing happens. Right clicking on it brings up no menu at all.

    What is going on here?
    There appears to be absolutely no way of changing the connection to a private connection.

    I made a video here:
    https://www.youtube.com/watch?v=oY2M0kgUO_Q


    • Edited by Paul May Monday, April 7, 2014 9:01 PM
    • Proposed as answer by hojomaio Monday, July 21, 2014 9:08 PM
    • Unproposed as answer by hojomaio Monday, July 21, 2014 9:08 PM
    Monday, April 7, 2014 8:43 PM
  • While not attempting to change anything, I am writing documentation for my support teams and I have to agree with Paul.  The Networks Menu from the right hand side of the screen does nothing but dispaly anything I am running Server 2012 R2u1 Datacenter.  A confirmation from Microsoft this is a feature/bug woudl be at least a minimum response I would expect.

    Thank you.

    Thursday, April 24, 2014 2:55 PM
  • Check if you can change from here :

    Run -- Gpedit.msc-- Open Computer configration -->Windows Settings -->Security Settings -->select Network list manager policies


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    We have Server 2012 R2 Standard Build 9600 (9600.winblue_gdr.140305-1710) and this worked for us.
    Monday, June 23, 2014 7:02 PM
  • I observed the same problem (unable to change Public network type - same as shown in your video) on my Server 2012 R2 systems, but I was able to fix it using the PowerShell steps in this link:

    http:// blogs.msmvps.com/russel/2013/12/29/set-network-location-to-private-in-windows-8-1server-2012-r2

    • Proposed as answer by jwilseyRCDB Thursday, October 16, 2014 5:35 PM
    Monday, July 21, 2014 9:15 PM
  • Hojomaio, your link was the response to my problem, thank you.

    I am assuming this setting is for security reasons, but I do find it weird that by default, if you install Windows Server 2012 R2 in a Workgroup, the network location is set as public. This makes remoting in very cumbersome particularly because there is no GUI to change the network location from public to private... Go PowerShell!

    Friday, January 16, 2015 2:41 PM
  • I had this same problem and the way I solved it was very easy. 

    1.) Left click on the network icon at the bottom right of the screen.  This will pull out Networks from the right side.

    2.) Right click on the network you are connected to.  This will pop up a box that says "Turn sharing on or off".

    3.) Click on the box that says "Yes, turn on sharing and connect to devices..."

    You are done.

    • Proposed as answer by andy_connect Thursday, February 1, 2018 12:25 PM
    Wednesday, June 24, 2015 10:57 PM