locked
Outlook 2016/Exchange 2016 on-prem: inconsistent search across Inbox and In-Place Archives RRS feed

  • Question

  • Environment is on-prem Exchange 2016 Enterprise CU12 with O365 Pro clients (Outlook 2016) running under Win10/Pro.  All legally licensed and functionally lashed together.  Please note this does not involve OWA at all at this point (that's a whole different issue).

    I have a couple users reporting very inconsistent search results when searching from Outlook 2016 across both Current Mailbox and In-Place archive.  For example, if we search across ONLY the Current Mailbox (with search parameter set for both Inbox and In-Place Archive), we can see (for example) 150 email items in the result.  If we then set the search type "All Mailboxes", we suddenly see fewer than 150 items.  At the very least we should see AT LEAST 150 items (those same items from the Current Mailbox search), plus any new items in the In-Place Archive.  That is not happening.  This is replicable across two (2) separate users at this time; I'm re-indexing my own personal mailbox to test with right now.  Multiple re-indexes on the clients; used both cache and non-cached mode (although please say if this is a known issue in searches).

    Is this a known bug in Exchange 2016 or Outlook 2016 (any version, including O365)?  What's happening here?  We can't roll out In-Place Archiving across our enterprise if this feature is broken (we've already done it on a single user with a huge mailbox (100G+) and are taking heat from that user for the failures).

    Thanks.

    SteveB

    • Moved by Perry-Pan Friday, October 4, 2019 6:51 AM
    Friday, September 27, 2019 6:12 PM

All replies

  • Hi Steve,

    You can check if this setting is enabled or disabled in the problematic users' Outlook clients:

    1. Open Outlook.

    2. Click File > Options, and then select Search.

    3. Clear the Improve search speed by limiting the number of results shown checkbox, and click OK.

    4. Restart Outlook.


    If there are any steps in this article that you haven't applied yet, you might also want to give them a try:

    https://support.office.com/en-us/article/troubleshooting-outlook-search-issues-2556b11f-f4d8-46be-b0a7-de33a3f4f066#bkmk_noresults

    Regards,
    Burak V.

    Saturday, September 28, 2019 7:53 PM
  • Hi Steve,

    I also tested this issue here: Exchange server 2016 (15.01.1713.005) with Office 365 version / Outlook 2016 Professional Plus (MSO 16.0.4266.1001)

    Search results returns correctly under "All Mailboxes" scope on both clients. Please refer to my results:

    Tried both Cached Exchange mode and Online mode.

    Please install the newest updates for both Office client and Exchange server to see if it works.

    Under cached Exchange mode, Outlook use Windows Search to index items. We can try rebuilding index on problematic client.

    To do this, open Control Panel > Indexing Options > Advanced > Rebuild. Wait for a while until it shows indexing complete,” and make sure Outlook is listed. Then tested again.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, September 30, 2019 4:17 AM
  • Thanks for replying!  My Exchange installations are 15.01.1713.5 and O36/Outlook 2016 are 1902 (build 11328.20420 Semi-annual); we cannot change the refresh to monthly on our O365 installs.

    After running some more tests related STRICTLY to Cached vs Non-Cached mode, we are getting different results on test searches.  For example with one search result, when CACHED/ALL, I see 170 msgs in "Current Mailbox" and 163 in "All Mailboxes".  However, when I set NON-CACHED, I see results of 170/170 on Current/All.  I see this on a pristine build with all emails downloaded and a fresh index built Friday night.

    There appears to be an issue with CACHED vs NON-CACHED on searches across local and archive mailboxes.  I can replicate this on different machines with different mailboxes.

    I won't perform an update on my Exchange servers just for testing purposes unless someone can tell me that an In-Place Archive searching/indexing issue(s) was resolved in the latest CU.  Also, the checkbox for limiting search results is already disabled on all test machines.

    Steve

    Monday, September 30, 2019 4:26 PM
  • >>I can replicate this on different machines with different mailboxes.

    Does it occur to multiple users with different versions of Office?

    It doesn't mean the search feature is related with the latest CU. Upgrading is normally the first choice to fix issues.

      

    >> However, when I set NON-CACHED, I see results of 170/170 on Current/All.  I see this on a pristine build with all emails downloaded and a fresh index built Friday night

    Does search results returns correctly under Online mode?

    When running under Online mode, Outlook use Exchange search and runs directly on the server. For cached Exchange mode, Outlook search using Windows desktop search.

    We can open Outlook on safe mode so that Outlook will use its own instant search function. Please exit Outlook, press Win key + R to open the Run command, type outlook /safe and then press Enter.

    If it occurs on both side, there could also be related with client itself.

         

    Considering your situation, let's reset Office settings on one problematic client to see if it helps.

    (Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur)

    (Note: this will remove all Office settings including Outlook profile, view settings or ribbon customization)

    1. Press Win + R to open Run. Type regedit and click Enter.

    2. Go to this path: HKEY_CURRENT_USER\Software\Microsoft\Office\x.0

    3. Rename this key to \x.0-old

    4. Restart Outlook and re-configure your account.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Perry-Pan Thursday, October 3, 2019 7:16 AM
    Tuesday, October 1, 2019 5:12 AM
  • How is everything going on with this issue?

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, October 4, 2019 6:51 AM