none
Project Server 2013 Portfolio Analysis Unknown Error When Running Hired Resources Report RRS feed

  • Question

  • I am working in Project Server 2013, and exercising the Portfolio Analysis capabilities. I've built an example portfolio of several projects which have resource plans. I've created several scenarios with different budgets (cost constraints) and also conducted resource analysis (resource constraints). In the resource constraints, I added an additional resource by entering 1 in the Hire Resources, recalculating, then saving under a new name.  This brought an additional project into the "Selected" queue from the "Not selected" queue.

    I then attempted to run the Hired Resources Report and I receive a rather non-helpful error listed twice:  "An unknown error has occurred". 

    Any ideas????

    Tuesday, January 14, 2014 12:51 AM

All replies

  • Hello, can you get the error details from the SharePoint ULS logs? Post back the error from these logs relating to this error and we will try to help. Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, January 14, 2014 1:31 AM
    Moderator
  • Unfortunately, I'm don't have access to the SharePoint Central Admin since I'm using Bemo, a cloud provider.  I'll drop a ticket on them unless someone else has seen this before.

    Thanks.

    Tuesday, January 14, 2014 3:16 AM
  • Hi

    I have the same error in one of my systems.

    The Log states:

    01/21/2014 08:59:50.63     w3wp.exe (0x3CEC)                           0x0CEC    Project Server                    General                           aeby7    Exception    [bucketHash:379F575B] Exception occured in method 'Optimizer.GetPlannerSolutionReportJSON' System.ArgumentException: An item with the same key has already been added.     at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)     at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)     at Microsoft.SharePoint.JSGrid.GridSerializer.ApplySliceUpdate(DataTable slicedTable, SliceUpdate sliceUpdate)     at Microsoft.SharePoint.JSGrid.GridSerializer.BuildOutput()     at Microsoft.SharePoint.JSGrid.GridSerializer.ToJson(Serializer s)     at Microsoft.SharePoint.JsonUtilities.Serializer.SerializeToJson(Object o, Boolean isKey)     at Microsoft.SharePoint.JsonUtil...    cd5f6c9c-d785-709a-cba0-b78a71a2f44d
    01/21/2014 08:59:50.63*    w3wp.exe (0x3CEC)                           0x0CEC    Project Server                    General                           aeby7    Exception    ...ities.Serializer.WriteKeyValuePair[T,U](T key, U value)     at Microsoft.SharePoint.JsonUtilities.Serializer.SerializeToJson(IDictionary dict)     at Microsoft.SharePoint.JsonUtilities.Serializer.SerializeToJson(Object o, Boolean isKey)     at Microsoft.Office.Project.Server.BusinessLayer.Optimizer.GetPlannerResHired(Guid analysisUid, Guid solutionUid, String[] sortColNames, Boolean[] sortColOrders, String sProjs, Guid[] roleUids, DateTime fromDate, DateTime toDate)     at Microsoft.Office.Project.Server.BusinessLayer.Optimizer.GetPlannerSolutionReportJSON(Int32 reportType, Guid analysisUid, Guid solutionUid, String[] sortColNames, Boolean[] sortColOrders, Guid[] projUids, Guid[] roleUids, String fromDate, String toDate)     at Microsoft.Office.Project.Server.Wcf.Implementation.PWAImpl.<>c...    cd5f6c9c-d785-709a-cba0-b78a71a2f44d
    01/21/2014 08:59:50.63*    w3wp.exe (0x3CEC)                           0x0CEC    Project Server                    General                           aeby7    Exception    ...__DisplayClass323.<OptimizerGetPlannerSolutionReportJSON>b__322()     at Microsoft.Office.Project.Server.Wcf.Implementation.WcfMethodInvocation.InvokeBusinessObjectMethod(String businessObjectName, String methodName, IEnumerable`1 actions) StackTrace:  at Microsoft.Office.Project.Server.Native.dll: (sig=874dbfdc-4770-4b1a-81f8-2b3d83ee10e5|2|microsoft.office.project.server.native.pdb, offset=3C1E) at Microsoft.Office.Project.Server.Native.dll: (offset=1255D)    cd5f6c9c-d785-709a-cba0-b78a71a2f44d
    01/21/2014 08:59:50.63     w3wp.exe (0x3CEC)                           0x0CEC    Project Server                    Unified Logging Service           c91s    Monitorable    Watson bucket parameters: Microsoft Project Server 2013, ULSException14, 070f6ea0 "project server", 0f001181 "15.0.4481.0", c180aef3 "mscorlib", 0400766f "4.0.30319.0", 5173bf53 "sun apr 21 12:28:35 2013", 00002120 "00002120", 000001b9 "000001b9", 44395864 "argumentexception", 00101621 "aeby7"    cd5f6c9c-d785-709a-cba0-b78a71a2f44d

    I can reproduce the issue in a second environment.

    Perhaps it is the same issue?

    Regards

    Christoph


    Christoph Muelder | Senior Consultant, MCSE, MCT | SOLVIN information management GmbH, Germany


    Tuesday, January 21, 2014 8:05 AM
  • Hi,

    I also have the same error on one of my systems. The ULS log is the same as above.

    Any ideas??

    Kr

    Tuesday, May 27, 2014 2:48 PM
  • I'm seeing the same error when I run the Hired Resources report. Any one have any ideas on how to troubleshoot this? It doesn't matter if I do 1 resource or 10...
    Tuesday, June 3, 2014 12:13 AM
  • Hi Neall, Alemaitre, Don and Christophe,

    This s most likely due to multiple rates being present.  We fixed the same issue in 2010 but reviewing the sproc this hasn't been fixed yet in 2013.  In 2010 it displayed duplicate data - in 2013 we have a key on the grid - hence the total failure.  I'm hoping we can push this through for a hotfix request shortly. There is a reasonable workaround with a sproc change (and if you have Project Server 2010 post October 2013 CU you could see what the change is in the published db in the

    MSP_PLANNER_ReadResourceHired stored procedure).

    Not that I'm  suggesting you make changes to the DB of course - but in your shoes I probably would... Let me know if you are in Project Online as we would need to fix there too.

    Best regards,

    Brian


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Tuesday, June 3, 2014 2:49 PM
    Owner
  • Hi Brian,

    Thank you for your answer.

    What exactly do I need to change in the stored procedure?

    I am working with Project Server 2013 on premises.

    Regards,

    Axel

    Wednesday, July 9, 2014 8:25 AM
  • I have just encountered the same issue with my test instance of Project Server.

    I have checked and there are no Varied Resource Rates in my Resource Pool either as a result of different cost rate tab values or due to "effective date" altering the cost of a resource from a specified date - all resources have a single rate applied in the default cost rate tab and none of my resources has cost changing over time.

    Is there another explanation for this issue?


    Dominic Moss | MAPM Microsoft Certified Technology Specialist | Our Newsletter: PM News Project Server Specialists Project Server PRIME | Twitter: @Twitter | Facebook: @Facebook | Linkedin: Wellingtone

    Monday, August 4, 2014 3:47 PM
  • We are facing the same issue on our test environment. We also do not have different rate tables for resources. However we have added rates to the resources using "Open" (Selected All Resources) in Microsoft Project Professional 2013. I have read somewhere that some people ran in to issues after editing the resources in Microsoft Project Professional.

    Tanzim Akhtar

    Thursday, November 6, 2014 11:27 AM
  • Hello Brian

    do you know if a CU has been released for that issue?

    Regards


    Jérome Charlon - Senior Project Server Architect - MCP-MCTS

    Thursday, November 20, 2014 8:16 PM
  • I saw where this is marked as the answer, but it's pretty clear from the follow-on posts and the fact the issue is still out there that it has not, in fact, been resolved, and this may or may not be the answer.  How can we get this resolved? 

    Don A. Cox, PMP, MCTS

    Monday, December 15, 2014 4:35 PM