"The form template cannot be published because the Sharepoint list or site content type settings folder could not be found"


  • I create a content type and then try to create:

    Stated goals: Create a custom Document Information Panel from SharePoint Server 2007

    1.       Create an Office Word 2007 document template to use a the document template for  a custom SharePoint Server 2007 content type.

    2.       Create site columns to use with a custom Content Type

    3.       Create a custom content type and associate the document template and site columns with content type

    4.       Create a custom Document Information Panel for the content type

    5.       Create document Library and add the content type

    Word Document Template

    1.       Start Microsoft Word 2007

    2.       Create a document type something

    3.       Save as a documentName.dotx (where documentName is whatever you like)
     I named mine: Project Status Report Template.dotx

    4.       Exit word

    Create Site Columns

    In this step is to define two project status report 0 related site columns.  You can use SharePoint site columns to define ta set of shared columns that you can reuse across multiple libraries and content types.

    1.       In SharePoint server click site actions

    2.        click Site Settings

    3.        click modify all site settings.

    This gets you into Site Settings


    1.       Select from Galleries, Site Columns

    2.       This takes you to Site Column Page. Click Create

    3.       Create a column with the following

    ·         Column Name: Project Name

    ·         Column Type: Single line of text

    ·         Group: Project Status Report

    ·         Select Yes for Required Column

    4.       Click Ok to create the new column.

    5.       Let’s do it again

    ·         Column Name: Project Owner

    ·         Column Type: Single line of text

    ·         Etc

    6.       Get out and select Content Type from Site  Settings

    7.       Create my Content Type

    8.       In Content Type select Document Information Panel settings

    9.       Create a new custom template.  This brings me right into InfoPath and make my minor modifications to the document and save it

    10.   Now I hit publish and that’s where the “bleep”  hits the you know what

    The error I get is this:

    “The form template cannot be published because the Sharepoint list or site content type settings forlder could not be found”

    I can never finish my plan because I am not  able to save my document info panel.

    Any suggestions?


    • Edited by Mike Walsh FIN Tuesday, September 01, 2009 11:04 AM Error message put in " ". No need for a "Error: " prefix
    Tuesday, September 01, 2009 9:45 AM

All replies

  • Update!

    I found something quite unexpected!!  I was working in the server box which had Office installed.  I swithed to one of my workstations and logged in to the site and now tried the same thing and this time InfoPath was able to publish to site without any issues.  Is this behavior documented?  OR... do I still have and issue at the server box??

    Tuesday, September 01, 2009 11:06 AM
  • Hi Angel,

    Did you ever find out the reason why this error message occured?

    I am now facing the same error msg on Sharepoint and Infopath 2010, and I am exactly working on an workstation instead of on the Server. I cannot find a way out.

    anyone with any solution?

    Saturday, March 24, 2012 10:16 AM
  • And now!

    I tried the same thing on another workstation. and all of the infopath publish and the add doc(opening the DIP in word) work very smoothly.

    :( still don't know what's the reason????

    any way thank you a lot! or I will never think of try in on another PC.

    Saturday, March 24, 2012 10:33 AM
  • Thank you! Using another computer with InfoPath solved the issue for me. I'm using Office 365 Pro Plus with SharePoint Online. I needed to modify the document information panel for a content type based on an Excel spreadsheet.
    Tuesday, May 13, 2014 1:16 PM