locked
app-v virtual mgmt console refuses to connect to management server/throwing error RRS feed

  • Question

  • After following the installation etc, the app-v management server console is throwing an error when clicked to connect. During installation,the appvirtdb was created and i also am part of the appvAdministrators group. localhost doesnt work either,though it pings ok. I am on my own local admin machine windows 2008 R2, SQL server 2008, ADS set up/IIS set up, ok,etc.

    Error code in error dialog is 0000C800

    Following is the log - in sftmmc  -->

    10/25/2011 9:09:19 PM http://127.0.0.1/
    ManagementConsole.MCException: [DBNETLIB][ConnectionOpen (ParseConnectParams()).]Invalid connection. ---> System.Data.OleDb.OleDbException: [DBNETLIB][ConnectionOpen (ParseConnectParams()).]Invalid connection.

    Server stack trace:
       at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
       at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.OleDb.OleDbConnection.Open()
       at SoftGrid.Management.DataAccess.TransactionManager.GetConnection()
       at SoftGrid.Management.SoftGridPrincipal.GetRoleGroupMapping()
       at SoftGrid.Management.SoftGridPrincipal.GetGroupsForRole(String role)
       at SoftGrid.Management.SoftGridPrincipal.IsInRole(String role)
       at System.Security.Permissions.PrincipalPermission.Demand()
       at System.Security.PermissionSet.DemandNonCAS()
       at SoftGrid.Management.Authorization.Authorize()
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at SoftGrid.Management.IAuthorization.Authorize()
       at ManagementConsole.ManagementSession.connect(String urlPrefix, NetworkCredential cred)
       --- End of inner exception stack trace ---

     

    Tuesday, October 25, 2011 4:23 PM

Answers

  • I don't have any strong evidence to back it up, but my gut feeling is that your issue is due to the machine also being a Domain Controller. Can you remove the DC role and try again? - This may require also reinstalling IIS.

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Wednesday, October 26, 2011 1:30 PM
    Moderator

All replies

  • What other software is installed on that machine? Is that machine also a domain controller?

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Tuesday, October 25, 2011 5:15 PM
    Moderator
  • Yup,aaron, the machine is its own domain controller - active directory. I am trying to login as domain administrator who is also configured as a memeber of AppVAdministrators group specified in the mgmt server install.

    I also tried sftmgmt.udl properties and "test connection" and it succeeded - login as mydomain\Administrator specified there.

    However, the "reset administrators" button in the app-v console is not working/connecting either.

    On the console, i specify "localhost" and the same mydomain\Administrator password there too.

    what should i do?

    Wednesday, October 26, 2011 6:33 AM
  • Wednesday, October 26, 2011 7:00 AM
  • Now I get 0000C81B error. Database is set up ok,and apparently the webservice is a problem/auntentication.

    10/26/2011 5:42:06 PM http://localhost/
    ManagementConsole.MCException: The remote server returned an error: (404) Not Found. ---> System.Net.WebException: The remote server returned an error: (404) Not Found.

    Server stack trace:
       at System.Runtime.Remoting.Channels.Http.HttpClientTransportSink.ProcessResponseException(WebException webException, HttpWebResponse& response)
       at System.Runtime.Remoting.Channels.Http.HttpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at SoftGrid.Management.IAuthorization.Authorize()
       at ManagementConsole.ManagementSession.connect(String urlPrefix, NetworkCredential cred)
       --- End of inner exception stack trace ---

     

    Wednesday, October 26, 2011 12:19 PM
  • Yet another update:-

    After rejigging the IIS settings to make asp.net app run under domain admin, i get

    Error Summary

    HTTP Error 500.24 - Internal Server Error

    An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

    Detailed Error Information

    Module

    ConfigurationValidationModule

    Notification

    BeginRequest

    Handler

    StaticFile

    Error Code

    0x80070032

    Requested URL

    http://localhost:80/SoftGrid

    Physical Path

    C:\Program Files (x86)\Microsoft System Center App Virt Management Server\App Virt Management Service

    Logon Method

    Not yet determined

    Logon User

    Not yet determined

    Most likely causes:

    system.web/identity@impersonate is set to true.

    Things you can try:

    If the application supports it, disable client impersonation.

    If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.

    Move this application to an application pool using Classic .NET mode - for example, %SystemRoot%\system32\inetsrv\appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"

    (You can set "Classic .NET AppPool" to the name of another application pool running in Classic managed pipeline mode)

    Links and More InformationIf you are not sure or unable to use the first two options, then it is preferred that you move this application to Classic mode.

    View more information »

    Wednesday, October 26, 2011 12:58 PM
  • I don't have any strong evidence to back it up, but my gut feeling is that your issue is due to the machine also being a Domain Controller. Can you remove the DC role and try again? - This may require also reinstalling IIS.

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Wednesday, October 26, 2011 1:30 PM
    Moderator