none
Use SMTP instead of Exchange MIM2016SP1 RRS feed

  • Question

  • So I went in to Microsoft.ResourceManagement.Service.exe.config and updated the following:

    <appSettings>
        <!-- Setup adds entries -->
        <add key="mailServer" value="sw20smtp.ourdomain.com" />
        <add key="isExchange" value="0" />
        <add key="sendAsAddress" value="svc-mimservice@ourdomain.com" />

    I then get the following in the event viewer after I restart the FIMService:

    The Forefront Identity Manager Service cannot connect with Exchange because required configuration is missing.
    The mailServer configuration setting in the Forefront Identity Manager Service application configuration file is missing or not a valid URI.
    Ensure an XML Node with this XPath exists and has inner text that is a valid URI representing the Exchange server:
    /configuration/appSettings/add[@key='mailServer']
    For example,

    <configuration><appSettings><add key="mailServer" value="http://www.contoso.com/ews/exchange.asmx" /></appSettings></configuration>;

    What is my issue??? Any insight would be great!!

    Thanks

    Monday, April 17, 2017 1:23 PM

Answers

  • We had this error aswell.

    The error message really is misleading, and it took some real deep digging in FIM code to find why.

    The reason is that you previously had Exchange polling configured. The Exchange polling setting in FIM is stored in the Registry, apparently. You cannot change it in the Microsoft.ResourceManagement.Service.exe.config.

    You have two possible solution:

    - Rerun the Install to reconfigure FIM to use the new mail server, and not do Exchange Polling.

    - Hack the registry, to set FIM not to use Exchange polling.


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    • Proposed as answer by Leo Erlandsson Wednesday, April 19, 2017 8:39 AM
    • Marked as answer by MikeFinazzo Wednesday, April 19, 2017 2:39 PM
    Wednesday, April 19, 2017 8:39 AM

All replies

  • Looks like you have broken the xml chain somewhere.

    Have you tried to open the config file in Visual Studio or another xml tool?

    /Søren

    Wednesday, April 19, 2017 8:15 AM
  • We had this error aswell.

    The error message really is misleading, and it took some real deep digging in FIM code to find why.

    The reason is that you previously had Exchange polling configured. The Exchange polling setting in FIM is stored in the Registry, apparently. You cannot change it in the Microsoft.ResourceManagement.Service.exe.config.

    You have two possible solution:

    - Rerun the Install to reconfigure FIM to use the new mail server, and not do Exchange Polling.

    - Hack the registry, to set FIM not to use Exchange polling.


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    • Proposed as answer by Leo Erlandsson Wednesday, April 19, 2017 8:39 AM
    • Marked as answer by MikeFinazzo Wednesday, April 19, 2017 2:39 PM
    Wednesday, April 19, 2017 8:39 AM
  • Could you give an example of what I'm looking for in the registry? I went here and I'm not seeing anything:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FIMService

    Thanks

    Mike

    Wednesday, April 19, 2017 11:10 AM
  • PollExchangeEnabled is now set to 0.

    Let you know if this works.

    Wednesday, April 19, 2017 11:20 AM
  • Great! Remember to restart the FIMService.

    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Wednesday, April 19, 2017 11:50 AM
  • If my SMTP requires authentication then please mention where I can mention credential.

    <appSettings>

        <!-- Setup adds entries -->
        <add key="mailServer" value="sw20smtp.ourdomain.com" />
        <add key="isExchange" value="0" />
        <add key="sendAsAddress" value="svc-mimservice@ourdomain.com" />

    Tuesday, October 16, 2018 6:13 AM