none
App-V 5 Error 0x4C401F0C-0x8007012F

    Question

  • Hi, 

    I am receiving the above error a lot on on our office 2010 package, once its received that package is broken until the RDS server is restarted. Microsoft suggest this is by design...http://support.microsoft.com/kb/2780304

    Having dug through the files it seems that the package encounters errors with the file MSOXEV.DLL, specifically it seems to lock it with windows explorer.exe. A quick search on the web indicates that this file is used by infopath for shell extension integration.

    My question is how do I disable the shell extension functionality either for a specific package or against specific applications?

    I've had a trawl through the deployment configuration but cant see an entry reference that relates to this, i may have missed it however as its a fairly large config file. I hope to disable this function and see if the file locking issues goes away.

    Thanks

    Keith

    Tuesday, December 03, 2013 3:59 PM

All replies

  • Hello,

    So you are removing, and then adding the same package? Any particular reason?

    I would try if the same experience occurs with App-V 5.0 SP2


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, December 03, 2013 4:11 PM
  • Yes, attempting to remove and re-add the same package, due to another error. This happens quite often.

    Log Name:      Microsoft-AppV-Client/Admin
    Source:        Microsoft-AppV-Client
    Date:          03/12/2013 15:00:05
    Event ID:      10001
    Task Category: Subsystem Startup
    Level:         Error
    Keywords:      Subsystems
    User:          xxxxx
    Computer:      xxxxxxxx
    Description:
    Process 11480 failed to start due to Virtual Shell subsystem failure. Package ID {7350edb6-ad57-4834-825b-3d39756866d5}. Version ID {16d3d103-2286-4594-9dfd-1df5e804ba31}. Error: 0x9B50172A-0x3
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-AppV-Client" Guid="{E4F68870-5AE8-4E5B-9CE7-CA9ED75B0245}" />
        <EventID>10001</EventID>
        <Version>1</Version>
        <Level>2</Level>
        <Task>22</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000008000</Keywords>
        <TimeCreated SystemTime="2013-12-03T15:00:05.442052500Z" />
        <EventRecordID>63</EventRecordID>
        <Correlation />
        <Execution ProcessID="5400" ThreadID="6348" />
        <Channel>Microsoft-AppV-Client/Admin</Channel>
        <Computer>xxxxxxxxxxxxxxxxxxxx</Computer>
        <Security UserID="S-1-5-21-1156189098-3849888882-1468240402-1210" />
      </System>
      <EventData>
        <Data Name="PID">11480</Data>
        <Data Name="Package">{7350EDB6-AD57-4834-825B-3D39756866D5}</Data>
        <Data Name="Version">{16D3D103-2286-4594-9DFD-1DF5E804BA31}</Data>
        <Data Name="SubsystemName">Virtual Shell</Data>
        <Data Name="ErrorHigh">2605717290</Data>
        <Data Name="ErrorLow">3</Data>
      </EventData>
    </Event>

    The original error received was in excel.exe.

    The user receives the messagebox below.

    The application was unable to start correctly (0xc0000225). Click OK to close the application.

    Normally removing and re-adding the package fixes this, although fixing this first error would obviously be preferable.

    App-V 5 SP2 is the version I'm currently running.

    Thanks

    Tuesday, December 03, 2013 4:29 PM
  • Tuesday, December 03, 2013 10:04 PM
  • Hi, Bit of a delay on replying due to other project commitments.

    This is still ongoing. However I have now found additional error messages. This issue occurs once a day in the morning following a scheduled task for something completely unrelated (A task that sends a reporting email for a natively installed app).

    When the task runs the following event's are reported in the app-v debug logs. All App-V apps then fail on the machine, a reboot followed by a package removal and resync is the only way to get it going. Repair doesn't help.

    The particular package referenced below is Acrobat reader. However no apps will launch any more.

    Log Name:      Microsoft-AppV-Client-VirtualizationManager/Debug
    Source:        Microsoft-AppV-Client-VirtualizationManager
    Date:          07/01/2014 05:45:10
    Event ID:      2036
    Task Category: None
    Level:         Information
    Description:
    AppData mapping cofiguration for user S-1-5-21-1156189098-3849888882-1468240402-1514, package {72c31f5c-f81e-42d2-a004-9b95f396eb94}: mapping target C:\Users\admHexaware\AppData\Roaming\Microsoft\AppV\Client\VFS\72C31F5C-F81E-42D2-A004-9B95F396EB94\AppData; local cache C:\Users\admHexaware\AppData\Local\Microsoft\AppV\Client\VFS\72C31F5C-F81E-42D2-A004-9B95F396EB94\AppData; need to copy: true

    Log Name:      Microsoft-AppV-Client-VirtualizationManager/Debug
    Source:        Microsoft-AppV-Client-VirtualizationManager
    Date:          07/01/2014 05:45:10
    Event ID:      2038
    Task Category: None
    Level:         Error
    Description:
    AppData download task failed. Error 0xAB201C0480070002; user S-1-5-21-1156189098-3849888882-1468240402-1514; package {72c31f5c-f81e-42d2-a004-9b95f396eb94}.

    Log Name:      Microsoft-AppV-Client-VFSC/Debug
    Source:        Microsoft-AppV-Client-VFSC
    Date:          07/01/2014 05:45:10
    Event ID:      208
    Task Category: None
    Level:         Error
    Description:
    Failed to get instance for volume: \Device\HarddiskVolume2
     Context: VfsCreateMappingEntry
     Status: 0xc0000225

    Log Name:      Microsoft-AppV-Client-VFSC/Debug
    Source:        Microsoft-AppV-Client-VFSC
    Date:          07/01/2014 05:45:10
    Event ID:      224
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Description:
    Failed to create mapping from message for user: <DOMAIN>\admHexaware
     PackageId: {72c31f5c-f81e-42d2-a004-9b95f396eb94}
     VersionId: {51e54285-a229-4ebe-8269-15ae376973b1}
     Status: 0xc0000225


    If a repair is attempted the following is displayed in the powershell window.

    PS C:\Users\TEMP> Repair-AppvClientPackage Office*
    Repair-AppvClientPackage : Internal AppV Integration error: Package not
    integrated for the user. Please ensure that the package is added to the
    machine and published to the user.
    Operation attempted: Repair Package.
    AppV Error Code: 010000001D.
    Please consult AppV Client Event Log for more details.
    At line:1 char:1
    + Repair-AppvClientPackage Office*
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult: (:) [Repair-AppvClientPackage], C
       lientException
        + FullyQualifiedErrorId : ReintegratePackageError,Microsoft.AppV.AppvClien
       tPowerShell.RepairAppvPackage

    Thanks


    Tuesday, January 07, 2014 12:57 PM
  • Hi,

    Continuing to get the errors below for all packages on a specific system. A reboot fixes it however it appears that the App-V client is a pretty odd state if it continues to assume if cant see either \Device\HarddiskVolume2 (The C Drive) or \Device\HarddiskVolume4 (The D Drive).

    Log Name:      Microsoft-AppV-Client-VFSC/Debug
    Source:        Microsoft-AppV-Client-VFSC
    Date:          08/01/2014 17:56:56
    Event ID:      208
    Task Category: None
    Level:         Error
    Keywords:      
    User:          XXXXXX\XXXXXXX
    Computer:      XXXXXXXXXXXXXX
    Description:
    Failed to get instance for volume: \Device\HarddiskVolume2
     Context: VfsGetMappedTarget
     Status: 0xc0000225
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-AppV-Client-VFSC" Guid="{9de0cf4d-2967-497f-9916-958c90ce687c}" />
        <EventID>208</EventID>
        <Version>1</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2014-01-08T17:56:56.916960100Z" />
        <EventRecordID>133</EventRecordID>
        <Correlation />
        <Execution ProcessID="4640" ThreadID="1848" ProcessorID="1" KernelTime="0" UserTime="0" />
        <Channel>Microsoft-AppV-Client-VFSC/Debug</Channel>
        <Computer>XXXXXXXXXXXXXXXX</Computer>
        <Security UserID="S-1-5-21-1156189098-3849888882-1468240402-3556" />
      </System>
      <EventData>
        <Data Name="NameLength">23</Data>
        <Data Name="Name">\Device\HarddiskVolume2</Data>
        <Data Name="Msg">VfsGetMappedTarget</Data>
        <Data Name="Status">0xc0000225</Data>
      </EventData>
    </Event>

    Once the error has appeared once on the system it screws the rest of the App-V published apps too.

    Any help appreaciated.

    This is proving a show-stopper.

    Wednesday, January 08, 2014 6:06 PM
  • Hello,

    I would raise a support call with Microsoft.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, January 08, 2014 8:34 PM
  • Hello, ever found a Solution for this Problem?

    We are getting same Errors after Upgrading AppV Client to SP2. Will try to deploy HF2 to see if it makes any changes.

    The Server is only affected if it runs more than one day. If we reboot our RDS Server daily the Problem never appears.

    Thank you

    • Proposed as answer by znack Wednesday, April 23, 2014 12:01 PM
    • Unproposed as answer by znack Wednesday, April 23, 2014 12:01 PM
    Wednesday, March 05, 2014 7:27 AM
  • I am having this same issue as well. Has anyone had any luck resolving this?
    Friday, April 18, 2014 11:12 AM
  • I am having this same issue as well. Has anyone had any luck resolving this?
          I am so having the same issue .
    Wednesday, July 09, 2014 7:23 AM
  • Hello,

    Suggestion have been to raise a support call with Microsoft. Unless someone, who can reproduce the issue, does so or provides _new_ information based on observations that provide additional insight - it is hard to provide additional suggestions to fix this. 


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, July 09, 2014 8:43 AM
  • Thursday, July 10, 2014 9:22 PM
  • Hi all,

    I have exactly the same issues- any updates on it? Do you have any new updates what is the root cause and what is the resolution for that one.

    Thursday, January 22, 2015 1:26 PM
  • Do you have something in English?

    Thursday, January 22, 2015 1:28 PM
  • Any new updates regading this issue:

    A reboot fixes it however it appears that the App-V client is a pretty odd state if it continues to assume if cant see either \Device\HarddiskVolume2 (The C Drive) or \Device\HarddiskVolume4 (The D Drive).Log Name:      Microsoft-AppV-Client-VFSC/Debug
    Source:        Microsoft-AppV-Client-VFSC
    Date:          08/01/2014 17:56:56
    Event ID:      208
    Task Category: None
    Level:         Error
    Keywords:     
    User:          XXXXXX\XXXXXXX
    Computer:      XXXXXXXXXXXXXX
    Description:
    Failed to get instance for volume: \Device\HarddiskVolume2
    Context: VfsGetMappedTarget
    Status: 0xc0000225
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-AppV-Client-VFSC" Guid="{9de0cf4d-2967-497f-9916-958c90ce687c}" />
        <EventID>208</EventID>
        <Version>1</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2014-01-08T17:56:56.916960100Z" />
        <EventRecordID>133</EventRecordID>
        <Correlation />
        <Execution ProcessID="4640" ThreadID="1848" ProcessorID="1" KernelTime="0" UserTime="0" />
        <Channel>Microsoft-AppV-Client-VFSC/Debug</Channel>
        <Computer>XXXXXXXXXXXXXXXX</Computer>
        <Security UserID="S-1-5-21-1156189098-3849888882-1468240402-3556" />
      </System>
      <EventData>
        <Data Name="NameLength">23</Data>
        <Data Name="Name">\Device\HarddiskVolume2</Data>
        <Data Name="Msg">VfsGetMappedTarget</Data>
        <Data Name="Status">0xc0000225</Data>
      </EventData>
    < /Event>

    Once the error has appeared once on the system it screws the rest of the App-V published apps too.

    Any help appreaciated.

    This is proving a show-stopper.

    Thursday, January 22, 2015 1:30 PM
  • Hello,

    If this is a show-stopper I would open a ticket with Microsoft to have assistance with the issue


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, January 24, 2015 10:47 AM
  • I think it is held up due to a Pending Task. If you turn off DynamicVirtualization, does the issue go away? Not a solution - but an important troubleshooting step.


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Thursday, February 12, 2015 6:09 AM