none
FAST Search Not Crawling documents RRS feed

  • Question

  • I am working on setting up FAST Search. I am using Information Worker (180 days trial) from Microsoft, with FAST Setup/Installed by default.

    I having created a webapplication and added some documents to a document library. Now I added a content source to FAST Query SSA and did complete crawling, it didnt seem to add those documents to FAST indexing. I came across some blogs afterwards suggesting using Content SSA and add content source there. After adding content source with just one Webapp, with no customization or webparts, just some documents. Now crawling takes forever. It ran for about a day and I had to stop the crawl finally. Still I dont see any single document in search.

    Any Ideas?

    Monday, April 4, 2011 12:06 AM

Answers

All replies

  • Monday, April 4, 2011 6:55 AM
  • If this is just a test environment anyway, I would recommend clicking the "Reset Index" link. That can often help the crawling get itself straightened out. Also, I recommend removing all entries from the FAST Query SSA content source that do not start with sps3://, as FAST Query SSA is only used for crawling people data.

    Regards

     


    Thomas Svensen | Microsoft Enterprise Search Practice
    Monday, April 4, 2011 8:17 PM
    Moderator
  • See my blog post from today - http://techmikael.blogspot.com/2011/04/remember-to-give-your-sharepoint-2010.html

    It's the info worker FAST self signed certificate which has expired.

    Regards,
    Mikael Svenson 


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    • Proposed as answer by Mikael SvensonMVP Tuesday, April 5, 2011 6:46 PM
    • Marked as answer by ExpertSoul Tuesday, April 19, 2011 6:42 PM
    Tuesday, April 5, 2011 6:46 PM
  • Hi Mikael,

     

    Thanks for reply. This exactly was the issue. Could you provide some more insight to this issue or may be some MSDN link?

    I wanted to know what is this certificate used for. Also, how can we control this kind of issues on live environment?

     

    Thanks again!

    Tuesday, April 19, 2011 6:44 PM
  • Hi,

    I wrote a blog post in January about how the default certificate generated by FAST for SharePoint only lasts for a year, and how to change it. The validity of the certificate is mentioned at the TechNet deploy guide.

    The certificates themselves are used to secure the traffic between the SharePoint servers and the FAST servers, as well as for traffic between FAST servers in a multi server deployment scenario. 

    Having all of this in the back of my mind coupled with when the IW image was released I suspected this to be the error once the image started to fail. I checked the expiration on the IW image certificate, and I was right.

    For production environments you have three options:

    1. Generate a new certificate every year

    2. Generate one which last for a really long time so you can forget about it

    3. Purchase a "real" certificate from a CA. You can typically get certificates which lasts for 1-3 years, so you need to monitor expiration and plan for changing it some time in the future.

    If you indeed need a real certificate or can use the self-signed depends on your security protocols and concerns. For most internal search systems I would rely on the self signed. For public facing search I would get one from a CA, and use https.

    -m


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/ - http://www.comperiosearch.com/
    Tuesday, April 19, 2011 8:39 PM
  • We ran into the same issue & as a workaround we removed all the HTTPS communications between the components in FS4SP.

    So for the content distributor address we changed it to : demo2010a.contoso.com:13390 (HTTP Port, refer your install_Info.txt)

    This happened on the last day of our scheduled demo, so till the time we could figure our the way to renew the expired certificates, the above workaroud saved us on the D-Day  :)

    Hope this helps!

    Thanks,

    Ashwani

    Monday, May 9, 2011 7:16 AM