none
Restart computer after log off, 10 min hang RRS feed

  • Question

  • Using the ADM template in a domain environment and locally, when I set; Restart computer after log off, the computer hangs for about 10 minutes.  For both Vista SP1and XP SP3.  After about 10 min the computer does finish the log off process and reboots.

    I have remotely monitored the process information and it does not seem that anything is running.

    My ultimate goal is to have the computer automatically reboot when the user logs off (ok, log off screen saver).  I have tried basic command scripts to execute shutdown/psshutdown, vb scripts and I have granted the interactive permissions – still no joy.
    Monday, April 27, 2009 2:28 PM

Answers

  • Hi Wil, thanks for the post. Does the issue occur on every clients with Windows XP and Windows Vista installed? Have you tried Clean Boot on the clients?

     

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

     

    Note: Please click Continue if the "User Account Control" window pops up.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please test this issue in the Clean Boot environment. If the issue disappears, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps!


    Sean Zhu - MSFT
    Wednesday, April 29, 2009 6:28 AM
    Moderator

All replies

  • Hi Wil, thanks for the post. Does the issue occur on every clients with Windows XP and Windows Vista installed? Have you tried Clean Boot on the clients?

     

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

     

    Note: Please click Continue if the "User Account Control" window pops up.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please test this issue in the Clean Boot environment. If the issue disappears, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps!


    Sean Zhu - MSFT
    Wednesday, April 29, 2009 6:28 AM
    Moderator
  • On an XP SP3 box:
    After I disabled all the extra stuff it didn’t work – didn’t restart.  I added the StaedyState stuff back in and it work – windows started its shutdown process in about 5/10 sec.
    One by one I added the services and programs back.  My issue seems to be with a combination of the Ghost client, SCCM clients and Sophos Anti-Virus.  Individually or any two of them seem to work fine, but they don’t seem to play well together – when trying to automate a shutdown after logoff.

    My main solution is to use a program from the Ghost Solution Suite to restart after logoff.  I have it run as a logoff script; ngctw32.exe with a parameter of; -hide.  I have a delay of about 10/15 sec but works fine.

    But I’m still having significant shutdown-after-logoff delays using SteadyState to restrict super mandatory roaming profiles in Vista.  I’ll continue to work on this and submit a new question once I work through some more items.

    Thanks for your help

    Wednesday, April 29, 2009 5:51 PM
  • I am seeing the same issue with two Vista SP2 boxes. I have disabled everything except Norton Internet Security 2009 and Steady State, and still experience long delays after logout. Strangely, it seems that the quicker I log out, the more likely it is to reboot.

    How did you do the logoff script? I could see running a logoff script with the contents: "shutdown.exe /r /t 5"
    Tuesday, June 30, 2009 1:10 AM
  • I am trying to acomplish the same thing reboot a machine when a user logs off but so far I haven't been able to make this work. I have a question open

    http://social.technet.microsoft.com/Forums/en/winserverDS/thread/744cf9a4-9320-4a8b-bcd9-d5301ba180da

    If possible I would really appreciate your help.

    Thank you.
    Saturday, October 31, 2009 10:59 PM