none
Remote desktop automatically logs off session on client disconnect RRS feed

  • Question

  • Installed Windows 8.1 on a server machine a few days ago, replacing Windows 7. With Windows 7 I could leave user sessions open simply by closing the client with the X/close button, and could then of course resume the same session later, be it through RDP or locally, but this does not seem to be default behavior with 8.1. Whenever I disconnect now, the session is automatically logged out, indiscriminately killing any applications that may be running in the session. It was like this out of the box.

    I've googled this quite a bit now, and I've tried a few proposed solutions (policy changes, registry value changes etc.), but absolutely none of it has had any effect.

    Any idea what's going on? Is this a bug, or is it by design? RDP is pretty much useless when it behaves this way..


    • Edited by spock84 Tuesday, January 6, 2015 7:03 PM
    Tuesday, January 6, 2015 7:02 PM

All replies

  • Hi,

    By default, a standalone installation will not be logged off when it is disconnected form RDP session, something must have been configured in your situation,

    I suggest you check the following policy

    Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Session Time Limits

    Verify that the setting "Set time limit for disconnected sessions"

    And more information about "timeout" in the link below

    http://technet.microsoft.com/en-us/library/cc754272.aspx


    Yolanda Zhu
    TechNet Community Support

    Wednesday, January 7, 2015 7:38 AM
    Moderator
  • No, I did not touch anything. We're talking about a 100% clean install.

    The only thing I can think of which was unusual to me, was that the installer required a Microsoft user account, which I then disabled and replaced with a normal, local user account (which is also the account I'm connecting to with RDP) when the install was done.

    The "Session Time Limits" policy is one of many suggested solutions that I've tried. It was set to "Not configured". I set it to "Enabled" and value "Never". No effect. I also tried disabling it, which didn't help either.

    Wednesday, January 7, 2015 8:31 AM
  • What is the "official" suggested solution here? Re-install? Go back to Windows 7? I'm leaning towards the latter..
    Thursday, January 8, 2015 11:53 AM
  • Hi,

    Apart  from the group  policy about "Session Time Limits", have you checked the Remote Desktop Session Host Configuration on the RD Session Host server as mentioned in the link I pasted above?

    Meanwhile, please install latest Windows Updates.

    If issue persists, please check the event log in terminal server and client PC to see whether any error or warning logs for these sessions terminate.

    Regards


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by Roger LuModerator Monday, January 19, 2015 10:06 AM
    • Unmarked as answer by spock84 Friday, January 23, 2015 12:42 PM
    Monday, January 12, 2015 2:00 AM
    Moderator
  • Hello.

    I have exactly the same observation about a clean Windows 8.1 install.  Did you ever manage to find the answer?  I am assuming this isn't normal for a clean Windows 8.1 box, since it's hard to find anyone else suffering from it like you and me.  :-(

    Many thanks
    Andy

    Sunday, April 26, 2015 11:43 AM
  • I know this is pretty old, but I want to clarify what I believe they are talking about. When RDP'ing into their client it logs them off of the client because the Windows ID is the same as what's being logged into from the RDP client. I've noticed this in the past, as it will happen if I try to use my Microsoft Live account as my computers account on multiple computers. For some reason it will only allow one active session of that particular account at a time. I found these questions on the search to find out if that's something that can be disabled, or if we're better off using local accounts instead.
    Sunday, November 29, 2015 6:42 AM