App-V 4.6 64bit client requiring authentication RRS feed

  • Question

  • Any ideas why the App-V client would suddenly start requesting a username and password every time I launch an application? I am running the 4.6 client on Windows 7 64bit. I have not see this behavior on other desktops, but it was running fine for weeks before this started happening. Wondering is a setting was inadvertantly changed.
    Thursday, April 22, 2010 7:08 PM


All replies

  • Absolutely no ideas? I am getting ready for a larger deployment and want to make sure the problem is not going to crop up on other desktops.
    Friday, April 30, 2010 6:28 PM
  • Hello,

    There is a small note regarding the problem in the client troubleshooting docs;



    Saturday, May 1, 2010 9:19 PM
  • Thank you for the link, but it does not appear to resolve the issue.

    "If a user attempts to start a virtual application to which the system administrator has restricted access, the user might be prompted to enter credentials. The user should type the user name and password for an account that has permission to launch the application and then press ENTER. "

    All accounts on this particular computer have to authenticate every time they run an application. If credentials are entered, the application launches fine. However, the service never updates fromserver so new application are not getting delivered and old applications are not getting removed. It's like the core app-v service has a security issue.

    Is it possible that a patch has modified permissions? I seen this with SQL server based apps quite a bit.

    Monday, May 3, 2010 8:34 PM
  • Hello,

    Since it suddenly appeared one day I would try to locate what changed in the environment. I can't say what happend in your environment as I have no knowledge of it.

    Considering that we are discussing a username / password check - I would verify anything having todo with authentication in your environment.


    Tuesday, May 4, 2010 4:17 AM
  • If I try to refresh the Publishing Server through the client, I get this error:

    The SoftGrid Client could not update desktop configuration information from the server {server_name}.
    The server will not allow a connection without valid NTLM credentials Please report the following error code to your System Administrator.
    Error code: xxxxxx-xxxxxx0A-00002002

    According to this KB article:


    The problem is the user is not part of the domain, but the client works fine on other machines. I have tried installing and uninstalling the client, but it did not resolve the issue.

    Wednesday, May 5, 2010 11:23 PM
  • Hello,

    Well -  a local account needs domain credentials to authenticate against the server.

    If the user does not have a domain account I would suggest to look into the stand-alone model inorder to resolve the above error.


    Thursday, May 6, 2010 3:54 AM
  • Unfortunately, this is a domain computer and I am using domain user accounts to test. The same accounts work perfectly on other computers so it should not be the specific accounts. It really seems like the credentials are not getting passed through to the client, but I am not sure what facilitates this with the App-V client. Outlook, IE and Explorer are all working fine and connecting without requests for authentication to remote systems.

    I was really hoping there was a reg tweak that would impact client authentication or maybe someone know what the dependancy was for the app-v client to authenticate.

    Thursday, May 6, 2010 2:00 PM
  • I am confused - in the previous message you said it was not a domain-user? What?

    Is this only happening with 1 client?

    Is this only happening with 1 user?

    Thursday, May 6, 2010 4:16 PM
  • According to this KB article:


    The problem is the user is not part of the domain

    I could have worded that a lot better. I was referring to the solution in the KB article that suggested the user/computer was not part of the domain. In my case both the user and computer are part of the domain.

    The problem is only with one Windows 7 64 bit computer that uses the 64bit client. I only have a handful of these in production, but I have 90+ Windows Vista 32 bit clients in use. Of the 7 Windows 7 64 bit clients in use, only one is experiencing the problem at this time. But the problem is definitely on the computer, since the same users can login to another computer and everything works.

    Thursday, May 6, 2010 4:41 PM
  • Hello,

    Apart from the architecture - whats the difference?

    Disable FW?

    Trusted for delegation?


    Thursday, May 6, 2010 6:02 PM
  • Nothing different other than the App-V requirements for 64 bit and any other app that is 64-bit vs 32-bit. I rebuilt the laptop and installed app-v fresh. Evertying worked and launched as expected. A few weeks later, I started getting prompted for credentials again. Now every time I open an app, I have to login - even is it is the same app during the same login session.
    Wednesday, November 24, 2010 8:12 PM
  • Hello,

    If you have the problem on one specific client I would say that something on it is different than all the other clients.

    Usually this type of problem relates to something I mentioned above, but its certainly not limited to.

    Again, I can't see all the details of your environment - and your problem description is really vague...

    Wednesday, November 24, 2010 9:58 PM
  • my guess would be that you installed some "windows live" component on the affected client!

    have a look at hklm\system\currentcontrolset\lsa\security packages

    • Proposed as answer by znack Tuesday, July 26, 2011 7:24 AM
    • Marked as answer by Aaron.ParkerModerator Friday, January 13, 2012 5:41 PM
    Friday, July 22, 2011 11:06 AM
  • Just for an FYI.  I was seeing the same issue on a Windows 8 machine running AppV 4.6.  Turns out the issue was tying my domain account with Microsoft account in windows 8.  Once I disconnected all was fixed.

    Thursday, April 11, 2013 8:28 PM