locked
Hyper-V Role Installation RRS feed

  • Question

  • I have an issue when installing the Hyper-V role. I have a fresh install of Windows Server 2008 R2 Datacenter (on a Dell Optiplex 980) and every single time I insall the Hyper-V role, my host loses Internet connection. Once I uninstall the role, the adapater works fines. I am beginning to think that there is a problem with the driver? I've checked the logs and there are no errors indicated.

    Any help would be greatly appreciated.

    Wednesday, May 23, 2012 12:59 PM

All replies

  • The only way I am able to get Internet connection restored with the Hyper-V role installed is by going into the physical adapter properties and checking the Internet Protocol Version 4 (TCP/IPv4) checkbox. However, this does not pass over to the virtual machines that exist on the host.

    • Edited by hhancock Wednesday, May 23, 2012 1:23 PM
    Wednesday, May 23, 2012 1:12 PM
  • hmm, thius sounds as if you have your nic converted to a virtual switch. when you activate the ip4 protocoll, does the nic only have virtual switch protocoll enabled? if so, go in hyper-v network management and select the allow allow management checkbox for your adapter. it creates both the virtual switch and a nic then, so you have both the switch for vm's and the nic for the host
    Wednesday, May 23, 2012 1:23 PM
  • That is correct. The physical nic only has the Microsoft Virtual Network Switch checked. Once I check Internet Protocol Version 4 (TCP/IPv4) the Internet connection is restored (however, this throws some warnings in the Event Viewer). The virtual nic resembles a physical adapater (everything except QoS is checked).

    I've done the following:

    • Updated BIOS from A6 to A10
    • Updated the ethernet controller
    • Updated the chipset
    Wednesday, May 23, 2012 1:44 PM
  • install latest suuport pack or drivers from the hardware vendor

    Darshana Jayathilake

    Wednesday, May 23, 2012 5:16 PM
  • All of the latest drivers are installed.
    Wednesday, May 23, 2012 5:51 PM
  • How many nics you have?

    Wednesday, May 23, 2012 10:34 PM
  • As it was stated before, install the lastest NIC drivers.

    You can also try with another NIC and see what happens.

    I really hope that you are using that Dell Optiplex 980 to test Hyper V ONLY, because that should not be put as server hosting production critical VMs!!!...

    Just saying.. :)

    Wednesday, May 23, 2012 11:28 PM
  • check the box allow management operating system to share this network adapter under settings. I am assuming you only have one nic?
    Thursday, May 24, 2012 3:46 AM
  • Hi,

    In Hyper-V enabled wizard, it will ask you to select Ethernet Cards to create Virtual Networks(like the following screenshot), you can try to unselect the physical network adapters on your computer. After Hyper-V role enabled, you can create an External Virtual Network manually in Hyper-V Manager.

     

    When you create the External Virtual Network bind to a physical network adapter in Hyper-V, if you check the box “Allow management operating system to share this network adapter”, the system will create a new virtual network adapter for Hyper-V host communication. This is useful if there is only one network adapter on the physical machine.

    • Proposed as answer by AzzaJ8 Friday, May 25, 2012 3:35 PM
    • Marked as answer by Vincent Hu Monday, May 28, 2012 2:23 PM
    • Unmarked as answer by hhancock Tuesday, May 29, 2012 1:45 PM
    Thursday, May 24, 2012 12:44 PM
  • I've tried this, still doesn't work. The host refuses to pass the external connection to the virtual machines.
    • Edited by hhancock Tuesday, May 29, 2012 1:49 PM
    Tuesday, May 29, 2012 1:45 PM
  • not sure what you mean with pass to the vm.

    if you select virtual network manager in the hyper-v console, you can create a virtual switch from a nic connection.

    if you select the "allow management operating system to share this network adapter", you will end with a virtual switch that you can use in your vm's and a virtual nic for your host system (that one will get the configuration of the physical nic before the virtual switch was created)

    now the host can still access the internet via the virtual nic created by checking the marked option, while the vm can access the physical nic via the virtual switch.

    is that the problem or am i missing something?

    Tuesday, May 29, 2012 2:25 PM
  • This doesn't work. I've tried everything possible. The host can access the Internet fine. However, when using this adapater for the virtual machines, it doesn't work. I've run some Microsoft scripts on the host to ensure that the virtual networks were setup properly and it didn't find any errors.

    What I mean by "pass" is that the virtual network is supposed to have access to the Internet (which it does on the host). However, once I add that adapater to the virtual machine, it doesn't "pass" the connection to the virtual machine.

    Here are some screenshots:

    Hyper-V Host

    Virtual Network Manager

    I am checking to see if it's a hardware problem.



    • Edited by hhancock Tuesday, May 29, 2012 3:05 PM
    Tuesday, May 29, 2012 2:41 PM
  • Virtual Machine Network Settings

    Virtual Machine

    As you can see on this last image, the adapater continues to say, "Identifying." Eventually, it will just error out. I tried using the network connection repair tool but it did not work. If you notice, this is the same adapater that's working on the host. So why doesn't it work for the virtual machines too?

    • Edited by hhancock Tuesday, May 29, 2012 3:10 PM
    Tuesday, May 29, 2012 3:06 PM
  • Hi!

    Do you have a router or a DHCP server in your network? Have you tried setting IP manually on the guest?

    If you've connected the NIC directly to a DSL modem or the Hyper-V server is located at a hosting company providing a single IP, then your VM's will not be able to reach the internet.

    Hyper-V does not "pass" the internet connection to VM's, in the manner like VMWare does using NAT. Creating an external virtual network creates a virtual switch and connects the physical NIC as its uplink. By checking the box allowing the Hyper-V host to communicate on the network, creates a virtual NIC on the host and connects it to the virtual switch.

    Tuesday, May 29, 2012 3:20 PM
  • Hi,

    My first post on these forums so go easy on me :)

    We're all appear to be basing this around the concept that you have some form of DHCP onsite that can issue out IP addresses on your internal network, assuming this to be behind a router / firewall of some description. Can you confirm what your current network setup i.e do you have a DHCP server or is it DHCP from a router etc..

    Also when you say that you get an IP on the host and it can access the internet but the VM cannot and then vice versa; can you check the IP address which is assigned to the host and compare it to the one on the virtual machine (when that can access the internet) to see if its the same etc...

    To me it sounds like its more of an IP address / DHCP configuration as opposed to the configuration of the Hyper-V host.

    -Aaron

    Tuesday, May 29, 2012 3:25 PM
  • DHCP is handled by Windows. We have multiple boxes in our environment that have no issues like this.
    Tuesday, May 29, 2012 3:27 PM
  • The IP on the host is correct. It pulls an IP from the DHCP server. The virtual machine, however, is pulling 169 address (same adapater mind you).
    • Edited by hhancock Tuesday, May 29, 2012 3:33 PM
    Tuesday, May 29, 2012 3:29 PM
  • When the virutal machine can access the internet, does it get the same IP address that the host has? or is it different?

    You can also try removing all network adapters on the virutal machine including non present devices and reinstalling the network adapters to see if that helps? I've seen similar problems with Legacy adapters that were not removed after building a VM from a PXE environment.

    Tuesday, May 29, 2012 3:43 PM
  • The virtual machine can never get Internet access, that's the problem. I've removed and reinstalled the network adapaters too many times to count. Nothing ever works. I've also updated all of the drivers but still nothing.
    Tuesday, May 29, 2012 4:36 PM
  • I've found that not all NIC's work very well with Hyper-V (or at all) without modifying NIC settings. In these cases, I prefer to add another NIC, like a Intel PRO 1000 card.

    The next step would be to disable TCP offloading (if you haven't done that already) and as a last step, disable TCP chimney, as these are the common troubleshooting steps when a NIC won't properly handle virtual networking.

    Saturday, June 2, 2012 8:46 AM