none
SCCM 2012 Deploy --- Error = The software change returned error code 0x87D00324(-2016410844).

    Question

  • Deployment to the client is successful but the error reported within Clients "SCCM Software Center"  

    The software change returned error code 0x87D00324(-2016410844).

    Also States on "Status" Past Due - Will be Retired"

    Can't figure this one out and I did some googling with no success in finding a solution?

    I am running an Adobe Flash install (.EXE)

    Any help or direction would be greatly appreciated


    RF

    Monday, September 3, 2012 3:12 PM

Answers

All replies

  • This has already been discussed here in the forums and the search function brings up the solution ...
    0x87D00324 indicates that the installation was successful, but the detection method did not detect the software as "installed". Just see AppEnforce.log and double check the detection menthod.

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, September 3, 2012 3:16 PM
    Moderator
  • Thank you for the follow up regarding my issue.

    This is what I have found in the logs ...the issue seems to be relevant to the dection method, the detection method/rule I had set for the deployment was to check the registry key value for the "version number" of Adobe Flash....

    Don't understand why Software Center states "Past Due - will be retired"...

    <![LOG[    Prepared command line: "C:\Windows\ccmcache\6\install_flash_player_11_active_x.exe"]LOG]!><time="10:37:16.223+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appcontext.cpp:331">
    <![LOG[    Executing Command line: "C:\Windows\ccmcache\6\install_flash_player_11_active_x.exe" with user context]LOG]!><time="10:37:16.224+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appexcnlib.cpp:201">
    <![LOG[    Working directory C:\Windows\ccmcache\6]LOG]!><time="10:37:16.224+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appexcnlib.cpp:215">
    <![LOG[    Post install behavior is BasedOnExitCode]LOG]!><time="10:37:16.232+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appcommon.cpp:1091">
    <![LOG[    Waiting for process 2372 to finish.  Timeout = 120 minutes.]LOG]!><time="10:37:16.236+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appexcnlib.cpp:1682">
    <![LOG[    Process 2372 terminated with exitcode: 0]LOG]!><time="10:37:27.453+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appexcnlib.cpp:1691">
    <![LOG[    Looking for exit code 0 in exit codes table...]LOG]!><time="10:37:27.454+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appexcnlib.cpp:315">
    <![LOG[    Matched exit code 0 to a Success entry in exit codes table.]LOG]!><time="10:37:27.455+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appexcnlib.cpp:394">
    <![LOG[    Performing detection of app deployment type Adbe Flash 11.4.402.264(ScopeId_E8DC2401-BEF4-46BC-A81A-2759C94D84FF/DeploymentType_d7b60459-7e3d-44dc-9273-cd63fdb69465, revision 2) for system.]LOG]!><time="10:37:27.461+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appprovider.cpp:2064">
    <![LOG[+++ Application not discovered. [AppDT Id: ScopeId_E8DC2401-BEF4-46BC-A81A-2759C94D84FF/DeploymentType_d7b60459-7e3d-44dc-9273-cd63fdb69465, Revision: 2]]LOG]!><time="10:37:27.481+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="localapphandler.cpp:291">
    <![LOG[++++++ App enforcement completed (11 seconds) for App DT "Adbe Flash 11.4.402.264" [ScopeId_E8DC2401-BEF4-46BC-A81A-2759C94D84FF/DeploymentType_d7b60459-7e3d-44dc-9273-cd63fdb69465], Revision: 2, User SID: ] ++++++]LOG]!><time="10:37:27.481+240" date="09-03-2012" component="AppEnforce" context="" type="1" thread="7236" file="appprovider.cpp:2345">

    Regards

    Ron


    RF

    • Proposed as answer by nabilser Wednesday, March 21, 2018 1:35 PM
    Monday, September 3, 2012 3:46 PM
  • How did you set up the detection method (details)? An application installation will only be successful if the software to be installed will be detected successfully.


    Torsten Meringer | http://www.mssccmfaq.de

    Monday, September 3, 2012 4:06 PM
    Moderator
  • I had setup the "detection method" as

    Setting Type: Registry

    Hive: HKEY_LOCAL_MACHINE

    Key: SOFTWARE\Wow6432Node\Macromedia\FlashPlayer

    Specified Reg Key: ( Supplied the registry key path for it to check)

    Checked: Use (Default) registry key value for detection

    Data Type: Version

    Selected: This registry setting must satisfy the following rule to indicate the presence of this application

    Value:  11.4.402.265  (Check for this Latest Adobe Flash Build/Version # 11.4.402.265)

    P.S. I have just added the second x64 bit path for Registry Checking, as I only had the x32 WOW path....same error on both x86 and x64 systems.


    RF

    Monday, September 3, 2012 4:26 PM
  • Wow6432Node is not valid on x86 systems.

    You should configure your registry check to verify the key at SOFTWARE\Macromedia\FlashPlayer and check the checkbox that says to use a 32-bit environment on 64-bit systems.

    Also, why use the default value? I doubt there's anything in there (the default value is the value display in a key in regedit with the name of "@").

    For a complete walk-through, check out this post: http://blog.configmgrftw.com/?p=469


    Jason | http://blog.configmgrftw.com

    Monday, September 3, 2012 6:43 PM
  • Hi,

    Thank you for your response

    ""Wow6432Node is not valid on x86 systems."""

    Yes, that I am aware of that.....Windows on Windows, for running x86 apps on x64 Windows<o:p></o:p>

    When I first created the detection method I had only created the "WoW" Check
    for Flash value in the reg, which was running against both x86 & x64 Win 7
    systems, and forgot to include the x64 check/, either case, the error appeared
    on the WOW check. Presently I have 2 "Detection Clauses" one for x86
    and the second clause is x64 ( non WOW Path), and still receive the same erorrs
    on both x86 & x64 systems. ( and x64 system have both reg entries since Win 7 has both x86 & x64 versions of IE)

    Looking at the registry of an x64 Win 7 system I find the Adobe Flash registry entry is
    located in both Wow6432Node and also in the x64 sections of the reg.....<o:p></o:p>

    """"Also, why use the default value? I doubt there's anything in there (the default value is the
    value display in a key in regedit with the name of
    "@").""""
    <o:p></o:p>

    When Default Value is selected the boxes/options below that allow for more detailed
    information to be entered when performing the "reg check"? This is
    where I had been able to enter specific Build/Version to look for, Flash
    11.4.402.265, so that if it does not discover the build # it will proceed with
    the install.....<o:p></o:p>

    I figured having the option to check for Build/Version # would omit SCCM reinstalling on
    systems that have build 11.4.402.265 already?<o:p></o:p>

    From what I understand is that Adobe Flash x64 installs both versions x86 & x64 since Win 7 has both IE
    x86 & IE x64 bit versions by default, and this would explain the Wow6432Node reg
    entries and the true x64 reg entries in both locations when installing.

    Overall, I am thinking I may be heading in the wrong direction in resolving this, as x86 & x64 versions install on the systems, so this tells me it is detecting when / what needs to be installed, the issue seems to be how it reports back after installing......

    Looking further, I view the Content Status Page, and there reporting info in Asset Detail under [Success]  all others { / In Progresss / Error /Unknown } has no info......

    If this helps provide further details.....

    Thanks

    Regards,

    Ron


    RF

    Monday, September 3, 2012 7:30 PM
  • Hi,

    I created a package for 64bits on Win 7 and deployed successfully using the detection method : Windows Installer with the Product Code: {676E4C31-0CD1-454E-BE3A-70D3AC93F915}  it worked 100% on all my systems.

    

    Regards.

    • Proposed as answer by Joel E.G Friday, May 10, 2013 3:26 PM
    Friday, May 10, 2013 3:26 PM
  • I have the same error message while installing kaspersky.

    I gave detection method as setup.exe /a/s

    please help me. in the log it shows     Unmatched exit code (4294967295) is considered an execution failure.

    Sunday, November 17, 2013 9:49 AM
  • Mohammed, why don't you just use the thread you started? http://social.technet.microsoft.com/Forums/en-US/e9756990-21a0-4a32-b0c7-6402f1817fef/sccm2012-application-package-is-failing-in-software-center?forum=configmanagergeneral
    It's much measier for you and others to follow if you would keep all the information in one place.
    Thanks.


    Torsten Meringer | http://www.mssccmfaq.de

    Sunday, November 17, 2013 10:27 AM
    Moderator
  • Good morning. I also encountered exactly same error messsage. I encountered this message during deployment of MicrosoftFixit50778.msi to remove Internet Explorer 9. I think this is because it is not an installation, but rather a process to uninstall Internet Explorer 9 and revert back to Internet Explorer 8. Can anyone guide me on how to set a detection method which can help to show the deployment status as complete so that I can monitor the actual deployment rate? Thanks.

    Edited: I deployed this MicrosoftFixIt as an Application.


    • Edited by dione_a Thursday, August 14, 2014 4:22 AM add on message
    Thursday, August 14, 2014 3:17 AM
  • You would have to test that on a test machine. My idea: check the version of iexplore.exe.

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, August 14, 2014 6:11 AM
    Moderator
  • I have tried deployment by package the MicrosoftFixit50778.msi and it manages to uninstall for me. However, deployment by application is not working.

    Can you guide me how to do it? Thanks.

    Friday, August 22, 2014 2:31 AM
  • I haven't looked up was that fixit does, but why not checking the file version of iexplore.exe as I already mentioned?

    Torsten Meringer | http://www.mssccmfaq.de

    Friday, August 22, 2014 6:15 AM
    Moderator
  • I found a link: http://eskonr.com/2010/04/sccm-reportcollection-for-computers-with-internet-explorer-with-different-versions/ which describes how to query the version of internet explorer. However, I do not know how to fit this into my detection method by deploying MicrosoftFixit50778.msi as an application in Software Library.

    Also, as running this msi will uninstall IE9 to become back IE8 (my test machine is Windows 7), this means I need to have the detection of IE version at the end of installation, is that correct? My screenshot is the default print screen for the msi when it was packaged, but it detects whether the msi is already installed or not, which is not what you suggested (checking version of IE).

    Can you guide me on where I can fit in the detection of IE version so that after running the msi, it will mark the installation as successful rather than marked as failed (the uninstallation process still works successfully after restart, but sccm report will be wrong due to it not completed correctly.)

    Please help. Thanks

    Friday, August 22, 2014 10:18 AM
  • just to be clear...what you wrote is not an answer.
    Wednesday, February 4, 2015 11:38 PM
  • This is not an answer! Seriously! This gives no solution to the issue. I'm having the same problem with Acrobat Pro and I checked the detection method which obviously didn't fix a damn thing.
    Wednesday, February 4, 2015 11:40 PM
  • maybe because no one wrote on his thread and it's best if you can find better answers then the "answer" you gave. I use the word answer loosely around TechNet.
    Wednesday, February 4, 2015 11:46 PM
  • Hi

    I have just deployed Adobe Flash. Sign up for Adobe Enterprise solution, its free.

    They will send you links to the MSI files for deployements so you would use the Adobe_Flash.msi. Then use the following script to deploy the product -

    msiexec /i "install_flash_player_19_active_x.msi" /qn /norestart /log "C:\WIndows\Temp\flash.log"
    copy mms.cfg %WINDIR%\SysWOW64\Macromed\Flash

    NOTE - you will need to create a mms.cfg if you would like to customise the installation, i.e. stop auto updates. This can be found all in the administration guide from Adobe.

    For the detection rule select the msi file and select equal to and same version.

    Hope that helps.

    Regards

    Dinesh

    Friday, December 4, 2015 5:01 PM
  • My question is how to setup the detection method when it's just a powershell script clearing the TPM.   No registry changes, no software install....   Ideas?
    Wednesday, February 10, 2016 3:51 PM
  • Don't use an Application to run a simple script; that's what packages and programs are for.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Wednesday, February 10, 2016 3:54 PM
  • Don't use an Application to run a simple script; that's what packages and programs are for.

    Jason | http://blog.configmgrftw.com | @jasonsandys


    Going by the many Technet articles, a powershell script is the easiest way.   What would you recommend then? 
    Wednesday, February 10, 2016 4:02 PM
  • Exactly what I said. Put the PowerShell script in a package and run it using a program in ConfigMgr.

    Jason | http://blog.configmgrftw.com | @jasonsandys


    Wednesday, February 10, 2016 4:28 PM
  • I was not able to find the link for the discussion, would be help me with that.
    Friday, July 15, 2016 1:35 PM
  • Hi Jasoon,

    I am in similar situation and trying to deploy a script through SCCM either as an application or package which copies files and folders to user profiles and in program files, which way would be best. I am trying so far as application with script file as app deployment type, it works but fails at the detection rule. well, there is no application installed, its just files being copied over into 2 different folders when user logged on. (e.g. program files & userprofile). can you please check and reply on this. thx


    Sathya

    Thursday, August 11, 2016 11:49 PM
  • Hi Sathya,

     

    I was literally pulling my hairs out on this issue and spent around 7 hours to resolve it. I tried detection with .LNK file .EXE file and .TXT file but nothing worked. Application will install successfully and will copy required files to relevant directories and will run without any issues but Software Centre will display that Installation was failed with error code 0x87D00324. I even modified my installation script so it creates .TXT file in TEMP folder at the end and tried detection with that file but no luck.

    Here is what worked for me:

    I had similar detection method on another deployment (thanks to my colleague who set it up in past) and I verified settings tab by tab and I found my issue! For some reason, in Detection Rule tab, where it says Specify the file or folder to detect this application, Type was changed from File to Folder! I believe it changes if you use browse feature find detection file.

    I deleted my detection rule, recreated detection rule with File instead of Folder, redistributed application and ran installation again. The installation status was changed to Installed.

    Unfortunately I cannot post screenshot as my account is not verified yet.

    Hope this helps someone.

     

    Mahesh


    • Proposed as answer by Mahesh- Saturday, August 13, 2016 5:31 AM
    Saturday, August 13, 2016 5:31 AM
  • I don't know if it applies to this post but the same thing happened to us a few weeks ago. A detection method was totally messed up because it was looking for a "Folder" instead of a "File".
    Thursday, October 13, 2016 3:06 PM
  • I wanted to add a reply to this thread.  I am currently installing an app, and I get the error code above, also software center shows "Failed" for the install.  However if I go to the path there the files are to be installed I see them all.  When I double click the exe the program launches.  Weird thing is there is no shortcut in the start menu.  Don't know if someone else has observed this after getting this error?

    Thoughts appreciated, thanks


    JCtech1123, Cheers

    Tuesday, November 8, 2016 10:35 PM
  • The software change returned error code 0x87D00324(-2016410844).

    This error could be cause of another application running. For example Lync running with start up will affect other office application suite. 

    Please close the Blocking software's, start up software's and antivirus and try. The deployment will be running fine.


    Monday, December 5, 2016 1:26 PM
  • Thank you Mahesh!

     :-)

    /espen

    Monday, January 30, 2017 7:05 PM
  • I know this is an old thread but if someone is looking for the answer, this article may be helpful 

    http://www.ciscostuff.gurjap.org/sccm-error-code-0x87d00324-for-office-365-deployment/.

    Good Luck
    Friday, July 7, 2017 7:01 PM
  • I hope this http://www.ciscostuff.gurjap.org/sccm-error-code-0x87d00324-for-office-365-deployment/ can help someone else having the similar issue.
    Friday, July 7, 2017 7:06 PM