locked
Disable hyperlink while exporting SSRS report to Excel RRS feed

  • Question


  • Hi Everyone,

                     Could you please answer for my question?

                                    " I want disable hyperlinks in ssrs report after exporting to excel format".Please help me out.

    Note: This is possbile with SQL SERVER 2008 R2.But I need to do in SQL SERVER 2008.

    Thanks in Advance.

    Santosh Belde.

    Friday, December 6, 2013 1:35 PM

Answers

  • Hi Santosh,

    According to your description, you want to disable the hyperlink while exporting the report to excel in SQL Server Reporting Services (SSRS) 2008. Just as you said, we can easily achieve the goal on SSRS 2008R2 version by using the RenderFormat built-in field as HTH post. 

    While we can’t use the same method in SSRS 2008, because it doesn’t have RenderFormat built-in field. After testing it in my own environment, we can refer to the following steps as a workaround:

    1. Create a parameter named Hide in the Report Data pane and select Boolean in the Data type drop-down list. 
    2. Choose Specify values in the Default Values tab, click Add button and set value to “False”. 
    3. In action property of the text box which contains the hyperlink, use the expression below to disable the hyperlink:
      =IIF(Parameters!Hide.Value=True,””,”hyperlink”)

    In this case, before user export the report to Excel, they can change the Hide parameter to True to disable the hyperlink manually, and then export it to excel. If this is not what you want, I am afraid there is no other approach to work around this issue. Thanks for your understanding.

    Regards, 
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support

    Sunday, December 8, 2013 9:42 AM

All replies

  • Hi

    You can use the render format built in field to control the hyperlink.

    In the action property of the text box you can use an expression to disable the hyperlink when the report is exported to excel, a sample expression is shown below:

    =iif(Globals!RenderFormat.Name="EXCEL", "","URLlinkhere")

    HTH

    Friday, December 6, 2013 3:11 PM
  • Hi Santosh,

    According to your description, you want to disable the hyperlink while exporting the report to excel in SQL Server Reporting Services (SSRS) 2008. Just as you said, we can easily achieve the goal on SSRS 2008R2 version by using the RenderFormat built-in field as HTH post. 

    While we can’t use the same method in SSRS 2008, because it doesn’t have RenderFormat built-in field. After testing it in my own environment, we can refer to the following steps as a workaround:

    1. Create a parameter named Hide in the Report Data pane and select Boolean in the Data type drop-down list. 
    2. Choose Specify values in the Default Values tab, click Add button and set value to “False”. 
    3. In action property of the text box which contains the hyperlink, use the expression below to disable the hyperlink:
      =IIF(Parameters!Hide.Value=True,””,”hyperlink”)

    In this case, before user export the report to Excel, they can change the Hide parameter to True to disable the hyperlink manually, and then export it to excel. If this is not what you want, I am afraid there is no other approach to work around this issue. Thanks for your understanding.

    Regards, 
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support

    Sunday, December 8, 2013 9:42 AM
  • Hi Katherine,

    Thanks for sharing valuable information.

                        I have followed same procedure which you had told, but it is not working. I am still facing the problem for disable hyperlink, when we do export to excel in SSRS.

    Please tell me if any other possible way to find out this in SSRS 2005 or 2008 not in 2008 R2.

    Thanks in Advance.

    Regards,

    Santosh.

    Wednesday, December 11, 2013 11:23 AM
  • Hi Santosh,

    Thank you for your post.

    I’m sorry that I cannot find another possible way to work around this issue. But based on my research, it seems that may be you have done something wrong with my former solution. Which value are you selected in the parameter when you want to export the report to excel? Please make sure you selected True value if you use my suggested expression.

    And please double check the procedures in your environment, and tell me the details about your current situation. It is benefit for us to do further analysis.

    Thanks,
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support

    Wednesday, December 11, 2013 2:26 PM