locked
My Windows phone 8.1 can't seem to find any certificates, needed for VPN RRS feed

  • Question

  • Hello,

    I set up an IKEv2 VPN at home so I could use it on my desktop as well as on my Windows phone.
    Now, I have two options which are supported by the VPN: 1) I can use username/password, but then I have to install the root certificate. 2) Use the client certificate.

    Now I've tried both but none seem to work. When I use username/password I get error 13801, which apparantly means that it can't find the root certificate. When I try to set up the VPN using the client certificate, I can't set it up because when I want to choose a certificate, it says there aren't any.

    I have installed both (several times by now) using the PFX and PF12 formats. I've tried regenerating them. None of this helps.
    My phone won't accept any crt or pem files so that's not gonna work either.

    I've tried restarting the phone, that didn't help either.

    Any suggestions?

    Thanks!

    Tuesday, July 15, 2014 7:55 PM

All replies

  • Okay, I didn't get it to work with user/password authentication, but I did manage to use a client certificate.
    What I had to do was regenerate the certificate with Extended Key Usage: ClientAuth.

    Now, I'm facing a new issue because the server isn't accepting me for some reason, which apparantly has something to do with authentication or encryption. I haven't figured that out yet so I'll have a look at the server software instead.

    But if anyone knows what kind of thing Windows phone could be asking for that Windows desktop doesn't, that could be useful.

    Wednesday, July 16, 2014 2:00 PM
  • Hi Kimberley1984

    I'm having that exact same problem.

    Did you find a solution?

    Monday, January 26, 2015 10:15 PM