locked
Weird 3 way calling issue RRS feed

  • Question

  • Hey,

    I have a strange problem:

    When someone calls in to the office main number a response group answers. After 10 seconds if the call is not picked up by an agent it is forwarded to an outside answering service. If an agent picks up the call on the last ring we get a weird 3 way calling situation where the caller, the agent and the answering service are all connected. Seems like the response group has already began forwarding the call, but the Lync client hasnt stopped ringing yet allowing the agent to join the forwarded call.

    Hope that makes sense!

    Any ideas out there?

    Thanks,

    Andrew

    Tuesday, August 23, 2011 12:00 AM

All replies

  • Hi Andrew,

    Please read the following article, hope you can get trace logs about the issue:

    http://blogs.technet.com/b/dougl/archive/2009/08/12/outbound-pstn-calling-from-response-groups.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 23, 2011 9:43 AM
  • Hi,

     

    i have similar problem. I think rgs call setup is too slow, this is a bug?

    http://social.technet.microsoft.com/Forums/en-US/ocsvoice/thread/26c15470-e1b0-4aab-80fa-4f9fadcec7f5

    http://social.technet.microsoft.com/Forums/en-US/ocsvoice/thread/f8cb5e68-04ae-46c4-bd54-9b53ba9bbc80

     

    Tuesday, August 23, 2011 11:21 AM
  • Can you set the 10s Timeout to a higher value, like say 20s, do you still see the issue, in the exact same system that failed with 10s ?
    Tuesday, August 23, 2011 2:53 PM
  • Hey,

    Thanks for your replies. I'll take a look at those links a report back.

    Premal, Do you think this issue could have anything to do with the client update you mentioned here - http://social.technet.microsoft.com/Forums/en-US/ocsvoice/thread/d0ca42ff-f26e-4c37-9683-f5b52857ce7f/

    Seems like it could be related in my mind.

    Thanks,

    Andrew

    Tuesday, August 23, 2011 8:30 PM
  • Hi,

     

    very intresting, we have ocs 2007 r2, with the newest client OC/3.5.6907.233, same problem. But if I downgreded client  to OC/3.5.6907.0, problem solved!

    Wednesday, August 24, 2011 7:50 AM
  • Hmmm that is interesting. I have a feeling it is due to the delay the client takes to establish the call - while the client is in the process of connecting to the call the response group transfers it to the answering service. The client somehow isn't aware of this, and is somehow able to join the call!

    Microsoft any ideas???

     

    Thanks,

    Andrew

    Wednesday, August 24, 2011 9:20 AM
  • I checked out the links provided. We don't have a long delay in call establishment (maybe 2 seconds), but wouldn't rule this out as being related. However it looks as though there is no answer to that problem so I am still stuck.

    Hopefully someone else out there can help.

    Thanks,

    Andrew

     

    Wednesday, August 24, 2011 9:28 AM
  • Do you have done the following test?

    1.Setting the response group Forward the call to a normal number(internal number or mobilephone number) after 10 seconds.

    2. Setting a normal lync client forward the call to the outside answering service.

    Then verify if the problem occurs again.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, August 26, 2011 2:32 AM
  • Hello,

     

    my response group forwarded to normal cell phone number, same problem...forwarding to another ocs client, same problem...

    Friday, August 26, 2011 7:31 AM
  • Yep I can confirm same issue regardless of the number.

     

    Thanks,

    Andrew

    Sunday, August 28, 2011 9:59 PM
  • I have logged a call with Microsoft. I will post back when I get a resolution.

    Andrew

    Monday, September 12, 2011 3:07 AM
  • Hello Andrew,

     

    what is Microsoft's opinion?

     

    Thanks a lot!

    Wednesday, September 21, 2011 9:07 AM
  • Still working with them but I will let you know soon as I have an answer. Have you got the same issue?

    Andrew

    Wednesday, September 21, 2011 8:26 PM