none
Access denied while attempting to update content type doc template or creating content type policy templates

    Question

  • Hello,

    On my SharePoint Online site, I am trying to do the following:

    1. At the site collection level, I'm trying to implement Content Type Policy Templates.

    2. Trying to update content type document templates.

    On both of these operations, I get the "Sorry, you don't have access to this page" message.  When I fill out the form and click "Request Access," I can then navigate to the "Access Requests and Invitations" screen and approve the request (with Full Control permissions), but I still get the same "Sorry, you don't have access to this page" message no matter what I do.

    Thoughts?  The account in question is the tenant's global admin, a site collection administrator, and has full control access to the site in question.


    EDIT:  One occurrence was at 10:48 AM with correlation ID f6eed59d-e013-3000-c2ef-769e1ff3528a.  What is the easiest way to get the ULS logs for this correlation ID?
    • Edited by blanghorst Friday, February 17, 2017 3:48 PM
    Friday, February 17, 2017 2:42 PM

All replies

  • Hi,

    Please try to create a new similar account to update content type document templates, test whether the issue occurs.

    If the new account works fine, I suggest you use the new account instead.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 21, 2017 8:08 AM
    Moderator
  • Dean, I've tried it on 2 different tenants and have the same results both times.
    Tuesday, February 21, 2017 1:02 PM
  • Any other ideas?  I'm really stuck and it is ridiculous that this doesn't work for me, especially when I have all the proper permissions.
    Wednesday, February 22, 2017 3:39 PM
  • I've seen the same error when trying to update the template for a custom content type.  It works for any site collection that I create via the SharePoint admin portal - but NOT for sites created as a result of creating an Office 365 group.  The result is the same for other O365 global admins.  I've noticed that the site template used is different - GROUP#0 (I get the error for any sites via this template) and #STS0 (It works).  Has anyone else experienced this?
    Thursday, March 2, 2017 2:53 PM
  • I opened a ticket with O365 support and was able to resolve the problem.  The issue was that Custom Scripts in the "Settings" section of the SharePoint Online Admin Portal has to be set to "Allow" in both sections.  We then ran a powershell script to make the change take effect immediately - if you don't run that script, a timer job should fix it overnight.
    Thursday, March 2, 2017 4:32 PM
  • Thanks, but we already had both sections in Custom Scripts set to "Allow" in the SharePoint Admin portal.  If we create a new group, we still get the error for the new site.
    Thursday, March 2, 2017 6:29 PM
  • Can you share with us this powershell code and how to run it in SPO, please?

    ...

    At this moment, I had set to "Allow" in both sections. Like I not have this powershell code to run now, I will wait until tomorrow to check if it works.

    Tuesday, September 12, 2017 7:23 PM
  • Sorry, I made those changes over 7 months ago at a previous employer and don't remember them.  I think I actually opened a support ticket and the resource assigned to the case is the one who referred me to the script.
    Tuesday, September 12, 2017 11:45 PM
  • Cool! Thanks, dude
    Friday, September 15, 2017 5:56 PM
  • The Powershell for it is:

    Set-SPOSite -Identity "https://mytenant.sharepoint.com/sites/MySite" -DenyAddAndCustomizePages $false

    • Proposed as answer by Arleta WanatMVP Friday, September 29, 2017 11:15 AM
    Friday, September 29, 2017 11:14 AM