locked
Alert on list view (filtered on multivalue lookup column) - no notifications when item contains multiple values RRS feed

  • Question

  • A user subscribed to an alert on a list view. The view has a filter: Multivalue Lookup = Value XYZ.

    Alerts come in when there is only one value in the lookup field.
    When there are multiple values, no alerts are received.

    Anyone aware of a solution/workaround? 

    Monday, November 14, 2011 9:37 AM

Answers

  • Hi 2Maarten,

    I’m trying to reproduce your issue, however, everything works well, I create a view and set alert on this view as you descripted, changes on this view can be alerted successfully whatever the lookup field is one value or multiple values.

    To troubleshoot this issue, please try to make more changes on the items in this view, check the mailbox to see the result, you can wait for several minutes because the timer job running times may cause the alert mails delay.

    Then, please make sure that the SMTP server permit connections from your SharePoint Servers, here is an article about “troubleshooting SharePoint email alerts-Checking the email infrastructure”, you can follow the steps to check:
    http://sharepointalert.info/2009/11/troubleshooting-sharepoint-email-alerts-check-email-setupinfrastructure/

    More information, SharePoint 2007 alerts not working:
    http://vspug.com/tigirry/2009/12/17/sharepoint-2007-alerts-not-working/

    Thanks,
    Qiao

    Wednesday, November 16, 2011 2:30 AM
    Moderator