locked
Turn off automatic switching to Basic theme RRS feed

  • Question

  • I have a complaint about the way Win7 automatically decides to disable my Aero theme when the computer is actually using resources. Mostly this happens when I play a videogame fullscreen, then have to switch to another program. Obviously there's some system slow down involved for a few seconds, but that doesn't mean that I want to permanently change themes! At the very least it should re-enable Aero as soon as processor/memory use goes back down to normal levels. A couple times I actually saw a message asking me if I want to switch to Basic theme, but most of the time it just does it without asking me. Worse yet, after I selected No, it switched anyway few minutes later. And as if that's not enough, I wasn't able to select my old theme, it actually modified my current theme. I couldn't find out where to enable Aero back, so I had to redo all my theme's settings from default.
    Tuesday, September 22, 2009 12:44 AM

Answers

  • Hi Prikolist,

     

    This issue shall be caused by the graphic card memory is not enough or the graphic card driver is not up to date. Please update your graphic card driver to see if the issue can be resolved. You also may need to contact the hardware manufacturer to confirm this issue.

     

    In addition, could you please let me know the brand and model of your graphic card?

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Friday, September 25, 2009 1:22 AM
    Tuesday, September 22, 2009 8:59 AM

All replies

  • Hi Prikolist,

     

    This issue shall be caused by the graphic card memory is not enough or the graphic card driver is not up to date. Please update your graphic card driver to see if the issue can be resolved. You also may need to contact the hardware manufacturer to confirm this issue.

     

    In addition, could you please let me know the brand and model of your graphic card?

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Friday, September 25, 2009 1:22 AM
    Tuesday, September 22, 2009 8:59 AM
  • I have the same problem as the OP. I have a brand new video card with the most recent drivers as of yesterday, its an ATI with 1gig of RAM. The automatic switching is really annoying since it modifies my theme without permission!

    Btw, I found this solution here to re-enable it without too much fuss:

    To display Aero effects such as transparency in Windows 7, follow these steps:

    1. Make sure that Windows Experience Index has been calculated and computed.
    2. Click on Start menu.
    3. Type the following text into the Start Search box:

      Aero

    4. Click on a search result listing under Control Panel group that named as the following:

      Find and fix problems with transparency and other visual effects

    Saturday, September 26, 2009 3:28 PM
  • Linda,

    You have misunderstood what the problem is. This issue is caused by windows 7. Despite the video card either temporarily or persistantly running low on memory, out of date drivers, or even the most up to date driver being coded incorrectly. Windows 7 is changing Windows 7 to the Basic theme all on its own, and there isn't a known way to disable that in the operating system, also it's Windows 7 that makes repeated popups saying "windows has detected your computer's performance is slow" and there isn't a known way to disable that in the operating system itself either - this here is the problem, the problem is that Windows 7 is adjusting the system and making a performance pop up based on what the video card is doing, after the user has acknowledged this then Windows 7 should not bother the user by switching to the Basic theme ever again nor should it continue the pop ups.

    The video card memory, or drivers themselves are not changing Windows 7 to the Basic theme, they are causing Windows 7 to malfunction because Windows 7 has what appears to be a design flaw. Video cards run low on memory all the time when used intensively, that doesn't mean that Windows 7 should change to the Basic theme by itself, it means Windows 7 should ask the user once and only once if they want to switch to basic theme, and then respect the decision of the user and stop making pop ups.

    Having said that, I too am being harassed by Windows 7, I'm running a pair of Radeon 5870s (with up to date drivers) with 12gb of triple channel RAM and an i7 with multiple monitors, while having multiple rdp sessions running, while doing raytracing etc.etc.etc. I run this thing intensively about three hours a day during weekdays. I know my video cards are running low on memory, I just want Windows 7 to stop telling me about it, and to stop modifying my settings.

     

    Here is what I've done for troubleshooting steps so far:

    Double checked my drivers

    If you run the "Find and fix problems with transparency and other visual effects" troubleshooter, it doesn't identify any problems, other than it couldn't find any problems.

    Event Viewer system information events are as follows:

    The Multimedia Class Scheduler service entered the stopped state.
    The Application Experience service entered the stopped state.
    The Application Experience service entered the running state.
    The Multimedia Class Scheduler service entered the running state.

    If you search for "windows has detected your computer's performance is slow" on Bing, you get 7,290,000 results, 8,520,000 in Google. The first 50 of each will paint you a much clearer picture of the real problem, which is that Windows itself needs to stop changing the theme on its own, and stop the pop ups once the user has interacted with them once.


    • Edited by Kentain Wednesday, October 12, 2011 5:34 PM
    • Proposed as answer by Kentain Tuesday, December 13, 2011 10:50 PM
    Wednesday, October 12, 2011 5:16 PM
  • Kentain,

    I have exactly the same problem as you. Fast workstation, mostly used as a workstation throughout the day and with multiple high-res monitors. When playing a game and alt-tabbing, Windows and its infinite wisdom disables Aero.

    Did you find a fix to this?

    Matt

    Tuesday, December 13, 2011 8:19 PM
  • Matt,

    I just keep re-enabling my theme after the heavy work is done.

    Tuesday, December 13, 2011 10:54 PM
  • "Marked As Answer by Linda Yan <abbr class="affil">Microsoft Contingent Staff, Moderator</abbr> Friday, September 25, 2009 1:22 AM"
  • This says it all. Officially there is no problem, Linda has said so herself.
  • Of course I have the same non-problem as everyone else, even with 1 GB of ddr5 & updated drivers.
  • The fact is that Windows 7 is no longer receiving much, if any, attention. Windows 8 is the new game in town. The King is dead, long live the King!
  • I started with Windows 3.0 in 1990, and in all seriousness Windows 7 may be my last windows. I have NO interest in Windows 8.
  • If anyone reads this, I'd suggest looking elsewhere for an answer.
Tuesday, January 24, 2012 1:29 AM
  • I don't see how this post qualifies as "Answered."  You didn't answer anything, you just told him about video drivers.  The question was, "how do you disable Win7 automatically switching to Basic Theme?"  Can this be done, yes or no?  I've got a Radeon 5700 and 6800, each with a gig of dedicated video memory.  I've got an i7 870 8 core processor with 8 gig ram.  As I was writing this, the system automatically switched back to Basic Theme - my CPU usage is at betwen 0 and 1%, and I'm only using 24% of physical memory.  My system runs through the performance indexing with a 7.9 (specifically testing Aero features) and the Aero testing program did not find any errors.  There was NOTHING else running on my displays other than this session of IE. 

    Turning off the "windows has detected your system is running slow" notifications is easy enough in the notification manager, but the fact that Win7 thinks my system is running slow is concerning when it clearly isn't.  If the auto-switch can be turned off, please tell us how.  If it can't tell us that so that we don't have to keep trying to solve this problem.

    t

    Friday, March 23, 2012 5:06 AM
  • I don't see how it's answered either, especially now we are nearly 2 1/2 years down the road from the originiating post made.  there is now very different hardware available, and more than up to date drivers installed, yet still this problem persists!!!

    And please, don't tell me I have low system resources too!!!  Intel i7 2600k (O/C'd @ 4.6 Ghz).  16gb Corsair Vengeance DDR3 RAM.  OGZ Vertex 3 120gb SSD 6Gb/s.  And, a lovely NVIDIA  TGT / Point of View 3gb GTX 590 Ultra Charged.  Whilst I realise that this hardware encompasses "speed stepping technology", and sometimes there may be a delay in relevant clock speeds ramping up to their max potential once specific software is started up or ran, this issue is down to Win 7, and nothing else!!!

    I cannot say for certain if I have solved this 100%, but have been testing for the last few days, and have got the "Nag Popup" telling me that my system is low on resources to cease, and have stopped windows auto changing my Aero Theme down to a basic theme!!!!

    All I have done is the following, and thus far it has worked!!!  I've tried dozens of ways to recreate the nag or auto aero switch, and can't get it to reproduce as yet, so might have found an answer :).........

    1)  Start Menu ->  "Search for programs and files"

    2)  Type in--->    sysdm.cpl   <---Press Enter, click on sysdm.cpl in the drop down list.

    3)  This will open your "Performance Options"  ->  Go to the "Advanced" tab.

    4)  Under the "Visual Effects" tab --->  you then have 4 options:-

    a) Let Windows choose what's best for my computer  (the default setting)

    b) Adjust for best appearance

    c) Adjust for best performance

    d)  Custom

    As this post and the actual issue itself both implies and proves;  Windows simply does NOT know "what's best" at times, and there are circumstances when it is best to take away automation from Windows, take control and choose your own options and settings.  IF none of the above work, or you're not happy with changing this setting and leaving it changed, you can always set it back to the default setting at a later time, no harm done.

    I've with "Custom" personally, (which when selected changes nothing in the list of available options that are checked in the relevant check boxes as set by default in Windows 7 anyway).  After several start up's and intensive system use, I can't recreate the problem :).  "In theory", this should stop Windows from changing any themes, or disabling the "Aero Theme" automatically.  Whether this turns out to be the case in practise over a longer time period, we shall soon find out!!

    Otherwise, after "googling" and searching few dozens and dozens of sources regarding this exact issue, I'm yet to find one answer that catergorically states how to turn this feature off.

    I'm sorry and with all due respect, but, "I just keep re-enabling my theme after the heavy work is done" isn't acceptable or good enough either!!

    Hope this helps.

    • Proposed as answer by DJJoeJoe Monday, April 9, 2012 8:07 AM
    Tuesday, April 3, 2012 9:49 PM
  • Hey deej710 pointing out that you should set the display settings manually like that seems like the thing to do in order to stop Windows from thinking it needs to step out of Aero etc. This issue has gotten very annoying since most modern games can tap out your CPU or GPU at some points and then windows thinks it needs to do the switch, this leads to the game actually freezing or usually just slowing down while the theme is changed, which is super annoying as you all can relate to.
    Monday, April 9, 2012 8:10 AM
  • This issue has not been resolved yet. I'm still getting this issue. I'm starting to wonder if Microsoft cares about this at all. While I'm playing a game and it switches to Basic, the game gets really laggy and it does not recover from this. Which means I have to exit the game and switch aero back on, then start the game again. This can take 15 minutes because Windows seems to have a real problem with switching themes. 15 Minutes is not much but I have to stop my game and if it's a multiplayer game when I'm doing real good in... Yea...

    Sunday, April 15, 2012 9:35 PM
  • I see that you are hardly unique to this issue, so I'm adding to the pile in hopes that Microsoft will finally fix this.

    IMHO, the DWM (Desktop Window Manager) has resource issues. It’s been my experience that the service, essential to the Aero-glass appearance on Windows 7, can easily be “maxed out” if there is too much pixel real estate in front of you.  My current environment uses two dedicated graphics adapters (AMD HD 5450 and AMD HD 6450) for three 1600x1200 monitors. And the Aero-glass appearance can only be maintained for a short time before the system automatically shifts to “Basic” appearance mode (and a variety of Event ID errors, 9024/9025/9026, are logged in the Application log). Restarting the DWM service re-enables the Aero-glass mode, but that will only last a short time.

    The Internet is populated with lots of complaints about DWM, all from people with lots of monitor space (very large monitor, multiple monitors, low-end or high-end graphic adapters). Many are running x64 and have lots of RAM, but the issue keeps popping up. The common thread that I see is that they all have very large total screen space in front of them.

    My wife’s machine, conversely, never has issues with Aero-glass. But she only has a single 1280x1024 monitor in front of her, and the critical resources used are much less.

    You can get an idea of the resources being exhausted through Microsoft’s SysInternal’s Process Explorer tool; a tool which provides far greater details about each Window's process and is available as a free download from technet.microsoft.com/en-us/sysinternals/bb896653. Once running this tool, select the dwm.exe process, right-click for Properties, then select the GPU Graph tab. You will see how close to maximum the resources are for this service.

    keywords: aero, graphic, efffects, glass, transparent, theme, DWM, visual, Event ID 9024 9025, 9026

    System Specs:
     HP Pavilion s5-1070t
     CPU: Intel i3-2100 (Sandybridge) 3.1GHz
     Motherboard: HP Proprietary (Pegatron 2AC2 “Carmel”), Socket 1155LGA, H61 Southbridge
     BIOS: AMI 7.16 (10/05/2011)
     Memory: 6GB (PC3-10700)
     Onboard Graphics: disabled
     PSU: 220w
     OS: Microsoft Windows 7 x64 (Enterprise Edition), SP1
     WEI: 5.1 (CPU: 7.1, RAM: 7.2, Graphics: 5.1, Gaming: 6.3, Hard Drive: 5.9)

     Graphics 1: AMD Radeon 6450 (512MB) OEM PCIe x16: one 1600x1200 DVI monitor attached
     Graphics 2: AMD Radeon 5450 (1024MB) PCIe x1: one 1600x1200 DVI monitor + one 1600x1200 displayPort monitor
     Graphics Driver: AMD Catalyst 12.4 for Windows 7 x64 (4/24/2012)

     HDD: Hitachi HDS721010CLA632 (1TB, 7200rpm, SATA 3Gb/s)
     LAN: onboard Realtek GBE (10/100/1000 Mbit/sec)
     WiFi: Ralink Technology (802.11b/g/n)


    Friday, May 11, 2012 6:36 PM
  • Greetings Linda,

    This is not an answered question -- I don't think anyone on this thread has been helped.

    Forget about drivers and whether a computer is capable to supporting Aero -- neither is not part of the question.

    We are looking for one thing: how to disable Windows 7 from choosing a different color scheme -- or rather, how to force Windows to use Aero under any circumstance. 

    Is there a solution or not? If not, when will one be released?

    Damion

    Thursday, August 16, 2012 10:53 PM
  • I have been looking for an answer as well, and today I finally found one. I went here http://www.mydigitallife.info/hack-to-force-enable-aero-in-windows-7/ and that gives you specific instructions on how to fix it. I hope this helped.
    Tuesday, August 21, 2012 10:41 PM
  • Hi all,

    To stop Win 7 from prompting to change from Aero to Basic:

    Since Windows doesn't understand how resources work, you need to keep it from checking them:

    In regedit go to:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM (create if not already existent)

    Set a new DWORD UseMachineCheck with a value of 0.

    This will keep Windows from checking if your computer "performs slowly" and thus attempting to disable Aero.



    Monday, August 25, 2014 9:21 AM
  • This is not an answer... This is a brush off. It is quite disappointing to see as the "official" Response..
    Sunday, September 21, 2014 5:50 PM
  • Good news everyone who is still using Windows7 like me!

    • Your Aero theme is being disabled by Windows?
    • Likely you're using multimonitor configuration?
    • You have lots of RAM and VRAM (2GB+) and want your computer to use full of its power?
    • You're receiving events 9024 in Event Viewer:
      "The Desktop Window Manager has been disabled automatically by the system due to too much system memory in use"?
    • You tried so many "solutions" like editing/adding registry keys and you didn't success?
    • You like to open many apps/tabs?

    Then the solution here is right for you and absolutely free*!

    After years of googling the answer, I get debugger in hands and in 30min it turned out, the solution is super-easy. It's as easy as 1-byte change!
    There is a process dwm.exe, and there're hard-coded limits in it (pseudocode):

    int CDwmAppHost::HandleSysmemUsageNotification( const MilMsgSysMemUsageData* pSysMemData ) {
    	dwSysMemDataSize = pSysMemData->size;
    	if ( dwSysMemDataSize > 30 ) {
    		DisableDueToSysmemLimit();
    	} else if ( dwSysMemDataSize > 25 ) {
    		ShowMemoryLimitNotification();
    	}
    }

    Big mistake of M$FT coders was that they hardcoded the values and didn't moved them into registry key.
    So one of possible workarounds is just replacing number '30' into something bigger!
    Disclaimer: Use at your own risk. I will not be liable for any losses, damages and nuclear wars because of the use of the advice.
    This tested on Win7 x64 SP1 with dwm.exe version 6.1.7600.16385. Highly likely it will work for other versions.

    Steps are:

    1. Minimize all of apps (otherwise it will be painfully laggy on step 2);
    2. In Task Manager->Services stop service UxSms. It will turn off Aero theme and unload dwm.exe from memory;
    3. Backup file c:\Windows\System32\dwm.exe just in case;
    4. Take ownership on c:\Windows\System32\dwm.exe (Right click --> Properties --> Security --> Advanced --> Owner --> Edit --> ...);
    5. Add yourself full permissions for this file (also in Security tab);
    6. Open it in HEX editor;
    7. Search for byte sequence "83 F8 1E" in the file. Be sure there is only one such sequence in the file;
    8. Change byte 1E into 7F (overwriting, not inserting). This will increase memory limit for DWM by scale of 4x.
      (Optionally if you're fluent in Assembly, you can NOP JA instruction next -- this will completely remove limit). Do not change the byte to values greater than 0x7F. It probably won't work;
    9. Start service UxSms.

    That's it! Since that your DWM likely won't be changing your theme anymore! Also, no needs for computer reboot!

    Cautions:

    1. Command `sfc /scannow` likely will reverse the changes.
    2. Some updates from M$FT can reverse the changes.

    *It's like a workaround, not a solution, though.

    P.S. After using fixed dwm.exe for 2 days I feel myself exciting! Now I have ~1500 tabs in Firefox and ~1500 tabs in Chrome and lots of other apps open -- and it works like a charm!

    • Proposed as answer by BulMax Monday, December 24, 2018 11:34 PM
    Monday, December 24, 2018 11:09 PM