locked
100 % CPU load in Explorer.Exe - SHLWAPI.dll!Ordinal629+0x161 RRS feed

  • Question

  • My laptop PC (Vista x86) regularly becomes very slow. When I check the CPU load via Process Explorer, I see that Explorer.exe takes 100% CPU time. It has spawned several threads which all have a high CPU load in SHLWAPI.dll!Ordinal629+0x161. My SHLWAPI.DLL version is 6.0.6000.16386.

    It might be related to searching via Start Menu - Start Search, since I often experience the slowdown after searching for a program. However, I'm not sure about the relation.

    Does anybody have an idea what could be causing this or how to solve the problem? Is there a newer version of SHLWAPI.DLL available that I could install? What functionality (which method) is located at Ordinal629+0x161?

    I hope someone can shine a light on this.

    Tuesday, February 20, 2007 11:07 AM

All replies

  • Hi
      
     I have exactly the same problem (with the same dll and version) with my windows vista version on my notebook.
    I don't no what to do. If i kill explorer.exe and restart it the CPU load stopps, but later it starts again.
    I don't know why and i haven't found something on the net.

    Does anybody know something about that problem?

    • Proposed as answer by vivek9935 Sunday, January 2, 2011 1:57 PM
    Tuesday, February 27, 2007 1:25 PM
  • Hello Mede,

     

    I haven't heard from anyone else on this issue yet, and haven't found a solution yet. However, I'm quite sure now that it's related to searching from the start menu search bar. I don't have the problem when I decide not to search from the search bar for a while, but often when I can't stand the temptation and start a search, the problem shows up immediately.

    Tuesday, February 27, 2007 5:47 PM
  • Yes

    I think I have found a solution, but I'm not sure about it.

    When you go to the settings of the starmenu (right click on the startmenu and properties) you can Adjust the startmenu by click on "adjust"(or so, i don't no about the word in english because my system is german).
    Then the 4th point (after run, pictures and computer) is "search files" (or "Dateien suchen" in german).
    There you have to choose one of three options. The first ist search in documents (userfiles), the second search in hole index and the third is do not search)

    When I set it to the third, "do not search in documents", i havent the problem with the CPU anymore, if I set it to "search in userfiles".

    Can you follow me?

    I think the problem is, that the search in you documents, doesn't stop when you close the startmenu. So Windows serach through you hole data and so it users 100% of the CPU after a litte time it stops and the system runs normaly.

    Do this Adjustments solves the Problem on your notebook too?

    • Proposed as answer by davidDWQ Tuesday, February 8, 2011 2:57 PM
    Tuesday, February 27, 2007 8:12 PM
  • Hello Mede,

    Thank you for the solution. I have changed the setting and haven't experienced the 100% CPU since than any more. So it seems that this really is a workaround!

    Regards, Beat Nideröst

    Wednesday, February 28, 2007 10:58 AM
  • Sorry to drag up a really old thread, but there is only this thread and another post on Channel9 concerning this issue. I've been experiencing 100% explorer.exe issues for a while and only tonight did I decide to track down what might have been happening. Monitoring Tools showed it was reading a large amount of data from C:\Users\[name] so it got me a little worried what it might have been doing. Luckily though after a few fruitless attempts at finding some other people with the same issue, I came upon this thread.

     

    The workaround listed a couple of posts ago does indeed stop this issue from occuring, and to be honest I never used the start menu to search for files in my user directory anyway, only for start menu items. Thanks very much.

     

    Adam Miles

    Thursday, October 18, 2007 11:15 PM
  • I've been experiencing the same thing around the same time you posted that message, so I figure we share the symptoms.

    It was right after a Windows Update following which Windows restarted itself in the middle of the night. Didn't install any new software. From then onwards, explorer persistently consumes as much CPU as it possibly can from the moment it's started until it's killed. I'm not sure what exactly is the cause (or I wouldn't be posting here) but I've noticed and observed a few things in the process:

    - Desktop and taskbar are pretty usable despite the 100% CPU usage. They respond to clicks, right-clicks and such. Lauching programs from Quick Launch works fine.

    - That is, until I click (or sometimes even point) on the Start Menu. THEN, everything ceases to respond (no hover, focus, etc.).

    - Once explorer.exe is killed and re-run from the Task Manager, it works again (still 100% CPU load though) as long as I don't touch the holy Start Menu.

    - Resource Monitor reports no udisk/memory utilization.

    - Even if the taskbar hangs, Desktop still responds just fine.

    - Any attempt to open a folder results in blank windows with responsive address bar and search bar and nothing else. This includes various control panels and My Computer (Win+E).

    Vista home premium OEM here. I've tried it with Search service disabled and enabled, no change. I already have searching in my home folder turned off. Tried running explorer with admin privilege, still no change. Tried leaving it for hours in hope that it will go away, no change. Tried isolating it from the network (I have mounted network drives), no change.

    I even manged to make some progress, by the way. Once I switched to classic Start Menu, it no longer hangs and the Start Menu even works. Still consumes 100% though.

    I'm lost. My notebook, also Vista and Windows updated, runs perfectly fine. I don't want to lose another day reinstalling Windows and setting up my work environment. Please share your thoughts if you can help.
    Monday, October 29, 2007 6:10 AM
  • THANKYOU MEDE, i had this problem for over a month, and you solved it. thanks man Smile (btw, one thing some people might want to look at is the audiodg.exe, it also uses a lot of CPU, so try reducing the sounds quality in your realtek HD sound manager)

    Sunday, November 4, 2007 2:04 PM
  • I had the same issue, but I went a little further in my research and discovered my problem. Since the problem was easily repeatable I ran ProcessExplorer as you did and discovered explorer.exe was using up 100% of one CPU core. So, I right clicked on explorer.exe and selected "properties". After that I went to the "threads" tab and found the runaway thread belonged to SHLWAPI.dll. I took note of the thread ID and ran ProcessMonitor with the filter set to only report on that thread. This lead me to discover a ridiculous amount of reads (144,000+) on the registry key HKLM\Software\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\. After looking through them I discovered that the culprit, in my case, was the McAfee Enterprise 8 managed suite which was scanning this key. I uninstalled the application, just installed the antivirus component and I have been unable to reproduce the problem.

     

    I doubt everyone who has this issue will find the same application is causing their problem, since I had the application installed on another Vista machine with no complaints. However, following the steps I took should assist you in getting closer to the root cause of your problem. Thanks to Mark Russinovich and the SysInternals team for providing such wonderful tools.

     

    Friday, January 4, 2008 4:01 AM
  • This post gave me some good ideas that I ended up using to solve the problem also.  Turned out it was a large, heavily nested zip file sitting in the root directory of my drive.  I blogged about it here helpdesk software blog

    Best regards,
    Rod
    Tuesday, January 29, 2008 3:12 AM
  • PROBLEM: CPU Usage reaches 100% after windows update (Windows Vista)

     

    a more precise Translation in English

     

    you have to

    1) right click the Start button (the little window logo on the right bottom)

    2) Click 'Properties'

    3) 'Start Menu' - 'Customize'

    4) scroll down and click 'Don't search for files' under 'Search Files' option

     

    It seems that this stupid permanent option of searching and rescanning the driver under explorer.exe consumes most of the CPU resources unless you got a super new dual core chip.

     

    Cheers!

     

    Wednesday, February 27, 2008 12:39 AM
  • I had a similar problem under Windows XP, but I would get 100% load only when the taskbar was displayed.  When hidden, usage would go to around 2%.  It could take up to 10 minutes for an application to load when the taskbar was displayed.  The SHLWAPI.dll Ordinal was 505 in this case.  I got rid of half the problem by right clicking on the C drive in Explorer and then selecting Properties.  In the Properties dialog box, I unchecked "Allow Indexing Service to index this disk for fast file searching", and then applied it to all subfolders and files.  After doing this, the load dropped to around 60% when the taskbar was displayed.

     

    I then turned off the taskbar magnifier and the load dropped to near 0%.  Looks like I'll only be using the magnifier when I really need it.

    Thursday, March 20, 2008 5:44 AM
  • How did you set Process Explorer to only report on SHLWAPI.dll!Ordinal629+0x161? I'm trying to isolate the culprit but can't figure out how to set to only report for one thread.

    Thanks.
    Thursday, March 27, 2008 1:59 PM
  • When you want to monitor the thread you need Process Monitor. You use Process Explorer to find which thread is causing the CPU spike. the steps to find the the thread are above in my previous post.

     

    Thursday, March 27, 2008 2:20 PM
  • Scott,

    I was trying to follow the directions you gave, and I guess I didn't word me question properly. I'm confused on the part where you talk about using Process Manager "with the filter set to only report on that thread". I have been using Process Manager, have also identified SHLWAPI.dll!Ordinal629+0x161 as the dll accessing explorer.exe, and now I'm trying to figure out which program is calling on SHLWAPI.dll.

    Thanks again.
    Thursday, March 27, 2008 8:17 PM
  • Scott,

    I just read your 2nd post, thanks for clearing that up. I just dl'd process monitor.

    Thank you!
    • Proposed as answer by Nick Danish Thursday, March 2, 2017 9:31 PM
    Thursday, March 27, 2008 8:25 PM
  • Explorer.exe is the process that is using that dll. What you have done is identified the thread that is causing your problem. Unfortunately, it will not tell you what application is hooking into explorer.exe and causing the problem. However, to gather more information you can open Process Monitor, not Process Explorer, and set the filter to only monitor that thread that is consuming the CPU. This will let you know what registry entires and files the thread is accessing and may give you a better idea of what is happening. In my case I found the CPU was spiking because of the reads to the registry, so I knew it must have been some application that would need to scan the registry. At that point I was pretty sure it was either the McAfee Enterprise product, or I had some spyware trying to grab information. After uninstalling the McAfee software I noticed my problem had gone away. Hope that helps.

    Thursday, March 27, 2008 8:30 PM
  • Hi,

     

    The issue comes from the way a ShortCut to a WebFolder is set in explorer to a WebDav Server.

    From XP to Vista, the way to set it changed.

    The correct way to create a Folder Shortcut is to create a CLSID_FolderShortcut
    object and to use its IShellLink and IPersistFiles interfaces to set it up.

     

    Opening Regmon helped me to found the "bad short cut" placed at the root of my computer (same level a Drive CSmile.

     

    The solution : Remove any Shortcut to any WebSite located right under the Computer in Explorer.

     

    Now problem gone and Vista working like a charm!

    Wednesday, April 23, 2008 1:08 PM

  • @nmoreau

    Can U explain "step-by-step" please, what shortcut U mean?

    Best, M.
    Sunday, May 4, 2008 11:45 AM
  • Thanks a lot, this helped to resolve my problem (it seems for now).

    I followed your steps in using Process Explorer & Process Monitor, and found out that in my case, a program called 'wpcumi.exe' was constantly opening and closing files, causing the 100% Explorer.exe processor load. Wpcumi appears to be related to parental control, although I could not find out what would go wrong by disabling it. So, using msconfig I disabled wpcumi.exe from starting, and voila... my computer is mine again, and no longer owned by some vague process.

    Note hat in my case, the 100% processor load would start happening after starting a program, notably Firefox (didn't try other applications).

    As I am using a laptop, this will hopefully save a lot of battery life as well!
    Saturday, June 14, 2008 3:31 PM
  • Mede, you are my hero.

    I have had this problem for two months and could not fix it.

    A few clicks and now it's sorted. Thanks a lot.

     

    Friday, October 17, 2008 10:24 AM
  • If I've learned anything from this thread it is to use Process Explorer to spot why explorer.exe is using a lot of resources. From all the posts it seems like it could be an array of items depending on your system configuration.

    I have an Intel quad-core Viste 64-bit Home Premium and the performance monitor showed one fo the CPUs was taxed at almost 100% all the time. Thankfully it did not affect performance terribly with the other three cores running at < 5%.

    For me, the culprit was the Parental Notification process. After killing that my CPU dropped to near 0% immediately. Go figure.

    Oh well. All in the day in the life of Vista I suppose. My biggest gripe is the "improved" search indexing feature which is meant to improve search speeds seems to cause more problems than it fixes. I think I'll switch to Google Desktop Search and disable the Windows version.
    Friday, November 28, 2008 3:32 PM
  • Nmoreau,      (to attention of Microsoft Developers)

    Thank you, that is a very interesting point!
    Removing web page links from "Computer" brought CPU use by explorer.exe from 100% to around 30-50%.

    So it certainly needs attention by Microsoft to be solved.


    The other 30-50% seem to be related to sub-process "SHLWAPI.dll!PathIsRootW+0xcc" as I found out from Process Explorer. Which also needs some attention by Microsoft. If it is indexing, it should only be one big indexing session, to index all files; further indexing of only new or modified files in real time, which should not take much of processing time at all, therefore - something isn't right.

    For information, I have a Core 2 Due T9400 2,53Ghz processor, 4 GB Ram, Vista Ultimate 64 bit SP1 on a laptop.
    During initial 100% explorer.exe load, both cores were 100% loaded (however I still could use the computer without visual slowdowns, so I assume it was priority controlled load). The greatest inconvenience was coming from fans going on full power all the time and of course increased energy consumption, which matters on laptops.

    SviFi


    P.S. Funny that English spell check in this forum does not have word Microsoft in the default dictionary.
    Friday, January 2, 2009 10:40 AM
  • Please help people!!

    I've tried everything you have suggested above, but nothing!
    I don't know what has caused this, but these past few days explorer.exe has been haywire!
    Every time I start up my laptop, it constantly uses between 40 and 50% of my processor (between my 2 cores)!
    I have tried the Process Explorer & Process Monitor route, but nothing.
    I can see that in Process Explorer, the explorer.exe thread SHLWAPI.dll!Ordnial197+0x57 is causing this!
    I tried monitoring the thread in process monitor, but nothing shows! The only thing that explorer.exe is doing in Process Monitor is checking the disk space on my Harddisks!

    However, if I kill explorer.exe and run it again, the processor hogging stops!

    Please help people!

    What now???
    Sunday, February 8, 2009 10:13 PM
  • Hi guys,
    I have the same problem as some of you. "Explorer.exe" is going nuts and using nearly 50% of the CPU.
    I've worked my way through the soultion Scott Rudy suggested, well almost anyway. Using Process Explorer I've tracked down Thread ID 3744 as the one that is causing this. And just like "Part.In" I've narrowed it down to "SHLWAPI.dll!Ordinal197+0x57".
    After this I've filtered Process Monitor to show just the thread 4733. Here's were I'm in a dead end.
    Process Monitor shows lots and lots of paths related to this thread, but how do I see which registry key is reading it in an ridiculuos amount like Scott did? I've never used porcess monitor before this...
    I think I'm on to a way of fixing this once and for all, but only with your help I'm afraid. My computerskills are limited and since I'm from sweden so is my english. Makes it tough to read some forum threads some times.

    Please help me with the last steps of this . . . / kind regards Matt
    Tuesday, February 24, 2009 11:14 PM
  • It's me again...
    after my last reply I scrolled down through the paths shown in process monitor. I'm using Avast antivirus and that showed up a lot in the list. So I disconnected the laptop from internet and uninstalled Avast and voila' , explorer.exe was back to it's normal values ( 0 -2%). Since I need a anti-virus-thingee I reinstalled Avast and it works fine now. Don't know if this is a sustainable solution to my problem but at least it's a way around it, hopefully for quite a while. I think I'm gonna try another anti-virus program to see if there's any difference in the long term outcome..

    If you have any hints on something I can do and change in the setup with Avast please let me know...

    Thanks a million to you Scott, your way have helped me so much in this matter. I've spent hours on the phone with HP's customers support. . . every time with the same suggestion, reboot/reinstall  the computer to the factory settings.

    This calls to celebrate with a cold beer
    Cheers
    Tuesday, February 24, 2009 11:57 PM
  • Oh ____!!!
    it's still a mess...
    "SHLWAPI.dll!Ordinal197+0x57" is still using up half the CPU...

    Changed from Avast to Nod32 with no improvement. . . seems that a bunch of programs are reading this, or whatever it does...

    Googled "SHLWAPI.dll!Ordinal197+0x57" but with no progress.. what does it do and why are so many softwares "after it"..?

    HELP!!!
    Wednesday, February 25, 2009 5:00 PM
  • Copying Part.in words ....  I've tried everything you have suggested above, but nothing!

    Finally, I managed to find the root cause !

    In my case, it was the Digital Persona fingerprint logon assistant, but it doesn't matter, it may be a different program causing the same problem in your case.

    Here is what I did:

    Open CMD, run Regedt32, and select HKLM>Software>Microsoft>Windows>CurrentVersion>Run.
    I opened Task manager and killed each one of those programs listed there, until I saw the CPU (and explorer.exe) usage going really down... from 48% to 6%.
    I exported the registry (just in case!) and basically removed the entry ...
    Problem solved!

    It is a temporary fix, until I find the problem within Digital Persona and put it back in.

    I hope this helps.

    • Proposed as answer by prenzo Thursday, March 19, 2009 1:27 PM
    Friday, March 13, 2009 9:54 PM
  • I finally managed to have Digital Persona working without affecting explorer.exe.

    I just moved to the end of the list on HKLM>Software>Microsoft>Windows>CurrentVersion>Run.

    As the list of software to be loaded after login flows an alphabetic order, I just deleted the original entry and added another one starting with "z" in the name of the reg, so it is now the last software to be loaded during login.
    I think the root cause was related to Digital Persona being loaded at the same time as some other software (maybe the antivirus) that was not ready, causing a dead lock of some file or DLL. Simply by changing the order of the files to be loaded in the login, gave the "other software" more time to became ready and solved the problem.

    As I mentioned before, in my case it was the Digital Persona software, but it doesn't really matter, it may be a different program causing the same type of problem in your case.

    Stupid problems sometimes require stupid solutions.

    Thursday, March 19, 2009 1:45 PM
  • Prenzo, I owe you one...
    I followed the steps in your solution and just like in your case Digital Persona was the cause of the problem.

    I've struggled with this for a very long time, spent hours and hours on the phone with HP customer support. . . And finnaly with your help my computer runs smoothly.

    Thanks a lot / kind regards Matt
    • Proposed as answer by draak13 Tuesday, April 14, 2009 10:40 PM
    Monday, March 23, 2009 5:40 PM
  • I had a similar problem where explorer is taking an entire core. I'm dubious that you have the same problem, but I just want to put this out there.

    When I expand 'My computer' in the left hand side of the window (the folder view, I believe it's called), it of course displays all of my disk drives and network drives. However, I notice that explorer (at least in my case) only pegs one core at 100% while: 1) I have focus put on explorer.exe, and 2) The 'my computer' in folder view is expanded. On closer inspection of the folder view after expanding 'my computer', I noticed that I actually had one extra little thing sticking around, that wasn't a local disk drive, and wasn't a network drive. It was labeled, 'My websites on MSN.' Right clicking on it and going into properties gave a minimum of information. Deleting it instantly solved the problem.

    -Ryan
    Tuesday, April 14, 2009 10:48 PM
  • How do you uninstall Internet Explorer 8. I've had all kinds of problems since I downloaded it.
    Friday, May 1, 2009 10:45 PM
  • Hello, now it got me. CPU always at 100%. Downloaded ProcessExplorer and ProcessMonitor. My problem is that i can't set the filter, because the programm crashs before, do to extrem ram use (1.6 GB). What can i do? Thanx. (Working with Vista, and have the problem since the last Windows Update).
    Wednesday, June 17, 2009 8:08 AM
  • I just wanted to comment that the solution of "Dont Search for Files" solved my problem as well.  I had been plauged with EXPLORER eating up more than half of my CPU resources for the last couple weeks.  I rarely use my laptop, so I am not sure which update did it, but its working fine now, and oddly, I can still search for stuff on my computer! :)

    -Mike
    Thursday, June 18, 2009 6:35 PM
  • Alternative fix.

    Seems that the corrupted data is connected to the user profile being used.

    Solution:  Create a new user profile and move all the data to the new profile and test it.

    For a non-domain computer simply create a new user and add them as an administrator and transfer all files and settings from the old damaged profile.  Then move the account back to user status.

    System on a Domain: Place an x in front of the old profile name from a different Administrator log-on.

    Log back in with your domain credentials and create the basic account folder.

    Log in as an administrator and then copy everything back to the users account.  Then just the normal reset of printers, favorites and email is done.

    This solution has worked for for me and probably less problematic than altering the registry.

    Sunday, June 28, 2009 7:04 AM
  • hello again, in my case it was the programm bwin.exe. It seems it was trying to search for an update all the time. I deinstalled and reinstalled the programm and now my CPU is bakc to normal. After that the windows-updates could also be installed.

    Thanx again to Scott Rudy for introducing me to ProcessExplorer and ProcessMonitor, couldn't have done it without them. :-)
    Wednesday, July 1, 2009 1:51 PM
  • Hi Guys,

    I have a problem with my explorer.exe, it seems it takes much more time than normal to start up. here is the event:
    This application took longer than usual to start up, resulting in a performance degradation in the system startup process: 
         File Name : explorer.exe
         Friendly Name : Windows Explorer
         Version : 6.0.6000.16386 (vista_rtm.061101-2205)
         Total Time : 45239ms
         Degradation Time : 23076ms
         Incident Time (UTC) : 21/07/2009 8:51:02 AM

    Any of you has a solution to this? (or related issue: fast vista start up!!!)

    Thxxx


    Tuesday, July 21, 2009 10:02 AM
  • Our Houston Computer repair company recently solved this kind of problem in one machine, take a look at our blog for the resolution of this problem. You can click on this link ---> Computer Repair Blog   to see what we did to solve the problem of explorer.exe using 100% of the CPU in a Windows Vista machine. I know for sure you can do the same on a Windows XP machine. So good luck to you guys.
    Friday, August 14, 2009 3:45 PM
  • This process help me identify that I have a broken desktop icon referring to Revo Uninstaller. By looking at the thread I in ProcessMonitor I could see that explorer.exe was constantly trying to open that File link and hence taking up most of the CPU. By deleting that short cut and and than removing this uninstaller I was able to get this problem resolved.

    So ensure that you don't have broken desktop shortcuts.
    Sunday, August 30, 2009 1:49 PM
  • Thanks Mede for the fix and ppanggi for the translation. The search indexing option might as well be called "enable constant hdd led". The start menu indexing option definitely improves productivity, but the search files and bookmarks options are just drains on system resources. I would recommend Everything
     as an extremely fast & light local file search alternative to Google Desktop or Windows search. Note NTFS is required to index.
    Thursday, September 3, 2009 5:00 AM
  • I have the same problem. When opening folders explorer runs 100% cpu time and crashes.
    It seems that explorer tries to generate thumbnails out of everything and it seems to run into problems on folders or sub-folders that contain movie files.
    I came to the conclusion because it starts up movie codec’s each time I click on a folder that has a movie as item in it’s folder or any sub-folder.
     
    What seems to have solved my problem is disabling thumbnails like this
    Folder options ->  View ->  [check] Always show icons, never thumbnails
    since disabling the thumbnails it works perfectly.
     
    I’m not just saying some observation I work with software I debug software and write them myself.

    Please let me know if this works for you.


    • Proposed as answer by uhav2bkidding Wednesday, February 24, 2010 11:36 PM
    Monday, September 14, 2009 4:08 PM
  • I have a different CPU hogging problem, but I am especially grateful to Scott Rudy who brought up the idea of using Process Explorer and Process Monitor for diagnosing this CPU hogging problem.


    Sunday, November 1, 2009 4:51 AM
  • Hi

    I have Windows XP, and I was having that problem with SHLWAPI.dll and high cpu usage.
    The suggestions for process explorer and process monitor were very useful.
    Following the advice above, process monitor reported that there were thousands of attempts to access create files in my start menu folder, and attempts to perform registry operations related to the value {0AFACED1-E828-11D1-9187-B532F1E9575D}.
    When I deleted the expanding folder shortcuts in the start menu, the problems seemed to stop.
    (For example, on classic start menu, you can drag "My Computer" into the start menu, so that you can browse your computer as a series of cascading menus.  Deleting these worked for me.

    I just thought I'd post this here as another possible culprit.  

    Thanks for all your help!

    - Leon
    Monday, January 18, 2010 10:33 PM
  • I am thrilled to get this fixed.  I've been searching for an answer for this for a year.  It's been driving me crazy.  Simple solution.  Wish there was a way to use thumbnails at least in the pictures folders and files.  This is so idiotic that Microsoft can't fix this.
    • Proposed as answer by DJ Stealth Sunday, April 10, 2011 5:15 AM
    Wednesday, February 24, 2010 11:39 PM
  • I had similar 100% CPU issues running explorer on Vista  with a fairly new high powered laptop. I got very tired of watching the green progress bar load when I wanted to see the contents of a folder.

    Deleting the shortcuts to my

    Websites on MSN

    and my

    Documents in Office Live

     

    (right click - delete in explorer)

     

    has solved the problem entirely, my laoptop is like new again. : )

    • Proposed as answer by spaindc Wednesday, March 23, 2011 10:06 PM
    Friday, April 9, 2010 8:30 AM
  • Thank you so much, everyone! It works :) Someone said that it won`t make any problems if PC has dual core CPU,  I have Quad and it`s making that problem... ;)
    Friday, April 30, 2010 10:05 PM
  • Hallo evrybody, i have the same problem with explorer.exe, using a large amount of CPU Core, but especially when opening the exploring folders's window and selecting several folders to copy.. then untill i don't kill the process, the CPU rest busy at 100%.. so i wanted to follow your suggestion ;)) but i get lost somewhere.. I right clicked on explorer.exe and selected "properties" but i can't find any "threads" tab in there.. instead i found a "theads" tab in the task manager (under process) and i found the thread number 440 for explorer.exe, now how can i understand the belonging file to the runaway thread? can you also explain to me how to run the the Process Monitor with filters in a detailed way please?
    Thanks in advance,
    Fabio.
    Sunday, May 2, 2010 11:47 PM
  • Hallo evrybody, i have the same problem (and i have a dual core CPU) with explorer.exe, using a large amount of CPU Core, but especially when opening the exploring folders's window and selecting several folders to copy.. then untill i don't kill the process, the CPU rest busy at 100%.. so i wanted to follow the Scott Rudy's suggestion ;)) but i get lost somewhere.. I right clicked on explorer.exe and selected "properties" but i can't find any "threads" tab in there.. instead i found a "theads" tab in the task manager (under process) and i found the thread number 440 for explorer.exe, now how can i understand the belonging file to the runaway thread? can you also explain to me how to run the the Process Monitor with filters in a detailed way please?
    Thanks in advance,
    Fabio.
    Sunday, May 2, 2010 11:50 PM
  • Hello Everybody, I have searched a lot for the same and after all brainstorming , i've found out the solution if u have instaleed Klite codec pack or Any other codec pack than just uninstall it...it's the fastest & Final Solution

     

    Thanks... Reply if it works..

    Tuesday, May 25, 2010 10:53 AM
  • Hi Fabio,

    follow my guide here and make a xperf trace and open it:

    http://www.msfn.org/board/index.php?showtopic=140264


    best regards
    André


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, May 25, 2010 12:25 PM
  • Thank you for the advise on an issue that I was just think I had to grin and bare it. Hope it works
    Saturday, January 1, 2011 7:42 AM
  • Hi,

    please make a xperf trace [1] to diagnostic the high CPU usage. With the correct symbols you can see which function causes this error. Please upload the etl file to your SkyDrive [2] and post a link here.

    I'll take a look at it, maybe I can see more details.

    André

    [1] http://www.msfn.org/board/index.php?showtopic=140264
    [2] http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Proposed as answer by Andre.Ziegler Sunday, January 2, 2011 2:15 PM
    Sunday, January 2, 2011 2:14 PM
  • Hi,

    I am running windows vista home premium SP1 in my laptop. This problem started few weeks back when I started using MATLAB2010. My explorer.exe is constantly using 50%of CPU units thereby slowing down all other processes. Please Help!!

    Thanks!

    Friday, March 18, 2011 6:01 AM
  • give me the xperf trace.

    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Friday, March 18, 2011 2:44 PM
  • thanks g2sheds; that made it for me!

     

    It's incredible microsoft program crashing microsoft program.

    It makes me think of the internet joke with the error message popup saying "Virus detected: Windows.exe - delete?"

    Wednesday, March 23, 2011 10:08 PM
  • I have the same problem. When opening folders explorer runs 100% cpu time and crashes.
    It seems that explorer tries to generate thumbnails out of everything and it seems to run into problems on folders or sub-folders that contain movie files.
    I came to the conclusion because it starts up movie codec’s each time I click on a folder that has a movie as item in it’s folder or any sub-folder.
     
    What seems to have solved my problem is disabling thumbnails like this
    Folder options ->  View ->  [check] Always show icons, never thumbnails
    since disabling the thumbnails it works perfectly.
     
    I’m not just saying some observation I work with software I debug software and write them myself.

    Please let me know if this works for you.



    I applied this fix and it solved my problem!!  Thanks ShGj

    What seems to have solved my problem is disabling thumbnails like this
    Folder options -> View -> [check] Always show icons, never thumbnails
    since disabling the thumbnails it works perfectly.

     

    DJ Stealth  ;-)

    • Proposed as answer by DJ Stealth Sunday, April 10, 2011 5:15 AM
    Sunday, April 10, 2011 5:13 AM
  • Similar problem with explorer process using 50% cpu while making repeated calls to SHLWAPI.dll!Ordinal197+0x3c.

    Procmon showing that explorer.exe repeatedly doing operation 'NotifyChangeDirectory' on a file in the recycle bin, and getting a 'DeletePending' result every time.

    As soon as I emptied the recycle bin the CPU load dropped back to normal.

    Great tips from Scott Re. the Sysinternals tools. Many thanks for that.

    Wednesday, April 13, 2011 3:29 AM
  • I had the same problem; explorer.exe would generally run at 50% of the cpu capacity and often use as much as 95% making the computer unusable.

    After a lot of head scratching I realised explorer.exe would consume close to 100% of the cpu whenever I left or right clicked on a folder which had video files in it.

    Long story made short, removing the folder solved my problem.

    I had recently loaded Internet Download Manager (IDM) and used it to quickly loaded some video clips into the previously mentioned folder.  It appears some or all of the video clips I loaded were not “reconstructed” properly, simply, they were not complete and/or fractured.  Apparently, this can cause explorer.exe to get stuck in a kind of computer Chinese Finger Puzzle and essentially lock the machine up by using all the cpu capacity while trying to figure out what the fractured files are.

    Monday, April 18, 2011 9:28 AM
  • Go to My computers-> Tools-> Folder Option ->View tab.

    Click on 'Restore to Default' button and check.

    Regards,

    Patel


    Mahendra PATEL

    • Proposed as answer by djjonezz Tuesday, July 31, 2012 8:35 PM
    Thursday, May 10, 2012 12:28 PM
  • I have seen this a few times in the support environment I work in. It appears the the shlwapi.dll error is often times related to shortcut created on the desktop for Windows search that causes problems with Internet explorer and Office applications. By permanently deleting the Windows desktop search icon from the desktop I've seen this problem resolved 3 or 4 times now.

    Hope this helps because I racked my brain on this for a while on this as I'm sure others have.

    Dennis

    Tuesday, July 31, 2012 8:38 PM
  • I had this problem forever. Seemingly out of nowhere explorer.exe would start tying up CPU.  Even when things were not entirely out of control, my laptop has seemed slower than what I'd expect, and battery life shorter than expected for months.  I had a virus problem at one point and actually uninstalled everything, and re-imaged my laptop from the manufacturers disks.  The problem came back not long after.

    This thread, and specifically the Start menu, Properties, Customize, Search Files, 'Do not Search for files' option fixed my problem.  Not just the 100% CPU problem, all file navigation in Windows Explorer is significantly improved.  

    Thanks to everyone for posting here! And God Bless SysInternals and their tools.

     

    Friday, June 28, 2013 12:01 AM
  • Go to My computers-> Tools-> Folder Option ->View tab.

    Click on 'Restore to Default' button and check.

    Regards,

    Patel


    Mahendra PATEL

    Thanks, this solved my issue.

    Explorer.exe 100% CPU & Mem usage.

    Process Explorer shows SHLWAPI.dll the culprit

    Thursday, October 3, 2013 2:22 AM