locked
Windows 7 - only displays administrators on welcome screen RRS feed

  • Question


  • I have a Windows 7 PC with 2 user accounts. Both are administrators. When I remove one account from the local administrators group and reboot, the welcome screen then only displays one account which is part of the local admins group.

    In order to have the other account appear on the welcome screen it has to be a local admin.

    How can I get Windows 7 to display both accounts on the welcome screen, the standard user  and the local admin?

    Windows Version is W7Pro64SP1

    • Edited by Navishkar Monday, April 11, 2016 8:16 PM mm
    Monday, April 11, 2016 8:13 PM

Answers

  • Hello Navishkar,

    From this link (https://windowsforum.com/threads/some-users-displayed-on-welcome-screen-others-not-displayed.71279/), here is what worked for a couple of people with this issue:

    1. Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value to a 1.

    2. Log off and log in again. (You will have to type both the user name and password yourself. This is only temporary.)

    3. Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value back to a 0.

    4. Log off.

    All icons are back.

    • Marked as answer by Navishkar Monday, April 18, 2016 12:14 PM
    Monday, April 11, 2016 9:02 PM
  • Hi Navishkar,

     

    Based on your description, please follow the steps below to check the result.

     

    1.Press WinKey+R > type secpol.msc and press enter

    2.Navigate to Local policies -> Security options

    3.Find the entry "Interactive Logon: Do not display last user name" and make sure it is disabled.

     

     

    If the problem still persists, we may need to modify registry.

    Note: Please be careful while working in the registry. Make sure you create a backup of Registry before you proceed.

     

    Navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList]

     

    Right-click on “ProfileList” and click export to save the entire subtree in case something goes wrong.

    Find several subfolders or “keys” named something like “S-1-x-xx…”, open them one at the time

    Each should contain at least the three value-sets, “Flags”, “ProfileImagePath” and “State”, some will contain more

    Look at the end of ProfileImagePath for the name of the user represented by the key

    You will usually have one for each user on the system, and one for each of the three system entries ‘systemprofile’, ‘LocalService’ and ’NetworkService’

    Delete any key (i.e. the whole “S-1-x-xx” folder) that does not contain at least those three values. Also delete any empty key named default.

     

    For more information, please refer to the link:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-security/windows-7-welcome-screen-doesnt-display-user/64be1788-6b4d-43f4-b999-5ab85847e694

     

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Navishkar Monday, April 18, 2016 12:14 PM
    Tuesday, April 12, 2016 11:50 AM

All replies

  • Hello Navishkar,

    From this link (https://windowsforum.com/threads/some-users-displayed-on-welcome-screen-others-not-displayed.71279/), here is what worked for a couple of people with this issue:

    1. Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value to a 1.

    2. Log off and log in again. (You will have to type both the user name and password yourself. This is only temporary.)

    3. Set the [HKEY_LOCAL_MACHINE \Software \Microsoft \Windows \CurrentVersion \Policies \System]
    DontDisplayLastUserName value back to a 0.

    4. Log off.

    All icons are back.

    • Marked as answer by Navishkar Monday, April 18, 2016 12:14 PM
    Monday, April 11, 2016 9:02 PM
  • Hi Navishkar,

     

    Based on your description, please follow the steps below to check the result.

     

    1.Press WinKey+R > type secpol.msc and press enter

    2.Navigate to Local policies -> Security options

    3.Find the entry "Interactive Logon: Do not display last user name" and make sure it is disabled.

     

     

    If the problem still persists, we may need to modify registry.

    Note: Please be careful while working in the registry. Make sure you create a backup of Registry before you proceed.

     

    Navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList]

     

    Right-click on “ProfileList” and click export to save the entire subtree in case something goes wrong.

    Find several subfolders or “keys” named something like “S-1-x-xx…”, open them one at the time

    Each should contain at least the three value-sets, “Flags”, “ProfileImagePath” and “State”, some will contain more

    Look at the end of ProfileImagePath for the name of the user represented by the key

    You will usually have one for each user on the system, and one for each of the three system entries ‘systemprofile’, ‘LocalService’ and ’NetworkService’

    Delete any key (i.e. the whole “S-1-x-xx” folder) that does not contain at least those three values. Also delete any empty key named default.

     

    For more information, please refer to the link:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-security/windows-7-welcome-screen-doesnt-display-user/64be1788-6b4d-43f4-b999-5ab85847e694

     

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Navishkar Monday, April 18, 2016 12:14 PM
    Tuesday, April 12, 2016 11:50 AM
  • Thank you both for your suggestions. Much appreciated.
    Monday, April 18, 2016 12:14 PM