locked
Http 504 Error on WSS 3.0 After Server 64bit 2008 Upgrades On 10/30/2013 RRS feed

  • Question

  • Hello all, after some automatic updates made on our Server 2008 R2 64bit server which was running WSS 3.0 we get an HTTP 504 error on our SharePoint site. Central administration comes up just fine, but the site itself doesn't. I ran through some possible fixes. It looks as if the server got "stuck" on an SPUpdate job which failed. I disabled the timer for it, but the site still doesn't come up. I ran a repair on WSS 3.0, and reran the system configuration wizard, but it fails at SPSearch instance process needing to be manually restarted.

    I was going to upgrade the system to SharePoint 2010 Foundation. Should I still go ahead with this, or should I resolve this issue first, and then run the upgrade? I haven't seen anywhere that the updates that were installed that day (over 25 or more) would cause any SharePoint issue. But since that day we can't open our company SharePoint site.

    Any ideas???

    Monday, November 4, 2013 5:50 PM

All replies

  • Whats your farm setup? do you using the DNS alias for site? is this error for everybody? any thing in the ULS log or Application log?

    Http 504 error is basically  "Gateway timeout error" and this due to networking error somewhere from the client side to the server.Check your default gateway or proxy server that is configured for the client it can also be that DNS is acting up.

    On the client machine run the following 4 commands in this order to clear up DNS and its caches...

      ipconfig /flushdns

    nbtstat -R

    nbtstat -RR

    arp -d *

    alos check this one http://www.checkupdown.com/status/E504.html


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog


    Tuesday, November 5, 2013 3:57 AM
  • Did you ever resolve this? I have a 64bit Windows 2008 R2 server running WSS 3.0 with the same issues and cannot seem to resolve!
    Tuesday, May 27, 2014 3:37 PM
  • Sadly, no...I never resolved this. I searched everywhere for answers, but finally gave up. On a good note, my company finally decided to put their resources towards SharePoint 2013 Foundation and eventually SharePoint 2013. So this might be a blessing in disguise for you like it was for me.
    Wednesday, May 28, 2014 7:48 PM