none
Correlation ID errors on each link from FAST Search Administration RRS feed

  • Question

  • Finally my FAST Search under SharePoint 2010 seems works fine, but then i opened my FAST Query SSA: FAST Search Administration I cannot open any links there, such us 

    Managed properties,

    Crawled property categories,    

    Manage property extraction,

    Spell checking management
       

    I'm reviving the 

    Error 
    Unexpected error occurred while communicating with Administration Service 
    Troubleshoot issues with Microsoft SharePoint Foundation. 
    Correlation ID:  are different from link to link


    Please advise

    Wednesday, March 28, 2012 7:40 PM

All replies

  • Hi Lampar,

    I've ran into this several times. it's a permission issue on the databases.

    Check if the user who is running FAST services (sp_fastuser) has the necessary permissions for all of FAST SQL databases.

    Also check if sp_fastuser is also in the FASTSearchAdministrators group in the Active Directory.

    Afterwards try to access these menus with sp_fastuser (no any other user) and see if it's okay.

    Amir

    Thursday, March 29, 2012 6:18 AM
  • I check all security on FAST databases and I did log in as a fastuser and still have same issue.

    Any other ideas?

    Thursday, March 29, 2012 3:46 PM
  • This can also be hapening if your FAST admin group is not properly set up:

    Make sure that your local FAST administrators group contains the SP_fastuser.

    make sure that your web app indentity user is also added to the local fast administrators group on your FAST servers


    SharePoint MVP, Microsoft VTSP, http://www.arcovis.com

    Thursday, March 29, 2012 8:45 PM
  • To make it clear, Ensure that your central admin app pool account should have access to the FAST WCF Service. Add the Central Admin App pool account to FAST Admin Group in FAST Servers.

    Sriram S

    Monday, April 2, 2012 7:43 AM
  • Both accounts are in Fast Admin Group
    Monday, April 2, 2012 5:56 PM
  • I added the Central Admin pool account in Fast Admin group, but still getting same error

    Can you tell me where i Can find FAST WCF Service?


    Monday, April 2, 2012 5:58 PM
  • WCF Services are available  in FAST Servers.  Possible fixes helps you

    Scenario 1:

    When you access the Managed property section from Central administration, you may get this error.

    Resolution :

    Ensure  FASTAdmin and Central admin app pool account added to the FASTAdmin local group in FAST Servers.

    Scenario 2:

    When you access the FASTSearch Keywords or any other links from Webapplication, you may get this error.

    Resolution

    Ensure FAST Admin account and Webapplication app pool account are added to FASTAdmin local group account ot FASTSearckKeyword group.


    Sriram S

    Tuesday, April 3, 2012 9:37 AM
  • Sriram,

    I do not have or I simply do not see WCF service  on my FAST Server.

    for Scenario 1:

    When I access the Managed property section from Central administration, I got following error error.

    Error 
    Unexpected error occurred while communicating with Administration Service 
    Troubleshoot issues with Microsoft SharePoint Foundation. 
    Correlation ID: 2e1e71f3-a265-4d93-9a3b-486b1e2c5a15 
    Date and Time: 4/3/2012 3:10:09 PM 

    Both FASTAdmin and Central Admin app pools accounts are in FAST Admin group on the FAST Server

    for Scenario 2:

    When I access the FASTSearch Keywords I got

    Error 
    Unexpected error occurred while communicating with Administration Service 
    Troubleshoot issues with Microsoft SharePoint Foundation. 
    Correlation ID: 4ac3c1ae-78ae-466f-883a-dc2771e55ead 
    Date and Time: 4/3/2012 3:44:42 PM 

    Both FASTAdmin and Central Admin app pools accounts are in FAST Admin group on the FAST Server, but I do not have FASTSearckKeyword group.

    Any ideas?
    • Edited by Lampar71 Tuesday, April 3, 2012 7:48 PM
    Tuesday, April 3, 2012 7:45 PM
  • Please find my comments inline.

    I do not have or I simply do not see WCF service  on my FAST Server.

    [Sriram] : Are you sure?. Go to FAST Admin Server - > Start->Run->Inetmgr - Ensure that you have "FASTSearchAdminServices" website.

    Try one more - > Go to FAST Admin Server-> open FAST Powershell window -> Get-FASTSearchContentCollection -name sp

    I do not have or I simply do not see WCF service  on my FAST Server.

    for Scenario 1:

    When I access the Managed property section from Central administration, I got following error error.

    Error
    Unexpected error occurred while communicating with Administration Service
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 2e1e71f3-a265-4d93-9a3b-486b1e2c5a15
    Date and Time: 4/3/2012 3:10:09 PM

    Both FASTAdmin and Central Admin app pools accounts are in FAST Admin group on the FAST Server

    for Scenario 2:

    When I access the FASTSearch Keywords I got

    Error
    Unexpected error occurred while communicating with Administration Service
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 4ac3c1ae-78ae-466f-883a-dc2771e55ead
    Date and Time: 4/3/2012 3:44:42 PM

    Both FASTAdmin and Central Admin app pools accounts are in FAST Admin group on the FAST Server, but I do not have FASTSearckKeyword group.

    Any ideas?

    for Scenario 1:

    When I access the Managed property section from Central administration, I got following error error.

    Error
    Unexpected error occurred while communicating with Administration Service
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 2e1e71f3-a265-4d93-9a3b-486b1e2c5a15
    Date and Time: 4/3/2012 3:10:09 PM

    Both FASTAdmin and Central Admin app pools accounts are in FAST Admin group on the FAST Server

    for Scenario 2:

    When I access the FASTSearch Keywords I got

    Error
    Unexpected error occurred while communicating with Administration Service
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 4ac3c1ae-78ae-466f-883a-dc2771e55ead
    Date and Time: 4/3/2012 3:44:42 PM

    Both FASTAdmin and Central Admin app pools accounts are in FAST Admin group on the FAST Server, but I do not have FASTSearckKeyword group.

    [Sriram] : Here you should use web application account , not central admin app pool

    Any ideas?

    Sriram S

    Wednesday, April 4, 2012 9:13 AM
  • Hi Lampar,

    When you say that your Fast Search implementation seems to work, can you please elaborate that a bit?

    Is it a correct assumption that you can crawl and you get search results back and the only issues you have are the error messages you get when trying to click on the link you mentioned in the first post?

    Regards,

    Daniel

    Friday, April 6, 2012 10:05 PM
  • Hi Daniel,

    Yes, it'c correct, I can do crawl, I can do search. The only issue are these links from Central Administration.

    Friday, April 13, 2012 6:17 PM
  • Hi Siram

    [Sriram] : Are you sure?. Go to FAST Admin Server - > Start->Run->Inetmgr - Ensure that you have "FASTSearchAdminServices" website.

    I have FASTSearchAdminServices one secure and one not(http://localhost:13257/, https://localhost:13258/). Can browser both and both briging me to the same spot.

    [Sriram] : Try one more - > Go to FAST Admin Server-> open FAST Powershell window -> Get-FASTSearchContentCollection -name sp

    PS E:\FASTSearch\bin> Get-FASTSearchContentCollection -name sp

    Name          : sp
    Created       :
    Cleared       :
    LastInput     : 4/13/2012 12:56:24 AM
    DocumentCount : 49066
    Description   : Default collection for SharePoint content
    Pipeline      : Office14 (webcluster)

    [Sriram] : Here you should use web application account , not central admin app pool

    pool identity for CA is my farm admin

    pool identity for FASTSearchAdminPool my sql admin, tried before fastuser

    FASTSearchAdministrators group includes, my farm admin, sql admin, SP admin and fast user accounts

    Thanks 

    Friday, April 13, 2012 6:57 PM
  • Hi. did you manage to solve it?? I am having the same issue as you. I have tried out those solutions stated above but none work. And I look into database but all the access are there. Please advise if there is anymore solution available. Thanks.

    Lectes.

    Tuesday, October 23, 2012 4:17 AM
  • Same issue for me, I fixed most of it by installing certificates respectively in FAST and sharepoint, try following again this steps:

    technet.microsoft.com/en-us/library/ff381253.aspx

    Now I still have the same error message but only when I create a new managed property with checking the box "refinement property".

    I spent two days but still searching for resolution...


    • Edited by Robert Snate Monday, October 29, 2012 4:34 PM link
    Monday, October 29, 2012 4:25 PM
  • also same issue here with few steps to check :
    gavinmckay.wordpress.com/2010/09/13/microsoft-fast-search-administration-unexpected-error-occurred-while-communicating-with-administration-service/
    Monday, October 29, 2012 4:44 PM
  • Thanks! My account is not granted permission in the Query Connector, added in and all worked out well!

    Lectes.

    Wednesday, October 31, 2012 10:15 AM
  • I missed one database, and add this db on SQL server solved my issue
    Tuesday, December 4, 2012 4:45 PM