locked
Removing mailboxes doesn't remove from get-mailboxstatistics RRS feed

  • Question

  • I'm trying to do some maintenance on my exchange 2007 server.  I ran get-mailboxstatistics and noticed some old mailboxes still exists.

    I removed (deleted) these mailboxes.  I ran get-mailboxstatistics again and noticed these mailboxes are still there although they no longer exist in the console\ mailbox list. 

    I ran clean-mailboxdatabase on each database and ran get-mailboxstatistics again and these mailboxes are still there.

    How can I remove them from get-mailboxstatistics?


    ScottL

    Wednesday, May 9, 2012 9:07 PM

Answers

  • Hi you can remove it with Remove-Mailbox command.

    $Temp = Get-MailboxStatistics | Where{$_.DisplayName -eq “User Name”}

    Remove-Mailbox -Database ”DB Name” -StoreMailboxIdentity $Temp.MailboxGuid

    References: Remove-Mailbox

    Thanks

    • Marked as answer by sloeb Thursday, May 10, 2012 1:27 PM
    Wednesday, May 9, 2012 10:47 PM
  • This worked great.  Thank you!

    ScottL

    • Marked as answer by sloeb Thursday, May 10, 2012 1:27 PM
    Thursday, May 10, 2012 1:27 PM

All replies

  • Hi you can remove it with Remove-Mailbox command.

    $Temp = Get-MailboxStatistics | Where{$_.DisplayName -eq “User Name”}

    Remove-Mailbox -Database ”DB Name” -StoreMailboxIdentity $Temp.MailboxGuid

    References: Remove-Mailbox

    Thanks

    • Marked as answer by sloeb Thursday, May 10, 2012 1:27 PM
    Wednesday, May 9, 2012 10:47 PM
  • Hello,

    Restart SA services.

    Thanks,

    Simon

    Thursday, May 10, 2012 8:09 AM
  • This worked great.  Thank you!

    ScottL

    • Marked as answer by sloeb Thursday, May 10, 2012 1:27 PM
    Thursday, May 10, 2012 1:27 PM