locked
SteadyState blocking Internet Explorer Pop-ups RRS feed

  • Question

  • I installed Windows SteadyState 2.5 on a machine with Windows XP SP3 and Internet Explorer 6. So I created a user with a high level of restriction in SteadyState. Because it's a machine used as a kiosk, I'm running Internet Explorer on Windows startup with "-k" option. The problem is that the website accessed from the kiosk has several links that open pop-ups and these links don't work. When I log in as administrator pop-ups open normally. I tried disabling the pop-up blocker in Internet Explorer for the restricted user but it didn't work. Can anyone help me?
    Thursday, May 13, 2010 8:13 PM

Answers

  • Hi Rafael, have you tried turning off all restrictions under feature restrictions - Internet Explorer restrictions? You can temporarily disable them and see if this is related to Windows SteadyState.


    Sean Zhu - MSFT
    • Marked as answer by Sean Zhu - Thursday, May 20, 2010 3:16 AM
    Friday, May 14, 2010 6:16 AM

All replies

  • Hi Rafael, have you tried turning off all restrictions under feature restrictions - Internet Explorer restrictions? You can temporarily disable them and see if this is related to Windows SteadyState.


    Sean Zhu - MSFT
    • Marked as answer by Sean Zhu - Thursday, May 20, 2010 3:16 AM
    Friday, May 14, 2010 6:16 AM
  • Hi Sean. Sorry for the delay in responding. Thank you for your help. I turned off "Internet Explorer restrictions" and pop-ups started to work. Now I need to find what restriction is blocking pop-ups.

    Rafael

     

    Monday, May 24, 2010 9:23 PM
  • This doesn't seem like much of a reply. The question was how to have restrictions on and still allow popups. I'm having the same problem. Do you know if there is anyone who would know which setting would allow IE to be restricted and still allow popups?

    Thanks

    David

    Thursday, January 20, 2011 12:33 AM
  • I know this thread is a bit old but wanted to update for others looking for a solution as I just fixed this problem.  

    Pop-up blocker is one of those settings that really doesn't have it's own option in steady state but the changes made to pop-up blocker can be made permanent on a per-user basis by completing the steps below.

    1) Log in as administrator (or any other user that has permission to administer steady state)

    2) Open steady state 

    3)  Click on the profile to administer

    4) Un-check the "lock this profile" option on the "general" screen

    5) log out and choose "save changes and re-boot" when prompted

    6) log in as the user you want change pop-up blocker settings for

    7) change pop-up blocker settings (in my case I turned it off since we restrict websites anyway)

    8) log off the user you are changing

    9) Log back in as the steady state administrator as in step 1

    10) Follow steps 2-5 except re-check the "lock this profile" option.

    Thursday, March 29, 2012 9:24 PM