locked
how to resolve ssas 2005 file size 4GB limitations RRS feed

  • Question

  • Hi all,

    We are currently using SSAS 2005 on windows server 2003(64 bit), and our cube is based on weekly partitions; Now we've got a problem of restoring the analysis database, the restore file got corrupted and part of data is showing only "#value" because there is file more than 4GB.

    We are using MOLAP storage. I know this is fixed in SSAS 2008, but as of now, we still need to use SSAS 2005.

    Is there any design/process which we could follow so that our data file size can reduce? For example, we can change partition(but weekly is the most we can do, daily will be too many partitions), or we can change the design of dimension?

    Any inputs would be appreciate.

    Friday, October 19, 2012 12:54 AM

Answers

  • Hello Memostone,

       Some pointers

       1. Make sure to have neccesary attributes only in the dimension.

       2.  Set the AttributehierarchyEnabled = False and EncourageGrouping = False for the attributes needed only for reporting. You can consider changing the attributes which are needed for reporting alone to be converted into member properties rather than keeping them as attributes.

      3. You can also set the AttributeHierarchyoptimizedstate = No optimization . But this will not create indexes on the given attribute. But this may slow down the queries against this attribute.


    Best Regards Sorna

    • Proposed as answer by Elvis Long Tuesday, October 23, 2012 9:55 AM
    • Marked as answer by Elvis Long Monday, October 29, 2012 1:11 AM
    Friday, October 19, 2012 5:41 AM

All replies

  • Hello Memostone,

       Some pointers

       1. Make sure to have neccesary attributes only in the dimension.

       2.  Set the AttributehierarchyEnabled = False and EncourageGrouping = False for the attributes needed only for reporting. You can consider changing the attributes which are needed for reporting alone to be converted into member properties rather than keeping them as attributes.

      3. You can also set the AttributeHierarchyoptimizedstate = No optimization . But this will not create indexes on the given attribute. But this may slow down the queries against this attribute.


    Best Regards Sorna

    • Proposed as answer by Elvis Long Tuesday, October 23, 2012 9:55 AM
    • Marked as answer by Elvis Long Monday, October 29, 2012 1:11 AM
    Friday, October 19, 2012 5:41 AM
  • Hi,

    There is no cube max size limit of 4GB in SSAS 2005 and later. There is a string store limit of 4GB in SSAS 2005, SSAS 2008, SSAS 2008 R2. In SSAS 2012 you can allow a larger string store size with a server setting.

    BR

    Thomas Ivarsson

    Friday, October 19, 2012 1:43 PM
  • Thank you all for the inputs. We will try and see how it works. 
    Friday, October 19, 2012 3:02 PM