locked
Remote SQL DB Instance Connection error while deplyting the Standalone Primary Site RRS feed

  • Question

  • Hi 

    I am getting error as The RPC server is unavailable .(Exception from HRESULT:0x8000706BA) while adding the Remote SQL DB named instance. I am also attaching ConfigMgr Setup log  can you please advice..

    Windows Firewall is turned off on SCCM Primary Site server and SQL DB server.

    I am able to telnet over port 1433 of SQL DB server, Dynamic Port is not Configured  for SQL DB Named Instance its only on TCP 1433.


    Shailendra Dev

    Friday, February 6, 2015 5:17 PM

Answers

  • Hi,

    Please confirm the ports below are allowed.

    Site Server --> SQL Server

    During the installation of a site that will use a remote SQL Server to host the site database, you must open the following ports between the site server and the SQL Server:

    Server Message Block (SMB) TCP 445

    RPC Endpoint Mapper UDP TCP 135

    RPC TCP DYNAMIC (See note 6, Dynamic ports)

    Reference:https://technet.microsoft.com/en-us/library/hh427328.aspx#BKMK_CommunicationPorts


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Joyce L Monday, February 9, 2015 8:41 AM
    • Marked as answer by Shailendra Dev Monday, February 9, 2015 5:12 PM
    Monday, February 9, 2015 8:38 AM

All replies

  • Does your site server computer account have local administrator permissions on the remote SQL server? Also, do the user account you are using for the install and the site server computer account have sysadmin privileges on the remote database server?

    Review the SQL Server requirements here as well: https://technet.microsoft.com/en-us/library/gg682077.aspx#BKMK_SupConfigSQLSrvReq

    Check out the tips here as well: http://gerryhampsoncm.blogspot.com/2013/10/configmgr-sql-some-tips.html

    Jeff

    Friday, February 6, 2015 6:47 PM
  • yes the Computer and User account has added to local Administrators group of Site and DB server, also such user has Sysadmin rights of DB server..

    Shailendra Dev

    Friday, February 6, 2015 7:13 PM
  • Is the remote SQL Server a cluster? If so, the site server computer account needs to be in the local administrators group on all cluster nodes.

    The error you are seeing is a problem connecting to WMI on the remote machine.  That is either permissions or a problem with a firewall blocking the communication.

    Honestly, this is why, if you can, hosting SQL on the site server is better.

    http://blog.coretech.dk/kea/system-center-2012-configuration-manager-sql-recommendations/

    Jeff

    Friday, February 6, 2015 7:20 PM
  • I am not using the SQL Cluster, its only SQL named instance and the Ports 1433,135,80,445 is able to telnet.

    Also I have turn off the firewall .. can you please suggest how i can resolve this issue..

    RPC,WMI service is running..



    Shailendra Dev

    Saturday, February 7, 2015 2:18 PM
  • seems you have Wmi namespace error, check the port 135 is open?

    Sharad Singh | My blogs: SharadTech | Twitter: @SinghSharaad | | Please remember to click “Mark as Answer” on the post that helps you.This can be beneficial to other community members reading the thread.

    Saturday, February 7, 2015 7:04 PM
  • yes i am able to telnet over port TCP 135.. 

    Shailendra Dev

    Sunday, February 8, 2015 8:54 AM
  • Hi,

    Please confirm the ports below are allowed.

    Site Server --> SQL Server

    During the installation of a site that will use a remote SQL Server to host the site database, you must open the following ports between the site server and the SQL Server:

    Server Message Block (SMB) TCP 445

    RPC Endpoint Mapper UDP TCP 135

    RPC TCP DYNAMIC (See note 6, Dynamic ports)

    Reference:https://technet.microsoft.com/en-us/library/hh427328.aspx#BKMK_CommunicationPorts


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Joyce L Monday, February 9, 2015 8:41 AM
    • Marked as answer by Shailendra Dev Monday, February 9, 2015 5:12 PM
    Monday, February 9, 2015 8:38 AM