locked
Anonymous Access to Sharepoint 2007 RRS feed

  • Question

  • I have set anonymous access in Central Administration>Application Management> Authenticaiton Providers> Edit Authentication>Allow Anonymous and in Site Settings> Advanced Permissions> Settings>  Anonymous Access>Entire Web yet visitors are still required to log in to view the site.

    It was working and the site did a Windows update and anonymous access is no longer available.

    Any ideas?

    Thanks

    • Moved by Mike Walsh FIN Thursday, September 15, 2011 5:25 AM Why post to the Search forum? (From:SharePoint - Search (pre-SharePoint 2010))
    Wednesday, September 14, 2011 11:45 PM

Answers

  • Thanks for the response. As I said in the original post I have configured the Central Admin and also the site details. All have been set to allow access.

     

    However, it seems that the master page has been marked as draft. I changed this and all anonymous access has been restored.

    Again, thanks

    • Marked as answer by Garry42 Thursday, September 15, 2011 5:43 AM
    Thursday, September 15, 2011 5:43 AM

All replies

  • What do you mean by annonymous access is no longer available ? Can you check the settings in Central Admin and site collection advanced permissions again ?
    Steve Thomas
    Thursday, September 15, 2011 1:56 AM
  • Hi,

     

    I agree with Thomas.

     

    Firstly, please check anonymous access setting in Central Admin and site collection.

     

    Secondly, enable IIS log, then reproduce the issue, look into the log to find more information.

     

    The issue can occur if anonymous access is configured in IIS and the anonymous access account password is not same as the actual information stored in the local user database or in Active Directory. If this is the case, check out the following article:

     

    http://www.symantec.com/business/support/index?page=content&id=TECH104479

     

    Configure anonymous access (Office SharePoint Server)

    http://technet.microsoft.com/en-us/library/cc263363(office.12).aspx

     

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Regards, Rock Wang Microsoft Online Community Support
    Thursday, September 15, 2011 3:35 AM
  • Thanks for the response. As I said in the original post I have configured the Central Admin and also the site details. All have been set to allow access.

     

    However, it seems that the master page has been marked as draft. I changed this and all anonymous access has been restored.

    Again, thanks

    • Marked as answer by Garry42 Thursday, September 15, 2011 5:43 AM
    Thursday, September 15, 2011 5:43 AM